Cisco Support Community
Community Member

softphone directory

How do you get the softphone corporate directory to work. I tried everyhting I could find on cisco's site. Whenver i hit show, the creen just swithces to the phone, no errors, nothing. Its ccm3.3, softphone 1.3

Id appreciate any suggestions.


Re: softphone directory

Use this link, this is the one I used to get it working for me:


Community Member

Re: softphone directory

Thanks, it worked, i typoed it

Community Member

Re: softphone directory


Just have a look in the softphone admin guide : p3.3

Table 3-2 Configuring Directory Settings

Setting Description

Display Name Enter a name for the LDAP directory.

For example, SoftPhone-CM

Server Name Enter the name for the LDAP server.

For example,

Port Number Enter the port number used by the directory.

For example, 8404

Account name Enter the directory administrator distinguished name


For example, cn=directory manager,

Password Enter the directory administrator password.

Search Base Enter the base—or root—of the directory service in which

to search for names.

For example, ou=users,

Table 3-2 Configuring Directory Settings (continued)

Setting Description


Enjoy, Christian


Re: softphone directory


I didn't like the idea of having to put in the directory manager name/password so here is how I modified the above to use any valid user ID/password:

Account Name: cn=EnterAnyValidUserID,ou=users,

Password: (enter password of the user inserted above)

Search Base: ou=users,

Community Member

Re: softphone directory

You can use Annonymous login on the DC directory and no user/password is required.

Community Member

Re: softphone directory

I am having the same issues. The above solutions did not change the symptoms. I don't think I typo'd it because I checked and rechecked, and even copied and pasted from the document. I have setup the softphone previously a few months ago and don't remember having to do all of this to get the corporate directory to work, it just did. I tried to use the DC directory administrator tool on the CCM server but I don't know the username/pw so I assume the article pertains to me with pw being ciscocisco. Would this have any affect on my problem? Thanks

CreatePlease to create content