Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

SOLVED: CER shows Failed to retrieve SysOid of a device

Funny: Turns out that the SNMP string hadn't been updated, as we'd been assuming. The wildcard ranges were off, and we were being bitten. Makes sense now.

I've got a large number of unassociated phones that CER seems to be having trouble locating.

It's throwing a lot of "Failed to retrieve SysOid of a device XXXX" errors.

The obvious thing to check would be that the device is SNMP reachable- which it is. If we install snmpwalk on the CER server, I can "snmpwalk -c <community> <devicename> system" and get the following:

SNMPv2-MIB::sysDescr.0 = STRING: Cisco IOS Software, C3750E Software (C3750E-UNIVERSALK9-M), Version 12.2(37)SE, RELEASE SOFTWARE (fc2)

We're using non-public strings, and that's been updated in the CER.

Is there anything else I'd need to check?

Are there any prerequisites required to get it to respond properly- does CER maybe just not recognize this SysOID as a valid one?

New Member

Re: SOLVED: CER shows Failed to retrieve SysOid of a device

This issue can occur if there is a firewall or access control list (ACL) that blocks the simple network management protocol (SNMP) reachability. In order to resolve this issue, make sure SNMP is excluded in the ACLs as well as in the firewalls.

CreatePlease to create content