Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Some IP Phones not coming up after upgrade

I am getting this on some IP Phones after we just upgraded to 3.3.3sr4a from 3.1.5. The phone reads the following: 'Protocal Application Invalid" then resets and continues to loop with this. Moreso, this happened after we upgraded the phone code to the latest rev.

3 REPLIES
New Member

Re: Some IP Phones not coming up after upgrade

Neal:

Had the same issues on the last two installs that I have done. I ended up doing two things that seam to correct the issue. I set the test port on a switch to NOT trunk while forcing the port into the "Voice" vlan. I also used an external power brick. I have not had time to test which one thing is the answer or if a combination of two correc the issue. Once I had got the phone to register a new firm ware was downloaded that I looks to have not been able to download in the past. Keep in mind that this was only need to get past the problem one time. After that it works just fine every where.

I have to think it as something to do with a plain old 7960. None of my 7960G's have had with issue. Something to do with the firmware being signed?

Carl

New Member

Re: Some IP Phones not coming up after upgrade

I am getting the same thing. I have a TAC case open, should have a fix today. With my IP phones at the central site they are upgrading fine but the phones at remote offices are failing with the same error. I have tried adding option 150 on the native vlan DHCP server but this has not resolved the issue. It seems that once the phone has uploaded the application loader it is then picking up an IP address on the wrong subnet or not getting one at all and can't perform the upgrade. I will let you know when I have a fix.

Luke.

Cisco Employee

Re: Some IP Phones not coming up after upgrade

it appeared that you were hitting a known phone bug CSCed84163 - "Loader may fail - Application Invalid"

B>Symptom:

When a phone is upgrade to release 6.0(1.0), from a 5.0 release, the upgrade may fail to complete.

The Display will read "Application Invalid"

Conditions:

This may occur if

1) There is no option 150 Set on the DHCP server on the native VLAN

2) CDP on the Switch and Phone do not converge in a timely fashion.

Workaround:

Insure that if a DHCP server is configured on the native VLAN, that it's option 150

information points to a known good call manager.

Luis.

109
Views
0
Helpful
3
Replies
CreatePlease to create content