Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

SRST not registering all DN's on a phone + other issues

I have an installtion using SRST on a 2600 series router (sh ver below). The problem is 2 fold: First I have a 7960 that in normal operating mode shows line 6 as DN 3146, but in SRST mode it shows line 6 as 3135 (a number that was previously programmed for testing). I have removed the SRST config and reloaded the router but it still comes back as 3135 on line 6. Second issue: I have a 7940 that in normal operation has both line 1 and 2 configured, but in SRST mode only the primary line registers.

NOTE: these are the only two phones that are connected at this time.

Here is the sh ver and sh run outputs:

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600-IS-M), Version 12.2(11)T9, RELEASE SOFTWARE (fc1

)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2003 by cisco Systems, Inc.

Compiled Mon 23-Jun-03 15:43 by cmong

Image text-base: 0x8000809C, data-base: 0x81673E2C

ROM: System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)

****** uptime is 19 minutes

System returned to ROM by reload

System image file is "flash:c2600-is-mz.122-11.T9.bin"

cisco 2620 (MPC860) processor (revision 0x200) with 61440K/4096K bytes of memory

.

Processor board ID JAD05030IO3 (1543276632)

M860 processor: part number 0, mask 49

Bridging software.

X.25 software, Version 3.0.0.

1 FastEthernet/IEEE 802.3 interface(s)

1 Serial network interface(s)

2 Voice FXO interface(s)

32K bytes of non-volatile configuration memory.

16384K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

*********************************************

Building configuration...

Current configuration : 2018 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

ip subnet-zero

!

!

ip domain name ***********

ip host *******************

ip name-server ************

ip name-server ************

!

!

!

voice call carrier capacity active

!

!

!

!

!

!

!

!

!

ccm-manager fallback-mgcp

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server ***********

ccm-manager config

mta receive maximum-recipients 0

!

!

!

!

interface FastEthernet0/0

no ip address

no ip mroute-cache

speed 100

full-duplex

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address *********** 255.255.255.0

!

interface FastEthernet0/0.2

encapsulation dot1Q 2

ip address **.**.**.** 255.255.255.0

ip helper-address ************

ip helper-address ************

!

interface Serial0/0

no ip address

no ip mroute-cache

shutdown

!

!

ip classless

ip http server

!

!

!

call rsvp-sync

!

voice-port 1/0/0

timing hookflash-out 50

!

voice-port 1/0/1

!

mgcp

mgcp call-agent ********* 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

!

mgcp profile default

!

dial-peer cor custom

!

!

!

dial-peer voice 9991023 pots

application mgcpapp

port 1/0/0

!

dial-peer voice 9991123 pots

application mgcpapp

port 1/0/1

!

dial-peer voice 999100 pots

application mgcpapp

port 1/0/0

!

!

call-manager-fallback

ip source-address ********** port 2000

max-ephones 24

max-dn 48

default-destination 3146

access-code fxo 9

voicemail 6000

!

!

1 REPLY
Silver

Re: SRST not registering all DN's on a phone + other issues

This does seem like a weird issue. You are however runing a significantly old version of SRST. Can you upgrade to atleast SRST 2.1, (12.2.15T), if the bug is not resolved there either, then I would suggest opening a TAC case for it.

Taimoor

101
Views
0
Helpful
1
Replies
CreatePlease login to create content