Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

srst options on 1760

Hi

I'm looking for some advice on configuring srst 3.0 on a 1760. My preference would be to use MGCP when registered to the call manager but the ios version I'm using does not suppor the ccm-manager commands and that's causing me problems it think.

using the call app alternate command in my config (pasted below) everything seems to be working except that when the tcp connection to the call manager comes back the voice ports on the 1760 never re-register with the call manager. Am I missing something in the configuration? Or would it be best to make this an H.323 gateway until a subsequent ios release adds support for the ccm-manager commands?

Here's my config:

no voice hpi capture buffer

no voice hpi capture destination

!

!

mta receive maximum-recipients 0

!

!

class-map match-all VOIP-SIG_CM

match access-group name VOIP-SIG

class-map match-all VOIP-RTP_CM

match access-group name VOIP-RTP

!

!

policy-map QOS-Policy

class VOIP-RTP_CM

priority 1024

class VOIP-SIG_CM

bandwidth 64

class class-default

fair-queue

!

!

!

interface FastEthernet0/0

description LAN connection to Water Center

no ip address

speed auto

!

interface FastEthernet0/0.10

description Water Center Data VLAN

encapsulation dot1Q 10

ip address 192.168.10.1 255.255.255.0

ip pim sparse-mode

no cdp enable

!

interface FastEthernet0/0.11

description Water Center Voice VLAN

encapsulation dot1Q 11

ip address 192.168.11.1 255.255.255.0

ip pim sparse-mode

no cdp enable

!

interface Serial0/0

ip address 192.168.101.2 255.255.255.252

ip pim sparse-mode

service-policy output QOS-Policy

service-module t1 clock source internal

service-module t1 remote-alarm-enable

ip rtp header-compression passive

!

router eigrp 1

network 192.168.10.0

network 192.168.11.0

network 192.168.101.0

auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0/0

no ip http server

ip pim rp-address 192.168.1.1 override

!

!

!

ip access-list extended VOIP-RTP

permit ip any any dscp ef

permit ip any any precedence critical

ip access-list extended VOIP-SIG

permit tcp any 192.168.1.0 0.0.0.255 range 2000 2002

permit udp any 192.168.1.0 0.0.0.255 eq 2427

permit tcp any 192.168.1.0 0.0.0.255 eq 2428

permit tcp any 192.168.1.0 0.0.0.255 eq 1720

permit tcp any 192.168.1.0 0.0.0.255 range 11000 11999

!

!

!

call application alternate default

call rsvp-sync

!

voice-port 2/0

no vad

no comfort-noise

timeouts interdigit 3

!

voice-port 2/1

no vad

no comfort-noise

timeouts interdigit 3

!

mgcp

mgcp call-agent 192.168.1.3 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

!

mgcp profile default

!

dial-peer cor custom

!

!

!

dial-peer voice 5 voip

description Incoming calls during fallback

incoming called-number 9T

destination-pattern T

session target ipv4:192.168.1.3

dtmf-relay h245-alphanumeric

codec g711ulaw

ip qos dscp af43 signaling

no vad

!

dial-peer voice 6 pots

application mgcpapp

incoming called-number .

destination-pattern 9T

port 2/0

!

dial-peer voice 7 pots

application mgcpapp

incoming called-number .

destination-pattern 9T

port 2/1

!

!

call-manager-fallback

secondary-dialtone 9

max-conferences 2

ip source-address 192.168.11.1 port 2000

max-ephones 30

max-dn 50

transfer-pattern ....

default-destination 0926

call-forward busy 0926

call-forward noan 0926 timeout 15

moh music-on-hold.au

multicast moh 239.1.1.1 port 2000

Cisco Internetwork Operating System Software

IOS (tm) C1700 Software (C1700-SV8Y-M), Version 12.2(15)ZJ2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc2)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2003 by cisco Systems, Inc.

Compiled Fri 15-Aug-03 23:44 by hqluong

Image text-base: 0x80008120, data-base: 0x813BB0E8

ROM: System Bootstrap, Version 12.2(7r)XM2, RELEASE SOFTWARE (fc1)

ROM: C1700 Software (C1700-SV8Y-M), Version 12.2(15)ZJ2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc2)

WTR-1760-1 uptime is 54 minutes

System returned to ROM by reload

System restarted at 18:41:57 CDT Sun Sep 7 2003

System image file is "flash:c1700-sv8y-mz.122-15.ZJ2.bin"

cisco 1760 (MPC860P) processor (revision 0x300) with 58659K/6877K bytes of memory.

Processor board ID FOC07211X13 (1364844789), with hardware revision 0000

MPC860P processor: part number 5, mask 2

Bridging software.

X.25 software, Version 3.0.0.

1 FastEthernet/IEEE 802.3 interface(s)

1 Serial network interface(s)

2 Voice FXO interface(s)

WIC T1-DSU

32K bytes of non-volatile configuration memory.

32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

6 REPLIES
New Member

Re: srst options on 1760

I had a similar problem. Finally used Ic1700-sv8y-mz.122-13.ZH2 and was able to configure the router for MGCP (CCM commands), and run SRST.

Jeff

New Member

Re: srst options on 1760

Which version of SRST are you running with that IOS Image on the 1760?

I have the same problem but I can't find an IOS image that have the MGCP (CCM Commands) and SRST v3.0 for that specific router.

-Jose

New Member

Re: srst options on 1760

I had to open a TAC case for this. We found that c1700-sv8y7-mz.123-2.T1.bin did the trick. It has all the MGCP and SRST and CCM-MANAGER commands.

Re: srst options on 1760

Please note that this was SUPPOSE to be supported under 12.3(2)T but due to a bug on the c1760 platform, support for a number of things was left out (ip nat inside source, ccm-manager, and many others).

I worked with TAC, who coordinated with the Feature Navigator Team to update the FN site -- the indicated this change wouldn't take effect until this week. So for the time being, be aware if you need ccm-manager support under c1760 in 12.3T code you will need 12.3(2)T1 as you pointed out.

New Member

Re: srst options on 1760

Hi,

I have a similar sort of issue.

I have a 1760. Running BRI VIC's in it. Using Callmanager 3.3(3).

Would like to set it up as MGCP, cant see the support for the BRI vic's in callmanager though, seems to only supp analog's and e1 / t1 etc.

Main goals are multicast music on hold and SRST 3.0 for streaming the music locally if possible.

Can this be done if it is configured as a H323 gateway? Has anyone done this, got a sample config?

Cheers,

Tim.

New Member

Re: srst options on 1760

Hi,

Heres a snippet from a post by Tim Medley /Paul Harrison titled REMOTE SITE MOH SERVERS .

The config at the top of this post has it configured.

The call manager is configured to multicast MOH at a specific address, but the WAN is not configured to support multicasting, instead the SRST router is configured to multicast MOH to the same address and port as the call manager server so the phones/gateways are tricked into playing whatever they hear on that port.

This way a caller on hold consumes NO wan bandwidth!

It is a trick but a very clever one that works fine. Don't complain about it just use it!!!

Thanks Tim for highlighting this.

273
Views
0
Helpful
6
Replies