Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Blue

SRST Problem

I am having a problem with SRST. Here is what is happening. The WAN fails, phones and gateway go into SRST correctly and inbound/outbound calls work correctly. When the WAN comes back everything goes back to normal and all is good. Now, this is working correctly because the "incoming called-number ." command is under the mgcpapp dial-peers. Here is the problem, if the gateway is reset the mgcpapp dial-peers are re-added but obviously this time without the "incoming called-number ." command. So inbound calls continue to follow the other pots dial-peers and not the mgcpapp dial-peers. I can disable ccm-config but I am hoping there is a better way. I have not had this issue in the past with SRST and I have now tried two different versions of IOS to be safe with the same result. Thoughts? Config is below:

translation-rule 1

Rule 1 ^3726 6

dial-peer voice 14 voip

preference 1

application default

destination-pattern 3726...

translate-outgoing called 1

voice-class codec 1

session target ipv4:192.168.X.X

no vad

!

dial-peer voice 999001 pots

application mgcpapp

incoming called-number .

port 0/0:1

!

dial-peer voice 9 pots

description 7-Digit - SRST

application default

destination-pattern 9[2-9]......

port 0/0:1

forward-digits 7

!

dial-peer voice 91 pots

description 10-Digit - SRST

application default

destination-pattern 91[2-9].........

port 0/0:1

forward-digits 10

!

dial-peer voice 911 pots

description 911 - SRST

application default

destination-pattern 9911

port 0/0:1

forward-digits 3

!

!

call-manager-fallback

ip source-address 192.168.X.X port 2000

max-ephones 30

max-dn 60

keepalive 10

default-destination 6000

date-format dd-mm-yy

  • Other Collaboration Voice and Video Subjects
1 REPLY
Bronze

Re: SRST Problem

Did you manage to find a solution for this problem? To me it appears as a bug. I am not able find many matching bug in the bug toolkit though!. What versions of IOS did you use btw?

96
Views
0
Helpful
1
Replies
This widget could not be displayed.