Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Streaming audio to 7960 via service

Glad to see a forum about xml services.

I'm not a programmer by any means. I bought the Cisco Press Developing IP Phone Services book and I have the SDK release notes.

Here's what I am trying to do. I want to create a simple service on some 7960's that allows users to listen to a list of available MOH source files that are on the MOH Server.

Here's what I have:

<?xml version="1.0" encoding="UTF-8"?>

<CiscoIPPhoneMenu>

<Title>Music on Hold Samples</Title>

<MenuItem>

<Name>Thank You for Holding</Name>

<URL>RTPRx:216.54.229.170\Thankyou Holding 1.ULAW.wav</URL>

</MenuItem>

<MenuItem>

<Name>Big Band</Name>

<URL>RTPRx:216.54.229.170\TFTPPath\Big Band.ULAW.wav</URL>

</MenuItem>

<MenuItem>

<Name>Doh</Name>

<URL>Play:Doh.raw</URL>

</MenuItem>

<SoftKeyItem>

<Name>Stop</Name>

<URL>RTPRx:stop</URL>

<Position>1</Position>

</SoftKeyItem>

<SoftKeyItem>

<Name>Exit</Name>

<URL>SoftKey:Exit</URL>

<Position>2</Position>

</SoftKeyItem>

</CiscoIPPhoneMenu>

On the phone when I select the Music on Hold Samples from the services menu, I am presented with 3 menu items and 2 softkeys, all as expected.

When I select menu 1 Thank You for Holding, the mute and speaker buttons light up and the streaming icon appears at the bottom of the page, but there is no audio.

When I select menu 2 Big Band, I get the same thing.

When I select menu 3 Doh, I get a Host Not found error on screen.

The first two files are known good moh source files. The 3rd file is a known good ringer file.

I've been reviewing the IP Phones Services SDK Notes, and the section that covers URI's doesn't list very much information.

I suspect that since i'm not really running a streaming application per say (cisco ip voice media streaming app is running) that I may need to run something on my server to actually stream the file. Is there a way to grab the stream from the MOH server?

But the ringer file should play correctly in the 3rd selection, accourding to the Dev Notes, the Play URI plays a specified file thats on the tftp server. This part is only to test connectivity to the server, but I can't get it to work.

tim

Tim Medley, CCNP+Voice, CCDP, CWNA

Sr. Network Architect

VoIP Group

iReadyWorld

  • Other Collaboration Voice and Video Subjects
6 REPLIES
New Member

Re: Streaming audio to 7960 via service

I get almost the same results. I changed you DOH.raw to a Chime.raw and that now plays...

Also when I was running the RTP stream, I looked at the Phone settings and it is not receiving a stream...

Re: Streaming audio to 7960 via service

Hi,

In order to receive an RTP stream, you must listen on the port on wich the sender is sending...... rtprx::port.

I think that you need a sort of multicast audio-server, wich is sending on that port.....

I tried to do this with MOH, no success. If you enable Multicast, the MOH server didn't work at all....

good luck

Sascha

New Member

Re: Streaming audio to 7960 via service

So does any one know the MOH Server's Port number??? Then you could point to that server and port and get the MOH Server's Stream. I would still like to run additional streams on a server that is NOT a callmanager. If any one has any suggestions that would be great!

New Member

Re: Streaming audio to 7960 via service

You can program MoH Multicast in the CallManager to increment based upon either port number or IP address. I like to use the IP address setup, then each stream uses a separate IP address and the same port number 16384. Use this port number in your programs and you should be able to listen to the stream.

Better yet, use a E&M card in a router and a telephone analog adapter, create a multicast stream in the router and program your service to listen to this multicast stream. This is what I'll be trying to do.

Good Luck!

New Member

Re: Streaming audio to 7960 via service

Hi,

I am experienced the same problem, so it does not work in any two methods.

In your example, the IP 216.54.229.170 is the IP of the CallManager?

I tried to use the port 554 and 80 but I have not success.

I will be glad if anyone help me.

Thanks

Sakata

New Member

Re: Streaming audio to 7960 via service

I am having the same problem with the Play:f provided in the documentation. I get the host not found. I know that my tftp server is fuctioning and the ip phone shows the tftp address in the network settings.

I have tried adding different paths instead of simply Play:Sax1.raw, but without any luck.

334
Views
0
Helpful
6
Replies
This widget could not be displayed.