Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Stupid Question - How to do Lan & Call Manager - 1 beer for first answer

Hi

I've got the following configuration:

1 - Call Manager - IP Address - 10.10.30.2

1- Router to PSTN - 10.10.30.1

1- IP Phones - 10.10.30.XXX

Switch Cisco 3560G

AD Server - 10.10.30.3

Mail Server - 10.10.30.4

Desktop pc - 10.10.30.XXX

When I connect one ip phone + desktop, the phone do reboots and then stop working.

I think I'm doing the wrong configuration of the switch?

Which should be the configuration in terms of ip of servers & desktops, call manager and switch?

Thanks in advance

M

14 REPLIES
New Member

Re: Stupid Question - How to do Lan & Call Manager - 1 beer for

First you should get your voice and data into separate vlans.

For example here is a typical switchport config:

interface FastEthernet0/5

description Whatever

switchport access vlan 18

switchport mode access

switchport voice vlan 20

spanning-tree portfast

New Member

Re: Stupid Question - How to do Lan & Call Manager - 1 beer for

Thanks for your cooperation.

So my voice vlan that contains the call Manager, router and ip phones should be on the following net for example: 10.10.40.XXX

And the AD Server, DNS Server and the pcs should be on other net, for example:10.10.30.XXX.

Super Bronze

Re: Stupid Question - How to do Lan & Call Manager - 1 beer for

That's the idea - your data stuff will be in the normal VLAN, and the phones in another.

You will of course have to have DHCP running in the VVLAN - either a DHCP server set up with an interface and scope in that VLAN, or an ip-helper configured on a router interface on the VLAN pointed to a DHCP server with a scope set up.

The DHCP scope should have the TFTP option configured to allow the phone to find the CallManager as well.

Regards

Aaron

Please rate helpful posts.

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
New Member

Re: Stupid Question - How to do Lan & Call Manager - 1 beer for

Thanks for your cooperation.

Will it work without having DHCP running in the VVLAN?

I do perfer to not having DHCP running.

New Member

Re: Stupid Question - How to do Lan & Call Manager - 1 beer for

If you're not using a dhcp server that is serving up addresses and tftp server info, you will need to manually set ip info and tftp address on the phone.

New Member

Re: Stupid Question - How to do Lan & Call Manager - 1 beer for

Ok, I can live with that. No problem to me to set up manually the ip info and tftp address on every single phene.

One thing that I don't understand is who will route the voice vlan and data vlan, my switch 3560G is not a routing switch!

Thanks in advance for your cooperation.

MP

New Member

Re: Stupid Question - How to do Lan & Call Manager - 1 beer for

Hi

3560 is L3 switch and is able to route packets beetween vlans. Just add:

int vlan 18

ip address 10.10.40.X 255.255.255.0

!

int vlan 20

ip address 10.10.30.X 255.255.255.0

Regards

Wojtek

Re: Stupid Question - How to do Lan & Call Manager - 1 beer for

Hi,

You can have phones and pc's on the same subnet,

but you need to use dot1p tagging;

int fa0/2

mls qos trust cos

switchport voice vlan dot1p

HTH

Sascha

New Member

Re: Stupid Question - How to do Lan & Call Manager - 1 beer for

Hi Sascha

Thanks for your cooperation.

With your configuration, I can then only have one subnet for all the ip phones, call manager and pcs!

I prefer your configuration.

So the configuration ex fa0/2 can then be applied to all ports of the switch, no matter which device is connect to that port(V Router, Call Manager, po's, printers)?

Kind Regards

MP

Re: Stupid Question - How to do Lan & Call Manager - 1 beer for

Hi,

Although this will work, it is always better practice to have 2 different subnets for voice and data though!

Only use this if you have no other choice for whatever reason, or if you are just testing in a lab or so.

New Member

Re: Stupid Question - How to do Lan & Call Manager - 1 beer for

Hi

I tested your configuration (ip phone + pc) and the ip phone didn't reboot and the pc also ok.

But all voice comunications throught that phone, had an strange behaivor, if the called party stopped speaking I did not hear nothing, that was something anoying because I didn't know if it hanged up or not.

How can we solve this issue?

Thanks for your cooperation

MP

Re: Stupid Question - How to do Lan & Call Manager - 1 beer for

Hi,

are you running h323 or mgcp on your gateway?

if it is h323, you might need to play with progress indicators.

also do a h323 bin on the interface on the voicegateway

is ipphone-ipphone ok?

New Member

Re: Stupid Question - How to do Lan & Call Manager - 1 beer for

Hi,

Yes we are running h323

This is our configuration

dial-peer voice 500 pots

destination-pattern .........

progress_ind alert enable 8

progress_ind progress enable 8

progress_ind connect enable 8

direct-inward-dial

port 0/2/0:15

forward-digits all

Do not understand what is h323 bin on the the voicegateway neither what is ipphone-iphone?

Thank you

MP

Super Bronze

Re: Stupid Question - How to do Lan & Call Manager - 1 beer for

Do you get the silence problem from IP-phone to IP-phone, or just when going through the H323 gateway?

If you get it only on the H323 gateway calls, try adding 'no vad' to the dial-peers that point to your CallManager servers.

Aaron

please rate helpful posts...

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
152
Views
35
Helpful
14
Replies
CreatePlease to create content