Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Switch Config Example

Hi,

We are looking to deploy 12 IP handsets and i`m really looking for a basic switch config to use for deployment??

Anyone know of any?

  • Other Collaboration Voice and Video Subjects
9 REPLIES
New Member

Re: Switch Config Example

Will you be using CME?

Switch config would look like this for the ports:-

! for CME router

interface FastEthernet0/1

switchport access vlan 2

switchport trunk native vlan 2

switchport mode access

spanning-tree portfast

! for infrastructure.

interface FastEthernet0/x

switchport access vlan 3

switchport trunk encapsulation dot1q

switchport trunk native vlan 3

switchport trunk allowed vlan 2,3

switchport mode dynamic desirable

switchport voice vlan 2

mls qos trust device cisco-phone

mls qos trust dscp

spanning-tree portfast

ip routing

>>>>>>>>>>>>>>>>>

Config VLAN 1,2,3 w/ an ip's.

VLAN 2 is voice

VLAN 3 is data.

That is all that is needed - maybe a .little complex, but there you go.

New Member

Re: Switch Config Example

Yep - CME - although i don`t know much about it!

For the Router we had:

interface FastEthernet0/X

switchport mode trunk

mls qos trust cos

auto qos voip trust

For the IP Phones we had:

interface FastEthernet0/15

switchport mode trunk

switchport voice vlan 2

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast

data VLAN 1

voice VLAN 3

Is auto Qos bad on the switches?

New Member

Re: Switch Config Example

I do not think that there is a need for "auto qos voip cisco-phone" since you already have "mls qos trust device cisco-phone" and "mls qos trust cos".

I am curios. Is your router talking to the switch using that interface that you configured?

New Member

Re: Switch Config Example

I`ll take the auto-qos out - wasn`t comfortble with it in!

That was the plan - the router will connect to the switch (with the first configure on the earlier note) and then that switch is connected to sme non-cisco gear. The Ip phone and PC`s wil hang off the Cisco switch only (using the seond config)

Any assistance would be great - as this is our first bash at it!

New Member

Re: Switch Config Example

Ok.

Here is a config. You will need to config sub-interfaces on the router. For data on,config is below to.

*Router*

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

encapsulation dot1Q 3 native

ip address 192.168.2.1 255.255.255.0

no snmp trap link-status

no cdp enable

!

interface FastEthernet0/0.2

encapsulation dot1Q 2

ip address 10.1.0.1 255.255.0.0

no snmp trap link-status

no cdp enable

*switch*

interface FastEthernet0/1

switchport access vlan 3

switchport trunk native vlan 3

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/2

switchport access vlan 3

switchport trunk native vlan 3

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/x+

switchport access vlan 3

switchport trunk encapsulation dot1q

switchport trunk native vlan 3

switchport trunk allowed vlan 2,3

switchport mode dynamic desirable

switchport voice vlan 2

mls qos trust device cisco-phone

mls qos trust dscp

spanning-tree portfast

!

interface Vlan1

ip address 10.20.0.12 255.255.255.0

!

interface Vlan2

ip address 10.0.0.1 255.255.0.0

!

interface Vlan3

ip address 192.168.1.38 255.255.255.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.18

New Member

Re: Switch Config Example

Thanks.

My data Vlan is 1

My voice Vlan is 2

My video conference Vlan is 3

So, my voice ports will look like this

interface FastEthernet0/X

switchport access vlan 1

switchport trunk encapsulation dot1q

switchport trunk native vlan 1

switchport trunk allowed 1,2

switchport mode dynamic desirable

switchport voice vlan 2

mls qos trust device cisco-phone

mls qos trust dscp

spanning-tree portfast

And, my link to the router will look like this:

interface FastEthernet0/2

switchport access vlan 2

switchport trunk native vlan 2

switchport mode access

spanning-tree portfast

And, my link to the video conferencing would look like:

interface FastEthernet0/1

switchport access vlan 1

switchport trunk encapsulation dot1q

switchport trunk native vlan 1

switchport trunk allowed 1,3

switchport mode dynamic desirable

switchport voice vlan 3

mls qos trust dscp

spanning-tree portfast

Do i treat the Video Conferencing config the same as a phone!

Thanks for the help by the way!

New Member

Re: Switch Config Example

First thing, let vlan1 just be for cisco traffic.

So you should have 3 vlans define. 2,3 and 4.

Can you describe what you want to do?

Is the router only for voice?

New Member

Re: Switch Config Example

Okay - sorry about the confusion. Please bear with me.

I am trying to do the following.

I have a c3662 router and a Cisco Cat switch.

I want to run 12 IP phones with PC`s off the back of them. I also have a video conference on a different VLAN at present which i would like to run off the switch at the moment.

I need to know the config for the port that the router is connected to, and also a config for the IP phones. Plus, i would like to get the config for the video conferencing unit.

This switch is then daisy chained to a 3Com old switch.

There are three different subnets for the data, IP phones and video conferencing. I would like the PC`s attached to the phones to take an IP address from the local server and not the router - i have setup DHCP on the router for the phones.

So, to summarise, i effectively want to connect a cisco cat switch to a router, and also another 3com switch. Off the cisco i want to connect a Video conferencing unit (in it`s own VLAN). I also want 12 Ip phones (to get their IP`s from the router), attached to the phones are PC`s who will get their lease from the server!

Hope that makes sense - sorry about the waffle!

New Member

Re: Switch Config Example

I am also new to this too.

So configure the require ports for the video vlan. THe config I sent you will work for the phones.

If the router is only use for voice, then that router can hand of the config I sent you for attaching only voice devices.

When you specify option 150, that will assign and ip to the phones using vlan2, since the phones by default want to use vlan 2.

ip dhcp excluded-address 10.1.0.1 10.1.0.10

ip dhcp pool ITS

network 10.1.0.0 255.255.0.0

option 150 ip 10.0.0.10

default-router 10.1.0.1

Since data is vlan 3 , it is native >> untagged traffic will be send on the switch using vlan 3. so you network with by default use vlan 3. Plug anything in those ports and you sits on the data vlan.

interface FastEthernet0/1

switchport access vlan 3

switchport trunk encapsulation dot1q

switchport trunk native vlan 3

switchport trunk allowed vlan 2,3

switchport mode dynamic desirable

switchport voice vlan 2

mls qos trust device cisco-phone

mls qos trust dscp

spanning-tree portfast

Please remember that you must specify the type of encapsulation, which should be 802.1q to talk to non cisco devices. Will you be swapping out the 3com?

You can put video on vlan 4. But remember that this must also be the same on the 3com switch.

I am not sure what the qos config would look like for video, but I believe that you can trust voip on that ports terminating the video.

Now if the 3com only handle video, you can trust that device.

mls qos trust [cos | device cisco-phone | dscp | ip-precedence]

Please research on cisco site how video configuration on a switch might look like.

Or what you can do, attach a few video device and enable auto qos discover to see how it classify traffic.

"sh auto qos" to show what the new configuration looks like after you apply the command.

Please review info on video http://www.cisco.com/en/US/partner/tech/tk543/tk757/technologies_tech_note09186a0080094968.shtml

So " mls qos trust dscp" should work on the interface to the device or switch carrying video traffic.

484
Views
0
Helpful
9
Replies
This widget could not be displayed.