Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Switch config for Voice

I have the following switch config for IP Phone

interface FastEthernet3/2

switchport access vlan 10

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10,20

switchport mode trunk

switchport voice vlan 20

int vlan 20

ip add a.b.c.d /16

ip helper-address a.b.c.d/16 "DCHP in dATA VLAN 10"

On the DHCP server, I have scopes for both Vlan 10 and Voice Vlan 20. The phones are getting an address from the dhcp servers in Vlan 10.

But the PC connected to the phone, cannot get a dhcp address.

This switch is connected to another switch that has the same vlan configuration. But I have not included the "ip helper address" under vlan 10 or 20.

Any ideas why the PC is not getting a DHCP address when connected to the phone.

2 REPLIES
New Member

Re: Switch config for Voice

switchport trunk native vlan 10

New Member

Re: Switch config for Voice

Thanks....that helped

101
Views
0
Helpful
2
Replies