Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Switch Port Configuration for Voice and Data - Best Practice

I need to find out what is the best practice to tipical switch port coniguration which connect to Cisco IP Phone and a PC.

I have the follwoing configuration configured:

interface FastEthernet1/0/12

switchport trunk encapsulation dot1q

switchport trunk native vlan 204

switchport trunk allowed vlan 204,205

switchport mode trunk

switchport voice vlan 205

spanning-tree portfast

What do I also need for QoS?

  • Other Collaboration Voice and Video Subjects
4 REPLIES
Cisco Employee

Re: Switch Port Configuration for Voice and Data - Best Practice

hello!

you should not have encap dot1q. That command will give you lot of issues. It is true that your port will behave like a dot1q trunk, but it is enough if you configure the voice vlan. so your configs should look like this:

interface FastEthernet1/0/12

switchport mode access

switchport voice vlan 205

switch access vlan blah

spanning-tree portfast

for QOS, you have to look at the following doc.. It is fairly straight forward:

http://www.cisco.com/en/US/products/hw/switches/ps646/products_configuration_guide_chapter09186a008014f36e.html

New Member

Re: Switch Port Configuration for Voice and Data - Best Practice

THX for the replay,

Can you be little more spacific on what kind of problem I will run into if I configure "encap dot1q"

Thnaks,

Cisco Employee

Re: Switch Port Configuration for Voice and Data - Best Practice

I have seen issues where you get an ip address in the data vlan or do not get an ip address at all..

hope that helps.

Re: Switch Port Configuration for Voice and Data - Best Practice

Hi,

You cannot just have a "tipical" switchport, it really depends on the type you use.

(i.e. 3550, 3560, 3750)

Some will need a trunk configured, some a access port with a voice vlan on it.

Autoqos will set the correct settings.

also have a look at the QOS and CCM SRND's !

http://www.cisco.com/go/srnd/

490
Views
0
Helpful
4
Replies
This widget could not be displayed.