Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

TAPS not working - Script not playing

I have

CM 4.1.3 sr3

CRA 3.5.3

I can install the script OK and services are all running. When I dial the route point the call is connected but there is just silent for about two seconds and then call hangs up. Is this a bug or have I overlook something? Call is definitely hitting the CRA server as seen in trace file.

Thanks in advance.

5 REPLIES
Green

Re: TAPS not working - Script not playing

Are you following this procedure?

http://www.cisco.com/warp/customer/788/AVVID/taps.html

TAPS service and JTAPI services are fine?

New Member

Re: TAPS not working - Script not playing

Yes I follow the procedure and TAPS and JTAPI Services are fine. Call is connected to CRA server but nothing is streamed back.

New Member

Re: TAPS not working - Script not playing

Hi

I found out that the TAPS.aef is not working. I tested the aa.aef file and it works fine. When I validate the TAPS.aef file it comes back with a java.lang error. Anybody seen this before?

New Member

Re: TAPS not working - Script not playing

This is the error that I am getting when I run the validate on the CRA Script Editor

java.lang.NoClassDefFoundError

at java/lang/Class.forName

at com/cisco/wfframework/steps/core/ClassInfo.showDeclaredMethods (ClassInfo.java:143)

at com/cisco/wfframework/steps/core/StepHost.compile (StepHost.java:432)

at com/cisco/wfframework/obj/WFBeanStep.compile (WFBeanStep.java:244)

at com/cisco/wfframework/obj/WFWorkflowUtility.validateSteps (WFWorkflowUtility.java:144)

at com/cisco/wfframework/obj/WFWorkflowUtility.compileWorkflow (WFWorkflowUtility.java:160)

at com/cisco/wfframework/obj/WFWorkflow.compile (WFWorkflow.java:684)

at com/cisco/wfframework/editor/ui/wfc/Form1.findCompileErrors (Form1.java:1410)

at com/cisco/wfframework/editor/ui/wfc/Form1.toolsCompileMenuItem_click (Form1.java:1417)

at com/ms/wfc/core/EventHandler.invoke (EventHandler.java)

at com/ms/wfc/ui/MenuItem.onClick (MenuItem.java)

at com/ms/wfc/ui/MenuItem$MenuItemData.execute (MenuItem.java)

at com/ms/wfc/ui/Command.invoke (Command.java)

at com/ms/wfc/ui/Command.dispatchID (Command.java)

at com/ms/wfc/ui/Control.wmCommand (Control.java)

at com/ms/wfc/ui/Control.wndProc (Control.java)

at com/ms/wfc/ui/Form.wndProc (Form.java)

at com/ms/wfc/ui/Control$ControlWindow.wndProc (Control.java)

at com/ms/wfc/app/Window.callback (Window.java)

at com/ms/wfc/win32/Windows.DispatchMessage (Windows.java)

at com/ms/wfc/app/Application$ThreadContext.runMessageLoop (Application.java)

at com/ms/wfc/app/Application.run (Application.java)

at com/cisco/wfframework/editor/ui/wfc/Form1.main (Form1.java:2241)

at com/cisco/wfframework/editor/WFEditor.main (WFEditor.java:37)

at WFCCNEditor.main (WFCCNEditor.java:128)

Hall of Fame Super Silver

Re: TAPS not working - Script not playing

What codec did you select when you installed CRS? I have similar symptom when the CRS was installed with g.729, the TAPS prompts are all g.711, I had to convert the prompt and then it worked fine.

Chris

234
Views
0
Helpful
5
Replies
CreatePlease to create content