Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

TAPS with CCM 4.1.3SR2 and CRS 4.0.2

Does anyone know if TAPS is supported with CCM 4.1.3SR2 and CRS 4.0.2? I just installed the taps component on the CRS server and I can't find the TAPS.AEF script anywhere.

11 REPLIES
New Member

Re: TAPS with CCM 4.1.3SR2 and CRS 4.0.2

Just figured out my problem. The install for the aef file is now performed through a AAR file in CRS 4.0 and higher. Hope this helps anyone else in a jam.

New Member

Re: TAPS with CCM 4.1.3SR2 and CRS 4.0.2

Fighting the same problem. Where are these aar files located. I believe the CRS Application Administration is used to upload. Thanks

New Member

Re: TAPS with CCM 4.1.3SR2 and CRS 4.0.2

Take a look at these two to see if they help you out

CSCsc83841, try searching for the "TAPS AAR.aar" file.

The bug ID explains some of the procedure.

New Member

Re: TAPS with CCM 4.1.3SR2 and CRS 4.0.2

Thanks this explains the issue. However, a search on the server does not find the TAPS AAR.aar file.

New Member

Re: TAPS with CCM 4.1.3SR2 and CRS 4.0.2

So here is what I found. Once you install the taps plugin from callmanager on the IPCC server, there will be a directory of c:\taps created. the AAR file will be located in there. Then you have to upload using the AAR management page in appadmin and it will extract the files, create the classes and put the taps.aef script in the repository.

New Member

Re: TAPS with CCM 4.1.3SR2 and CRS 4.0.2

I have used the procedure described in the bug notes but I have found that sometimes it works and sometimes it dosen't. In my lab I have IPCC 4.02 and TAPS works, in a production enviroment I also have TAPS with IPCC 4.02 which dosn't work. Dispite being told that there should be no difference using a enchanced license instead of a standard license did get TAPS to work.

New Member

Re: TAPS with CCM 4.1.3SR2 and CRS 4.0.2

I'm having the same problem. With a standard license, I cannot get IPCC 4.0.2 to load the taps script. I'm getting the following error:

Application=TAPS,Exception=com.cisco.app.InvalidApplicationException: failed to load script; nested exception is:

com.cisco.wfapi.WFPreprocessException: Java extensions are not licensed to support data type: java.io.FileInputStream (line: 1, col: 1); nested exception is:

com.cisco.expression.ExpressionLicenseViolationException: Java extensions are not licensed to support data type: java.io.FileInputStream (line: 1, col: 1); nested exception is:

com.cisco.wfapi.WFPreprocessException: Java extensions are not licensed to support data type: java.io.FileInputStream (line: 1, col: 1); nested exception is:

com.cisco.expression.ExpressionLicenseViolationException: Java extensions are not licensed to support data type: java.io.FileInputStream (line: 1, col: 1); nested exception is:

com.cisco.script.ScriptPreprocessException: Java extensions are not licensed to support data type: java.io.FileInputStream (line: 1, col: 1); nested exception is:

com.cisco.expression.ExpressionLicenseViolationException: Java extensions are not licensed to support data type: java.io.FileInputStream (line: 1, col: 1); nested exception is:

com.cisco.wfapi.WFPreprocessException: Java extensions are not licensed to support data type: java.io.FileInputStream (line: 1, col: 1); nested exception is:

com.cisco.expression.ExpressionLicenseViolationException: Java extensions are not licensed to support data type: java.io.FileInputStream (line: 1, col: 1)

I opened a TAC case to see what they say... I'll post the resolution if they have one besides giving me an enhanced license.

New Member

Re: TAPS with CCM 4.1.3SR2 and CRS 4.0.2

I have the same issue. Standard license and getting the following.

1014: Feb 06 16:20:49.251 EST %MIVR-STEP_MEDIA_CONTROL-7-OFF:Disabling XDEBUGGING5 messages

1015: Feb 06 16:20:49.266 EST %MIVR-EXPR_MGR-3-EXPR_NOT_LICENSED:Expression not licensed: Non terminal token id=null,Expression type=java.io.FileInputStream,Token=objFile,Line=1,Column=1,Exception=com.cisco.expression.ExpressionLicenseViolationException: Java extensions are not licensed to support data type: java.io.FileInputStream (line: 1, col: 1)

1016: Feb 06 16:20:49.266 EST %MIVR-EXPR_MGR-3-EXCEPTION:com.cisco.expression.ExpressionLicenseViolationException: Java extensions are not licensed to support data type: java.io.FileInputStream (line: 1, col: 1)

1017: Feb 06 16:20:49.266 EST %MIVR-EXPR_MGR-3-EXCEPTION: at com.cisco.expression.impl.NodeImpl.preprocess(NodeImpl.java:3297)

1046: Feb 06 16:20:49.266 EST %MIVR-SCRIPT_MGR-3-INVALID_SCRIPT:Invalid script: Script=TAPS.aef,Exception=com.cisco.wfapi.WFPreprocessException: Java extensions are not licensed to support data type: java.io.FileInputStream (line: 1, col: 1); nested exception is:

com.cisco.expression.ExpressionLicenseViolationException: Java extensions are not licensed to support data type: java.io.FileInputStream (line: 1, col: 1)

1047: Feb 06 16:20:49.266 EST %MIVR-SCRIPT_MGR-3-EXCEPTION:com.cisco.wfapi.WFPreprocessException: Java extensions are not licensed to support data type: java.io.FileInputStream (line: 1, col: 1); nested exception is:

1048: Feb 06 16:20:49.266 EST %MIVR-SCRIPT_MGR-3-EXCEPTION: com.cisco.expression.ExpressionLicenseViolationException: Java extensions are not licensed to support data type: java.io.FileInputStream (line: 1, col: 1)

Whats your case number; I may be able to my SE to do some tracking down for us.

New Member

Re: TAPS with CCM 4.1.3SR2 and CRS 4.0.2

I have the same issue; in the lab with the TOI license file TAPs works; in production with a standard license it does not work.

I am thinking that you need the enhanced or premium license to use the customer classes that the new TAP.aef uses. I still don't have a solution.

New Member

Re: TAPS with CCM 4.1.3SR2 and CRS 4.0.2

Hi

I've had this exact same problem as well - I've had a TAC case open since Jan 26. They escalated this to an SE and this is a confirmed bug with IPCC Express Standard versions of CRS.

This is the message I eventually got back from TAC:

"On the error message you are receiving I suspect you are hitting CSCsd05475

Which is planned to be fixed on 4.0.4 SR1"

CSCsc09484 is probably related too.

This will be fixed with CRS 4.0.4 SR1, however that means we are still out of options with shipping kit:

1. TAPS won't work with Extended Services because it won't let you load the script into the repository. CSCef17749

2. The version of IP IVR that ships with CCM is 4.0(2) or 4.0(3).

Best thing to do is to grab a copy of CRS3.5x with a valid license file or get the enhanced or premium version of IPCC/IVR.

New Member

Re: TAPS with CCM 4.1.3SR2 and CRS 4.0.2

Hi, I've just installed Cisco Extended Services CD (version 3.5.2) in my CCM 4.1.3sr3a and read the following guide to help me:

Device Configuration with TAPS and BAT in Cisco CallManager Administration

Unfortunately, I halted in the step where I was supposed to configure the application in CRS admin page, with tapsuser (as in the configuration example): the TAPS.aef just does not show in the drop-down list. Is this bug CSCef17749 related to this issue?

209
Views
4
Helpful
11
Replies