Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Trouble while reinstalling subscriber

I am reinstalling a CCM cluster in test setup running CCM 4.02a es30.1

I first installed Publisher alongwith Windows. Then upgraded to es30.1 and also restored the data using backup of my production system. This all went smooth.

Now when I am trying to install suscriber, I am facing an issue. I reinstall windows successfully. After starting CCM installation, it collects all the dat like passwords etc and then asks for disk 2. After inserting disk 2 it installs Cisco Directory. Once this step is completed next it goes to installing callmanager. Here the process suddenly throws an error message stating that there was some fatal error and application could not be installed. After this the installation rolls back. This same thing happened every time I tried to install suscriber. I have tested following things

1. Removed es 30.1 So the system was running only 4.02a. Still the same issue occurred while installing suscriber.

2. Since I have restored backup, it was already cotaining the configuration of the subscriber server I was installing. Removed the suscriber server (to be installed) from all CCM groups etc and deleted the CCM Subscriber as well as server entry from the publisher. Still the same issue.

3. Tried reinstalling this subscriber right from the scratch multiple times.

I have attached log of the process alongwith.

Any help is greatly appreciated.....as usual :)

Best Regards,

Anand P. Diwakar

4 REPLIES
Blue

Re: Trouble while reinstalling subscriber

perhaps the clusterID for that subscriber still exists in the PUBs cluster configuration.

try to use the 'recover from backup' option when rebuilding the subscriber. this will allow the sub to be built with the proper ID, etc. that the pub has configured.

or perhaps you can rebuild the PUB without the restore and then rebuild the SUB. (same exact names, etc.)

after sub is completed and you've verified SQL replication is 100% completed, then perform the restore to the PUB only.

or last but not least, you can build the PUB, perform the restore and then build the SUB without a restore. see if the PUB can replicate to the SUB as it should normally.

PS...i've only had problems with 4.02 in almost every scenario. (haven't touched it in at least two years) upgrading to 4.1x was a real ease on my sanity as many 'weird issues' were resolved and a side benefit was more features, stability and better response (less CPU hogging).

Re: Trouble while reinstalling subscriber

Thanks for the help Greg,

ust want to know a few things about your suggestions

1. You mean that while reinstalling OS I should use "recover from backup" instead of saying new installation. Am I right here. I am not sure what exactly is cluster ID. Can you educate me a little about that.

2. Second option I am trying right now :)

But this is not exactly how it should be. I am just wondering say if I have to add some new subscriber, I cannot rebuild the pub for that. So I am trying to figure out the exact cause why is this happening. Besides I have done this stuff with 4.1.3 for multiple times and it went all smooth, so just wondering what could be the issue here.

3. The last option is exactly what I did. I restored the pub completely and then I started reinstalling sub. But while installing CCM application it just crashes and rolls back entire process.

So as of now I am moving ahead with option 2. Will update you how it goes

New Member

Re: Trouble while reinstalling subscriber

I think your sub is not seeing your pub at some level. I had this exact problem once and solved it by placing the entries for each server in the host and lmhost files of each server. I believe they are in c, winnt, system32, drivers, etc, host and samlmhost. Or something like that. Anyway it like to have drive me crazy trying to get the sub loaded and that was all it was.

Re: Trouble while reinstalling subscriber

Hie David,

I dont think lmhosts is an issue here. I have already made entries in that and have checked that sub pings pub using hostname. And besides in that case installation will not go beyond a stage where we specify pub name and password on suscriber. Here it is actually going all the way ahead to install SQL, then takes second CD, installs directory and then while installing callmanager it suddenly crashes

149
Views
4
Helpful
4
Replies