Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Trouble with CCME 4 and VIC2-2FXO; IOS 12.4(9)T

Trouble with CCME 4 and VIC2-2FXO; IOS 12.4(9)T

I am having trouble making outgoing call or answering incoming call.

When I try to call out from my IP 7961 phone, it fails with the message "unknown number".

For incoming call, it rings but when I pick up the call nothing happens,

Put the receiver back on hook, the phone carries on ringing. I am in UK

and just trying to set up test system with one analogue line. Any help will

be most appreciated. My config of the 2811 router is posted below. All calls ineternally works fine.

Thank you for your help.

hostname Test-CME

!

!

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 10.10.10.1 10.10.10.10

ip dhcp excluded-address 10.139.139.1 10.139.139.10

!

ip dhcp pool host

network 10.10.10.0 255.255.255.0

default-router 10.10.10.1

option 150 ip 10.10.10.1

!

ip dhcp pool data

network 10.139.139.0 255.255.255.0

default-router 10.139.139.1

dns-server 10.139.139.5

!

voice-card 0

no dspfarm

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

supplementary-service h450.12

h323

sip

header-passing

registrar server expires max 3600 min 3600

!

!

interface FastEthernet0/1

no ip address

no ip mroute-cache

duplex auto

speed auto

no shut

!

interface FastEthernet0/1.2

description ** Data VLAN **

encapsulation dot1Q 2

ip address 10.139.139.1 255.255.255.0

!

interface FastEthernet0/1.3

description ** Voice VLAN **

encapsulation dot1Q 3

ip address 10.10.10.1 255.255.255.0

!

ip http server

ip http authentication local

no ip http secure-server

ip http path flash:

!

tftp-server flash:S00104000100.sbn

tftp-server flash:TERM41.7-0-3-0S.loads

tftp-server flash:term61.default.loads

tftp-server flash:term41.default.loads

tftp-server flash:CVM41.2-0-2-26.sbn

tftp-server flash:cnu41.2-7-6-26.sbn

tftp-server flash:Jar41.2-9-2-26.sbn

tftp-server flash:term70.default.loads

tftp-server flash:term71.default.loads

tftp-server flash:cnu70.2-7-6-26.sbn

tftp-server flash:Jar70.2-9-2-26.sbn

tftp-server flash:TERM70.7-0-3-0S.loads

tftp-server flash:CVM70.2-0-2-26.sbn

!

control-plane

!

voice-port 0/3/0

connection plar opx 202

caller-id enable

!

dial-peer voice 1 pots

incoming called-number .

destination-pattern 9T

port 0/3/0

!

telephony-service

load 7914 S00104000100

load 7941 TERM41.7-0-3-0S

load 7961 TERM41.7-0-3-0S

load 7970 TERM70.7-0-3-0S

max-ephones 20

max-dn 40

ip source-address 10.10.10.1 port 2000

calling-number initiator

service phone videoCapability 1

system message MKC CME

url services http://10.10.10.1/voiceview/common/login.do

url authentication

http://10.10.10.1/voiceview/authentication/authenticate.do

time-zone 21

date-format dd-mm-yy

voicemail 600

max-conferences 8 gain -6

call-forward pattern .T

call-forward system redirecting-expanded

moh music-on-hold.au

web admin system name admin secret 0 test

dn-webedit

time-webedit

transfer-system full-consult dss

transfer-pattern 9.T

secondary-dialtone 9

create cnf-files

!

!

ephone-dn 1 dual-line

number 201

label 201

description Sarah

name Sarah

!

!

ephone-dn 2 dual-line

number 202

label 202

description Vitthal

name User2 Vitthal

!

!

ephone-dn 3 dual-line

number 203 secondary

label 203

description Neil

name User3 Neil

!

ephone 1

video

username "user1" password 201

mac-address 0018.18EE.947F

type 7961 addon 1 7914

button 1:1

!

!

ephone 2

video

username "user2" password 202

mac-address 0018.18BB.B973

type 7941

button 1:2

!

ephone 3

video

username "user3" password 203

mac-address 0018.1885.6BA2

type 7970

button 1:3

4 REPLIES
Green

Re: Trouble with CCME 4 and VIC2-2FXO; IOS 12.4(9)T

Hi Vitthal,

The config looks good to me.

Could you please paste the:

debug voice ccapi inout

debug ephone detail

Thanks

New Member

Re: Trouble with CCME 4 and VIC2-2FXO; IOS 12.4(9)T

Hi

Please find enclosed debug attachment for voice ccapi and ephone. First, I called from outside. Extension 202 rings but when I answered on extension 202 nothing happens. Replace the rceiever and the pone starts ringing again.Second step. I tried to call out by dialing 9 and then number but after a while phone displays unknown number.

Thank you for your help.

Vitthal

New Member

Re: Trouble with CCME 4 and VIC2-2FXO; IOS 12.4(9)T

On your outbound dial-peer, do you need to drop the 9? If you don't drop it, the router will forward the full dialed number (9 plus any other digits before the timeout) to the telco, and the call will fail.

Inbound, your config looks good. There might be some signalling and dtmf config you have to do, but I am not familiar with UK standards.

New Member

Re: Trouble with CCME 4 and VIC2-2FXO; IOS 12.4(9)T

Hi

My understanding is that router will drop 9 before forwarding the dialled digits. However, I will drop 9 manually and see what happens. I will let you know by tomorrow.

Thanks for your help.

Regards,

Vitthal

171
Views
0
Helpful
4
Replies
CreatePlease to create content