Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Troubleshooting no busy tone

Hi,

we are using CCM3.2(3)sr2 and vg200 12.2(19) with a E1 Multiflex Trunk behind a Nortel Meridian PBX.

VoIP users calling an outside number hear no busy tone if the called number is busy. The connection attempt is terminatet such a normal call disconnect (see the q931 debug).

vg200#

2w3d: ISDN Se1/0:15: TX -> SETUP pd = 8 callref = 0x0316

2w3d: Bearer Capability i = 0x8090A3

2w3d: Channel ID i = 0xA9838B

2w3d: Calling Party Number i = 0x00, 0x81, '333', Plan:Unknown, Type:Unknown

2w3d: Called Party Number i = 0x80, '00123789231', Plan:Unknown, Type:Unknown

2w3d: ISDN Se1/0:15: RX <- SETUP_ACK pd = 8 callref = 0x8316

2w3d: Channel ID i = 0xA9838B

2w3d: ISDN Se1/0:15: RX <- PROGRESS pd = 8 callref = 0x8316

2w3d: Cause i = 0x8091 - User busy

2w3d: Progress Ind i = 0x8288 - In-band info or appropriate now available

2w3d: ISDN Se1/0:15: RX <- DISCONNECT pd = 8 callref = 0x8316

2w3d: Cause i = 0x8190 - Normal call clearing

2w3d: ISDN Se1/0:15: TX -> RELEASE pd = 8 callref = 0x0316

2w3d: ISDN Se1/0:15: RX <- RELEASE_COMP pd = 8 callref = 0x8316

vg200#

VoIP users calling a Nortel phone connected to the PBX hear the busy tone if Nortel phone is busy (see the q931 debug).

vg200#

2w3d: ISDN Se1/0:15: TX -> SETUP pd = 8 callref = 0x0317

2w3d: Bearer Capability i = 0x8090A3

2w3d: Channel ID i = 0xA9838B

2w3d: Calling Party Number i = 0x00, 0x81, '333', Plan:Unknown, Type:Unknown

2w3d: Called Party Number i = 0x80, '371', Plan:Unknown, Type:Unknown

2w3d: ISDN Se1/0:15: RX <- SETUP_ACK pd = 8 callref = 0x8317

2w3d: Channel ID i = 0xA9838B

2w3d: ISDN Se1/0:15: RX <- DISCONNECT pd = 8 callref = 0x8317

2w3d: Cause i = 0x8191 - User busy

2w3d: ISDN Se1/0:15: TX -> RELEASE pd = 8 callref = 0x0317

2w3d: ISDN Se1/0:15: RX <- RELEASE_COMP pd = 8 callref = 0x8317

vg200#

The difference is the progress message "user busy" in the first debug. The second debug contains no Progress message, the "user busy" is part of the disconect message.

I found some tips on CCO like "voice call convert-discpi-to-prog" (http://www.cisco.com/en/US/tech/tk652/tk653/technologies_tech_note09186a0080111b58.shtml) and "progress_ind progress enable" but no success.

Ideas are welcome.

Thanks a million

2 REPLIES
Silver

Re: Troubleshooting no busy tone

The PSTN is giving you a progress message that is telling the router to cut through the audio path as the busy tone is being played in band.

Try adding 'progress_ind progress enable 8' on the POTS dial peer the call is matching on and using to send the call to the PSTN.

New Member

Re: Troubleshooting no busy tone

Hi pacameron,

this is something I also tried ...

Here is the current dial-peer config

dial-peer voice 1 pots

tone ringback alert-no-PI

destination-pattern .T

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind progress enable 8

port 1/0:15

159
Views
0
Helpful
2
Replies