Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Unable to login to EM

I have CCM3.3(3) installed and integrated with the customer AD(W2K). I am unable to get the EM services to work (Login Unsuccessful, Error:[6])

Below is the trace file that I have.

Feb 16 17:30:14.014 SGT %EMApp-EMAPPSERVLET-7-UNK:Posting to EM Service:<query>

<appInfo>

<appID>CCMSysUser</appID>

<appCertificate>xxxxxxx</appCertificate>

</appInfo>

<deviceUserQuery>

<deviceName>SEP000DED409A79</deviceName>

</deviceUserQuery>

</query>

75: Feb 16 17:30:14.014 SGT %EMApp-EMAPPSERVLET-7-UNK:URL of EM Query Service:http://10.9.1.5/LoginService/query.asp

76: Feb 16 17:30:14.389 SGT %EMApp-EMAPPSERVLET-7-UNK:The login status result for :SEP000DED409A79:null

77: Feb 16 17:30:14.389 SGT %EMApp-EMAPPSERVLET-7-UNK:Context:/emapp

78: Feb 16 17:30:14.389 SGT %EMApp-EMAPPSERVLET-7-UNK:Context:/emapp ::URI:/jsp/form1.jsp

79: Feb 16 17:30:25.014 SGT %EMApp-EMAPPSERVLET-7-UNK:DirUserInfoVector=[DirUser.DirUserInfo@2b9406]

80: Feb 16 17:30:25.014 SGT %EMApp-EMAPPSERVLET-7-UNK:DirUserInfo=DirUser.DirUserInfo@2b9406

81: Feb 16 17:30:25.014 SGT %EMApp-EMAPPSERVLET-7-UNK:Profiles for user:ipsec1=DefProf=IPSec1-DP: Profs= : IPSec1-DP

82: Feb 16 17:30:25.014 SGT %EMApp-EMAPPSERVLET-7-UNK:Posting to EM Service:<request>

<appInfo>

<appID>CCMSysUser</appID>

<appCertificate>xxxxxxx</appCertificate>

</appInfo>

<login>

<deviceName>SEP000DED409A79</deviceName>

<userID>ipsec1</userID>

</login>

</request>

83: Feb 16 17:30:25.014 SGT %EMApp-EMAPPSERVLET-7-UNK:URL of EM Service:http://10.9.1.5/LoginService/login.asp

84: Feb 16 17:30:25.717 SGT %EMApp-EMAPPSERVLET-7-UNK:Error from EM Service[6]:DB Request Error: Couldn't submit login request to DBL: CDBLException Dump: [ODBC Error]: Failed to connect to datasource: [Microsoft][ODBC SQL Server Driver][SQL Server]Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'.

85: Feb 16 17:30:25.717 SGT %EMApp-EMAPPSERVLET-7-UNK:The EM Service returned error code:6

86: Feb 16 17:30:25.717 SGT %EMApp-EMAPPSERVLET-7-UNK:Context:/emapp ::URI:/jsp/phone_error1.jsp

I think my problem may be with the login to the SQL. I have check to ensure that anonymous login is enabled. Please advise.

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: Unable to login to EM

I had in the passed also problems with EM, after restore the DB on a new CCM.

To re-enter the passwords in the Anonymous access , the EM was working again.

1) Configure Virtual Directory --

a) Right Click Login Service, select Properties

b) In Virtual Directory Tab---

1) make sure Read and Log Visits are checked, none others

2) Make sure Execute Permissions are 'Scripts and Executables'

3) Make sure Application Protection is 'Low (IIS Process)'

c) In Documents tab, make sure only enabled default doc is

'Default.asp'

d) In Directory Security tab, click Edit button under Anonymous Access

and Authentication Control

1) Make sure Anonymous access is checked, no other options are

2) Click Edit button under Anonymous Access

3) Set Username to CCMEML

4) Set password to CCMEML password

5) Click OK

6) Click OK

e) Click OK

2 ) It may be necessary to restart the IIS service.

Try it , maybe this is the case !!!!

5 REPLIES
New Member

Re: Unable to login to EM

I had in the passed also problems with EM, after restore the DB on a new CCM.

To re-enter the passwords in the Anonymous access , the EM was working again.

1) Configure Virtual Directory --

a) Right Click Login Service, select Properties

b) In Virtual Directory Tab---

1) make sure Read and Log Visits are checked, none others

2) Make sure Execute Permissions are 'Scripts and Executables'

3) Make sure Application Protection is 'Low (IIS Process)'

c) In Documents tab, make sure only enabled default doc is

'Default.asp'

d) In Directory Security tab, click Edit button under Anonymous Access

and Authentication Control

1) Make sure Anonymous access is checked, no other options are

2) Click Edit button under Anonymous Access

3) Set Username to CCMEML

4) Set password to CCMEML password

5) Click OK

6) Click OK

e) Click OK

2 ) It may be necessary to restart the IIS service.

Try it , maybe this is the case !!!!

New Member

Re: Unable to login to EM

what is the CCMEML password?

New Member

Re: Unable to login to EM

In the passed I had a simulair problem, This is the action I have made, with a cisco SE involved.

This seems to be caused by an error in the setup of the EM service

virtual

directory. This virtual directory can be recreated with the following

steps:

---- Delete Existing Virtual Directory ----

1) Start->Programs->Administrative Tools->Internet Information Services

2) Expand pc->DefaultWebsite in left pane

3) Right click Login Service, select Delete

---- Clean up Directory ----

4) Rename C:\CiscoWebs\LoginService\ diretory to

C:\CiscoWebs\OldLoginService\

5) Create directory C:\CiscoWebs\LoginService\

6) Copy following files from C:\CiscoWebs\OldLoginService\ to

C:\CiscoWebs\LoginService\:

a) Tools\ directory and contents

b) login.asp

c) query.asp

d) loginSecure.asp

e) querySecure.asp

f) *.dtd

Note that the following folders and files should not be moved over:

_private\

_ScriptLibrary\

_vti_pvt\

_Images\

global.asa

sampleloginapp.asp

samplequeryapp.asp

testlogin.asp

testquery.asp

XMLForm.htm

XMLFormQueryTest.htm

XMLFormTest.htm

---- Re-create Virtual Directory ----

7) In the Internet Services Manager (opened in step 1 above), right

click

Default Web Site, select New->Virtual Directory

8) Follow the wizard:

a) Alias: LoginService

b) Directory: Browse to C:\CiscoWebs\LoginService

c) Select Read, Run, and Execute

9) Configure Virtual Directory --

a) Right Click Login Service, select Properties

b) In Virtual Directory Tab---

1) make sure Read and Log Visits are checked, none others

2) Make sure Execute Permissions are 'Scripts and Executables'

3) Make sure Application Protection is 'Low (IIS Process)'

c) In Documents tab, make sure only enabled default doc is

'Default.asp'

d) In Directory Security tab, click Edit button under Anonymous Access

and

Authentication Control

1) Make sure Anonymous access is checked, no other options are

2) Click Edit button under Anonymous Access

3) Set Username to CCMEML

4) Set password to CCMEML password

5) Click OK

6) Click OK

e) Click OK

10) It may be necessary to restart the IIS service.

Cisco Employee

Re: Unable to login to EM

Conditions:

This occurs when the EM Service is running on a subscriber.

Run ADSIEdit on the AD 200x server. LabeledURI attribute value imder

cisco\CCN\systemProfiles\HotelingProfile

If you find two links pointing to both Publisher and Subscriber. So deleted the Subscriber

loginservice/login.asp URL and restarted IIS and TOMCAT service.

Cisco Employee

Re: Unable to login to EM

Conditions:

This occurs when the EM Service is running on a subscriber.

Run ADSIEdit on the AD 2003 server. LabeledURI attribute value imder

cisco\CCN\systemProfiles\HotelingProfile

If you find two links pointing to both Publisher and Subscriber. So deleted the Subscriber

loginservice/login.asp URL and restarted IIS and TOMCAT service.

197
Views
8
Helpful
5
Replies
CreatePlease login to create content