Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Unity 2.4.6(135)/TSP 7.0 Upgade Failed

Last night I attempted to update the unity TSP to 6.0b to allow us to upgrade CallManager to 3.2... This didn't work - Unity would drop calls as soon as it answered them.

I then tried 7.0, this had the same problem, and I was unable to get back to the original state.

I've since removed all the TSP stuff/dlls etc and reinstalled 7.0 as I'm assured by everything I find on the cisco site that it should work. It still doesn't, however.

I get the following errors in the event log:

Event Type: Error

Event Source: AvMiu_MC

Event Category: Error

Event ID: 530

Date: 13/02/2003

Time: 1:01:14 PM

User: N/A

Computer: VOICEMAIL

Description:

Component Miu: Thread 0x00000E44 had a Failure on Port 1 in AvWav

DESCRIPTION:

File: h:\commsvr\Sources\UnityAvWav\WAV.C(3211)

Method: WavSetVolume

Failure: call to WavOutSupportsVolume failed.

Followed by:

Event Type: Error

Event Source: AvMiu_MC

Event Category: Error

Event ID: 524

Date: 13/02/2003

Time: 1:01:14 PM

User: N/A

Computer: VOICEMAIL

Description:

Component Miu: Thread 0x00000E44 had a Failure on Port 1 in Method CAvMiuWave::SetVolume()

DESCRIPTION: AvWav WavSetVolume failed with 0xFFFFFFFF.

DETAILS:

FileName: C:\CommServer\localize\Prompts\ENG\AvSubSignIn\AvSubSignInENG002.wav

HWAV: 0x01482BD4

Target Volume: 100

WavState: WAV_OPENED.

CALL SEQUENCE:

[13:01:14:281 - 0x00000C74] LINE_APPNEWCALL(0x00010167)

[13:01:14:281 - 0x00000C74] GetNewCall() - 0x0001019A

[13:01:14:281 - 0x00000C74] SetEvent(NewCall)

[13:01:14:281 - 0x00000C74] LINECALLSTATE_OFFERING(0x00010167)

[13:01:14:484 - 0x00000E44] Answer() entered

[13:01:14:499 - 0x00000E44] lineAnswer(0x0001019A) - 0x00010178

[13:01:14:499 - 0x00000E44] LINECALLSTATE_OFFERING(0x0001019A)

[13:01:14:499 - 0x00000E44] LINE_REPLY(0x00010178 | 0x00000000)

[13:01:14:687 - 0x00000C74] LINECALLSTATE_CONNECTED(0x00010167 | Active)

[13:01:14:687 - 0x00000E44] LINECALLSTATE_CONNECTED(0x0001019A | Active)

[13:01:14:687 - 0x00000E44] WaitFor(0x00010178 | CONNECTED) - CONNECTED

[13:01:14:687 - 0x00000E44] Answer() - S_MIU_CONNECTED

[13:01:14:828 - 0x00000E44] Play() entered

[13:01:14:843 - 0x00000E44] ResetEvent(IOComplete)

[13:01:14:843 - 0x00000E44] ResetEvent(IOActive)

[13:01:14:874 - 0x00000E44] WavOpen(C:\CommServer\localize\Prompts\ENG\AvSubSignIn\AvSubSignInENG002.wav) - 0x01482BD4

[13:01:14:874 - 0x00000E44] WavGetLength(0x01482BD4) - 3003

[13:01:14:874 - 0x00000E44] WavClose(0x01482BD4) - 0x00000000

[13:01:14:890 - 0x00000E44] WavOpen(C:\CommServer\localize\Prompts\ENG\AvSubSignIn\AvSubSignInENG002.wav) - 0x01482BD4

[13:01:14:890 - 0x00000E44] WavSetChunks(0x01482BD4) - 0x00000000

[13:01:14:890 - 0x00000E44] WavSetPosition(0x01482BD4 | 0) - 0

[13:01:14:890 - 0x00000E44] WavSetVolume(0x01482BD4 | 100) - 0xFFFFFFFF.

Any ideas?

Incidentally we are still using cm 3.1. There are also some info messages as each port (of 8) starts up, then another that says that the port will be unavailable until Unity restarts... Of course, restarting doesn't help!

3 REPLIES
Cisco Employee

Re: Unity 2.4.6(135)/TSP 7.0 Upgade Failed

It looks like you probably hit CSCdv88847. It happens when there's a conversation volume level set to something other than "medium". With newer versions of the TSP, you'll see this with somewhat older versions of Unity.

It's taken care of in later versions of 3.X. However, there is a 2.4.6 based "hot fix" that's available from TAC for this issue. Before the hotfix is installed, you'd have to bring the sytstem up to at least 2.4.6.161.

New Member

Re: Unity 2.4.6(135)/TSP 7.0 Upgade Failed

I checked the subscribers, they were all left on medium... However, switching to low resolved the problem...

In order to avoid having to modify each subscriber I found a registry value that controls the "median volume" and set this to 50 (from 100), this now has the system working!

Thanks a lot - TAC have been working on this case for 5 days and haven't come near to fixing this!

New Member

Re: Unity 2.4.6(135)/TSP 7.0 Upgade Failed

Could you tell me what the registry value is and where it is found?

Regards

Mark

95
Views
4
Helpful
3
Replies