Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Unity 3.1.3: all Exchange subscribers are lost

I'm installing a Unity 3.1.3 UM (AD & E2K environment). After the installation I imported all the needed AD users. It went fine. After that I called the voicemail-DN: Unity asked to enter the password and I had the self-enrollment process. So, that was perfect.<br><br>Few minutes later I tried to do this operation again: Unity didn't recognize this extension as a user anymore... I went to the Unity Admin pages and all the imported users had disappeared!! The only subscribers left were Example Admin & Example Subscriber.<br><br>When running the Unity Import tool, the previously imported users are not seen anymore. I suppose this means that Unity still sees them somewhere... But where?<br><br>Any idea about this? Can I find my users back?<br><br>

3 REPLIES
Anonymous
N/A

Re: Unity 3.1.3: all Exchange subscribers are lost

Hmmm... sounds like all the users got tagged as subscribers and then the location object Id got changed around somehow (should not be possible to do by accident) and now the Unity server thinks those subscribers are all associated with a different Unity box... it wont let you import them for that reason.

No clue why or how this would happen (have not seen that) and I'm just guessing based on the system behavior you describe.

If you have WTS access to your box, ping me at Cisco email address and I'll call in and look around at your database to see what might have happened...


Jeff Lindborg
Unity Technical Lead/Answer Monkey
Cisco Systems
lindborg@cisco.com
http://www.AnswerMonkey.net (new page for Unity support tools and scripts)

Anonymous
N/A

Re: Unity 3.1.3: all Exchange subscribers are lost

Jeff,

For the moment my problem is solved: I used the BunnyKiller to remove all the Unity subscriber properties from the AD & I resynchronized the system key (because the AA and VMO licences were not released...) After that I was able to re-import all the Exchange users again. I hope that everything will still be OK on Thursday morning (tommorow is a holiday in Belgium...).

PS: Great tools! Thanks for making them available!

Anonymous
N/A

Re: Unity 3.1.3: all Exchange subscribers are lost

I still have a question about this installation. I have two separate accounts for the Unity installation & services. I followed the Installation Guide to grant the necessary permissions to these accounts, but when I wanted to import the Exchange users I got the error: "Unexpected error. Method '~' or function '~' failed." I found a quick (and dirty) work-around: I made the services account Domain Admin & everything worked fine.
Afterwards I tried the Permission wizard to grant the permissions, but the problem was still the same.
Of course, the customer doesn't like that the services account has to stay a Domain Admin...

Did I miss something or is this issue linked to the configuration of the E2K & AD of the customer? Although he says there's nothing special.


107
Views
0
Helpful
3
Replies
CreatePlease to create content