Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Unity 3.1.3 AvCsMgr service fail

Installed a clean Unity 3.1.3, setup fails to start AvCsMgr. Have tried all combiantions of service accounts/rights etc. Rebuilt the server from scratch - still get AvCsMgr service fails to start "the service did not return an error".

This is a lab server & has duplicate DC, Exchange2k etc. Also the account permissions, group memberships and service logins are recreated as in the production system. This has worked before with the same lab domain setup and hardware when testing upgrade to 4.0.2 (although that had its own quirks). I am using this to test upgrade to 4.0.3, then Exch2003. Any ideas on what to try? I also tried using the 4.x Perms Wizrd and that did not solve the issue. This is becoming a show stopper.

5 REPLIES
Cisco Employee

Re: Unity 3.1.3 AvCsMgr service fail

The event log should have something in there with failures during the Unity startup that would likely shed some light on this.

I'd definitely run down the 4.0(3) version of PW path that you are - however remember that it wont dynamically assign those accounts you setup to the services in question, you'll have to do that manually. The PW Help covers this a bit but you'll need to make sure your directory facing account is assigned to the AvDSAD and AVDSGlobalCatalog services and that the message facing account is assigned to the AvCsMgr and AvCsGateway services. In later versions of Unity there are additional services (notifier, message stor monitor) that need to be assigned as well but those services are not present back in 3.1(3).

New Member

Re: Unity 3.1.3 AvCsMgr service fail

The EV log just says that the service failed to start and done so x times etc.

The setup log just states that the service failed to start and that setup failed to complete.

I made script to change the service account logins (got tired of doing it over & over manually); however whatever account was set for AvCsMgr (dom.admin, exch.admin, unity service, local system) has not worked. I am using the same set of procedures that was done successfully in the past, including as configured in the current production system so I am at a loss as to what's wrong now.

Cisco Employee

Re: Unity 3.1.3 AvCsMgr service fail

At what point do you get the message that the setup failed to complete? Is that when eg running the message store part or already in the first part of the installation?

It would be interesting to see in the tempu.log where it goes wrong. Also please look in application log as well.

What can be tried as well is to reconfigure the avcsmgr.exe service by typing from the command prompt under the commserver directory avcsmgr.exe -service. Then you should have a look at the services applet and it should have disabled the service. Then reboot and it should be gone. After reboot issue the same command (this should recreate service), go to the services applet and change it to have the appropriate startup account. Then clear event logs (especially app logs) and try to start and paste in this forum the errors that you see.

Ullie

New Member

Re: Unity 3.1.3 AvCsMgr service fail

The error comes up at the last part on Config Wiz - when starting the Unity services; then I get the error when trying to restart AvCsMgr manually and when reconfiguring it with the other accounts listed above.

Well, the logs aren't much help - hench posting to this forum. I will try your suggestion to remove & readd the service & see if that helps - I hope!

New Member

Re: Unity 3.1.3 AvCsMgr service fail

Got it fixed, eventually:

Error with MSMQ, so reinstalled it and blew out the log (QMLOG). Coincidentally the MSExchangeIS had hung prior to this so the system mbx couldn't be accessed (Doh error), hence the service failures.

165
Views
0
Helpful
5
Replies