Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Unity 3.14 "failed to reassign the installer's account"

I am installing Unity 3.14 when running the config wizard I receive an error message "failed to reassign the installer's account to current user". During the setup process I am asked for the administrator account, when I choose it within the domain the text box uses "NTDOM" for the domain name instead of the actual domain name. I don't know if this is part of the problem or not. I am already aware of the bug ID CSCDU25037 that outlines this problem and a registry editing solution, unfortunately the key they are referring to already exists on my server so that is not the fix for me. I have also used the Permissions wizard to grant the proper rights to my installer and service accounts. Any help would be appreciated.

7 REPLIES
New Member

Re: Unity 3.14 "failed to reassign the installer's account"

I'm assuming you're seeing this during the second step of the installation. If it's CSCdu25037, then you may want to check to see if you're still a member of a valid domain, that you've got connectivity with your domain controllers, and that you can see your Exchange server. What do the last 6 or so lines of your tempu.log file look like?

New Member

Re: Unity 3.14 "failed to reassign the installer's account"

I'm not that familiar with the tempu.log file, but I have added to this message the last 6 lines: Sorry about the wrap I have spaced between each line to make it a little easier to read.

Thanks,

Any help will be appreciated!

2002-07-18T15:39:56 - ...loading C:\CommServer\SysCheck\AvXMLTestsSvr.dll (e:\views\cs_ue3.1.3.43\un_Doh2\UnityConfig\Setup\ThisSetup.cpp 1139)

2002-07-18T15:39:56 - ...loading TestSuite: C:\CommServer\SysCheck\ENU\ConfigurationSetup\TestSuitesFullAccessExchange55.xml (e:\views\cs_ue3.1.3.43\un_Doh2\UnityConfig\Setup\ThisSetup.cpp 1172)

2002-07-18T15:39:56 - System Test: Check for Microsoft Exchange 5.5 administrator rights (e:\views\cs_ue3.1.3.43\un_Doh2\UnityConfig\Setup\ThisSetup.cpp 1206)

2002-07-18T15:39:56 - Syscheck(TestSuitesFullAccessExchange55.xml.xml) returned 0. (e:\views\cs_ue3.1.3.43\un_Doh2\UnityConfig\Setup\GetEx55Info.cpp 385)

2002-07-18T15:39:56 - Step:CGetAdminAccountStep [IDD_GETADMINACCOUNT] (e:\views\cs_ue3.1.3.43\un_Doh2\UnityConfig\Setup\ThisSetup.cpp 359)

2002-07-18T15:39:56 - Step 'CSetupStep' (123) modeless: 15 milliseconds (e:\views\cs_ue3.1.3.43\un_Setup\SetupEngine2\IWLib\src\step.cpp 910)

New Member

Re: Unity 3.14 "failed to reassign the installer's account"

Have you verified that you're still a member of a valid domain, that you've got connectivity with your domain controllers, and that you can see your Exchange server? What account do you use to run your Exchange server?

Is the account Unity will be running under set to be the Service Account Admin for the organization/site? I'm not sure if the TestSuitesFullAccessExchange55.xml test should return 0 if everything's cool. You may want to run syscheck to verify we've got all the permissions we need.

Have you run the Permissions Wizard against the account you're installing/running Unity with?

New Member

Re: Unity 3.14 "failed to reassign the installer's account"

I have verified the domain information and can ping the fully qualified name of my Exchange 5.5 server. The service account does have service account admin priveledges for the site. I have run syscheck and everything associated with exchange 5.5 is a success. Yes I have also run the permissions wizard, it completes with success for each account also.

New Member

Re: Unity 3.14 "failed to reassign the installer's account"

I am having the exact same problem at the moment. 3.14 with Exchange 5.5. Any help would be greatly appreciated!!!

New Member

Re: Unity 3.14 "failed to reassign the installer's account"

I fixed it! I ran "Create Installer Account" from ConfigMgr.exe in the commserver folder. Weird....

New Member

Re: Unity 3.14 "failed to reassign the installer's account"

Thanks dude,

You save my days from finding out the problem!

CHeers and have a nice day

121
Views
0
Helpful
7
Replies