Cisco Support Community
Community Member

Unity 4.02 Permissions Wizard

I'm attempting to run the Permissions WIzard following the steps outlined in the installation guide and am running into problems. Brief outline of environment ...

Domain A - Forest Root, GC's

Domain B - Another Domain in Forest w/ Transitive Trust to Domain A

I ran the Schema Update on the GC of the Forest Root (Domain A) and verified that the schema in Domain B is updated.

The Unity server is a member server in Domain B.

I've created the 3 Unity users for admin,dir,msg in Domain B AD with the MMC on the Unity server.

When I run the permissions wizard (the account logged in on the Unity server is Domain Admin, Exchange Full Administrator, allowed to Act as part of operating system on Unity server) I select Exhchange 2000 and continue.

When prompted for the installation account in the wizard I select the Domain B UnityAdmin account from the Directory listing. However when the selection screen closes the user does not appear and I cannot continue. I've tried selecting any user in Domain B to use as the Installion,Directory, and Message account but the same thing happens.

Strangely enough if I select any user from Domain A I can continue along until the point where I have to select the OU to create users and such which also only allows me to select things in Domain A. The problem of course is that the Unity related object we want to be created in Domain B's AD not Domain A.

Has anyone experienced this type of problem when using different domains in the forest? Any suggestions or things that I could be checking?



Cisco Employee

Re: Unity 4.02 Permissions Wizard

Well, the most obvious thing here would be the account you're running as doesn't have the juice to get/set what it needs to in the domain B. Can you try running as a member of the enterprise admins as a test?

Community Member

Re: Unity 4.02 Permissions Wizard


That was one of the first things we tried after scratching our heads for awhile and technically it works but with a slight problem.

As I mentioned (probably not very clearly though) I can run the Permissions Wizard as DOMAINA\Administrator (which is a member of the Enterprise Admins group in the forest).

When I click to the part where it says to "Choose the Windows Account to Install Cisco Unity" the default installation account shows up as DOMAINA\Administrator. I'd obviously like to change that to the account for installing as described in the documentation which is where the problems really start happening. When I click the "Change" button I can browse DOMAINB (which the Unity server is a member) for users and select the user DOMAINB\UnityAdmin account. However when I select ok and am returned to the "Choose" window the installation account value is blank and the "Next" button is grayed out.

The only thing that is clear is that the Permissions Wizard does not accept the users in DOMAINB for some unknown reasons but will accept *any* user in DOMAINA. As far as my understanding of things are this should be an acceptable thing to be doing but the Wizard won't select the users and even worse doesn't give any indication as to why.

Any help is greatly appreciated.


Community Member

Re: Unity 4.02 Permissions Wizard

Just to sum something up. I can use accounts in DOMAINA to install and choose a location is DOMAINA to put the Unity subscriber accounts but cannot use accounts or store in DOMAINB even though the Unity server is in DOMAINB.

Is there known problems when configuring Unity to use Active Directory in a forest that has transitive trusts between DOMAINA and DOMAINB? Thats probably what needs to be discovered.


CreatePlease to create content