Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Unity issue

Well, I think its Unity.....

When someone from the outside leaves a voicemail, the voicemail is VERY distorted. Almost sounds like a broken speaker. But it's not consistent! Happens only occasionally... I've checked the same voicemail from different IP phones and I get the same result. ANy ideas? Could it be the H.323 gateway? (I'll post the router config)

Here is the topology:

PSTN---PRI----3640--h.323--3524----CM1 (Unity and IP Phones connect up to the 3524 as well)

Here is the router config:

k wr t

Building configuration...

Current configuration:

!

version 12.1

service timestamps debug datetime msec localtime

service timestamps log datetime msec localtime

service password-encryption

!

hostname 3640-GSX-R1

!

logging buffered 4096 debugging

no logging console

no logging monitor

aaa new-model

aaa group server radius safewordGroup

server 172.16.1.185 auth-port 1812 acct-port 1813

!

aaa authentication login safeword group safewordGroup local

aaa authorization exec default if-authenticated

aaa accounting send stop-record authentication failure

aaa accounting exec rad-acct start-stop group safewordGroup

enable secret 5 $1$/Jac$lEoMpst5.tpczKboIjIW6.

!

!

!

!

!

voice-card 2

!

ip subnet-zero

no ip finger

ip tcp synwait-time 5

no ip domain-lookup

ip domain-name ch1.gsx.com

!

isdn switch-type primary-5ess

isdn voice-call-failure 0

call rsvp-sync

voice rtp send-recv

!

voice service pots

!

!

!

voice class h323 1

h225 timeout tcp establish 3

!

!

!

!

!

controller T1 2/0

framing esf

linecode b8zs

pri-group timeslots 1-24

!

controller T1 2/1

framing esf

linecode b8zs

ds0-group 1 timeslots 1-24 type e&m-wink-start

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

encapsulation isl 10

ip address 172.16.1.251 255.255.255.0

no ip redirects

!

interface FastEthernet0/0.2

encapsulation isl 20

ip address 172.16.56.251 255.255.255.0

ip helper-address 172.16.1.11

no ip redirects

!

interface Serial2/0:23

no ip address

no logging event link-status

isdn switch-type primary-5ess

isdn incoming-voice voice

no cdp enable

!

router eigrp 1

network 172.16.0.0

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.1.250

ip route 172.16.40.0 255.255.255.0 172.16.1.6

no ip http server

!

logging trap warnings

logging 172.16.1.185

radius-server host 172.16.1.185 auth-port 1812 acct-port 1813 timeout 10 retransmit 3 key 7 13161211

190910

radius-server retransmit 3

radius-server timeout 10

!

voice-port 1/0/0

!

voice-port 1/0/1

!

voice-port 1/1/0

!

voice-port 1/1/1

!

voice-port 2/0:23

input gain 6

output attenuation 6

no comfort-noise

!

voice-port 2/1:1

input gain 6

output attenuation 6

no comfort-noise

!

dial-peer cor custom

!

!

!

dial-peer voice 1 pots

destination-pattern 9T

progress_ind alert enable 8

progress_ind progress enable 8

progress_ind connect enable 8

direct-inward-dial

port 2/0:23

!

dial-peer voice 100 voip

preference 1

destination-pattern 6302...

progress_ind setup enable 3

voice-class h323 1

session target ipv4:172.16.56.2

dtmf-relay h245-alphanumeric

codec g711ulaw

ip precedence 5

no vad

!

dial-peer voice 101 voip

preference 2

destination-pattern 6302...

progress_ind setup enable 3

session target ipv4:172.16.56.1

dtmf-relay h245-alphanumeric

codec g711ulaw

ip precedence 5

no vad

!

dial-peer voice 2 pots

destination-pattern 91T

progress_ind alert enable 8

progress_ind progress enable 8

progress_ind connect enable 8

port 2/1:1

!

dial-peer voice 1800 pots

destination-pattern 91800T

progress_ind alert enable 8

progress_ind progress enable 8

progress_ind connect enable 8

direct-inward-dial

port 2/0:23

prefix 1800

!

dial-peer voice 1888 pots

destination-pattern 91888T

progress_ind alert enable 8

progress_ind progress enable 8

progress_ind connect enable 8

direct-inward-dial

port 2/0:23

prefix 1888

!

dial-peer voice 1866 pots

destination-pattern 91866T

progress_ind alert enable 8

progress_ind progress enable 8

progress_ind connect enable 8

direct-inward-dial

port 2/0:23

prefix 1866

!

dial-peer voice 1877 pots

destination-pattern 91877T

progress_ind alert enable 8

progress_ind progress enable 8

progress_ind connect enable 8

direct-inward-dial

port 2/0:23

prefix 1877

!

dial-peer voice 102 voip

preference 1

destination-pattern 6303...

progress_ind setup enable 3

voice-class h323 1

session target ipv4:172.16.56.2

dtmf-relay h245-alphanumeric

codec g711ulaw

ip precedence 5

no vad

!

dial-peer voice 103 voip

preference 2

destination-pattern 6303...

progress_ind setup enable 3

session target ipv4:172.16.56.1

dtmf-relay h245-alphanumeric

codec g711ulaw

ip precedence 5

no vad

!

dial-peer voice 104 voip

preference 1

destination-pattern 6304...

progress_ind setup enable 3

voice-class h323 1

session target ipv4:172.16.56.2

dtmf-relay h245-alphanumeric

codec g711ulaw

ip precedence 5

!

dial-peer voice 105 voip

preference 2

destination-pattern 6034...

progress_ind setup enable 3

session target ipv4:172.16.56.1

dtmf-relay h245-alphanumeric

codec g711ulaw

ip precedence 5

!

dial-peer voice 106 voip

preference 1

destination-pattern 26..

progress_ind setup enable 3

voice-class h323 1

session target ipv4:172.16.56.2

dtmf-relay h245-alphanumeric

codec g711ulaw

ip precedence 5

!

dial-peer voice 107 voip

preference 2

destination-pattern 26..

progress_ind setup enable 3

session target ipv4:172.16.56.1

dtmf-relay h245-alphanumeric

codec g711ulaw

ip precedence 5

!

dial-peer voice 108 voip

preference 1

destination-pattern 38..

progress_ind setup enable 3

voice-class h323 1

session target ipv4:172.16.56.2

dtmf-relay h245-alphanumeric

codec g711ulaw

ip precedence 5

!

dial-peer voice 109 voip

preference 2

destination-pattern 38..

progress_ind setup enable 3

session target ipv4:172.16.56.1

dtmf-relay h245-alphanumeric

codec g711ulaw

ip precedence 5

!

dial-peer voice 110 voip

preference 1

destination-pattern 40..

progress_ind setup enable 3

voice-class h323 1

session target ipv4:172.16.56.2

dtmf-relay h245-alphanumeric

codec g711ulaw

ip precedence 5

!

dial-peer voice 111 voip

preference 2

destination-pattern 40..

progress_ind setup enable 3

session target ipv4:172.16.56.1

dtmf-relay h245-alphanumeric

codec g711ulaw

ip precedence 5

!

dial-peer voice 3 pots

destination-pattern 9011T

progress_ind alert enable 8

progress_ind progress enable 8

progress_ind connect enable 8

port 2/1:1

prefix 011

!

dial-peer voice 4 pots

destination-pattern 6000

port 1/1/0

!

gateway

!

banner motd ^C

**********************************************************************

* *

* WARNING: Use of this system is restricted to authorized GSX users. *

* All activity is monitored, recorded and reviewed. *

* *

**********************************************************************

* This system is for use of authorized users only. Individuals using *

* this computer system without authority, or in excess of their *

* authority, are subject to having all of their activities on this *

* system monitored and recorded by operations personnel. *

* *

* In the course of monitoring individuals improperly using this *

* system, or in the course of system maintenance, the activities of *

* authorized users may also be monitored. Anyone using this system *

* expressly consents to such monitoring. Anyone using this system *

* expressly consents to any evidence collected through monitoring *

* of criminal or malicious activity be reported to law enforcement. *

**********************************************************************

^C

!

line con 0

exec-timeout 0 0

logging synchronous

transport input none

line aux 0

modem InOut

modem autoconfigure discovery

speed 300

flowcontrol hardware

line vty 0 4

login authentication safeword

!

end

3640-GSX-R1#

5 REPLIES
Cisco Employee

Re: Unity issue

Perhaps you are having intermittent duplex mismatches.

Especially since you are using a VLAN trunk interface between the router and the switch, you want to hard-code the speed and duplex to 100/full on both the router FastEthernet interface as well as the switch port.

New Member

Re: Unity issue

Thank you for the suggestion. I will certainly take a look at that. We also upgraded the Unity TSP driver so hopefully that will give us some help as well.

Kind Regards,

Mike

New Member

Re: Unity issue

Hi Mike,

I need your help please. Having a similar scenario as yours but I'm not familiar with the 3640 config as H323 device. My scenario is as follows:

PSTN--t1 pri--3640--ethernet--3524--CM1

So I assume that 3640 is talking h323 to CM1, am I correct ? and "dial-peer voip" statements are for voice connections to CM1 ? do you have FXS ports in your config because I'd seen "dial-peer pots" statements ? Can you post the "show diag" so I know what interfaces in your 3640 ? Thank you very much.

Duc Vu

New Member

Re: Unity issue

Duc,

On the 3640, i have a NM-2HDV (with 2 T1 controllers) 1-NM-2V (1- 2 port FXS for polycom conference phones and 1-2 port FXO for backup PSTN access. It also has a Fastethernet interface as well. I can't do a show diag today as I'm not at the customer site.

All your assumtions were correct.

New Member

Re: Unity issue

What version of Unity and CCM are you using?? I have noticed problems like that in versions prior to 2.4.6 with distortion... 2.4.6 and the latest TSP should take care of that...

In addition, the recording level or playback level may just be too hot... there is a utility on www.answermonkey.net called wavegain that can adjust the appropriate registry entries to modify wave levels.... just beware that even the the lead Unity Product Architect wrote the utility, Cisco doesn't officially support it...

147
Views
0
Helpful
5
Replies
CreatePlease to create content