Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Unity Server Configuration Wizard fails - SQL Error

Inital setup runs fine. After rebooting and trying to run Configuration Setup, I get the following message in a Setup pop-up box:

The following problem was found while verifying that the system meets the installation requirements:

Unable to open a SQL Connection to the Unity database.

System is only DC for domain/forest

Windows 2000 SP2

E2K SP3 Installed

Unity 3.1(3)

MSDE 2000 w/SP2

I installed SQL Enterprise Manager and looked at the databases. There does not appear to be anything for Unity. What should show up? Any ideas on how to get past this?

Thanks

4 REPLIES
Cisco Employee

Re: Unity Server Configuration Wizard fails - SQL Error

That's a bit odd... there should be a UnityDB database in there with all the tables and some default objects that the configuration setup then pushes to the directory (i.e. example admin, unaddressed messages DL etc...). the only reason I can think for this to fail is if you were not logged in as a member of the local admins group (built ins for a DC) and didn't have proper read/write access to SQL - however sysCheck should have caught it in that case.

Try firing up the ConfigMgr.exe under the \commserver directory and running each of the first 7 options in order from the top down (database schema script, datbase extended script, configure database schema, run database localization prep script, run database configuration script, run rules configuration script, run schedules configuration script) and see if it creates the tables properly or throws up an error... if it creates the stuff properly go ahead and also select the "configure default location" option and then try the configuration step again.

New Member

Re: Unity Server Configuration Wizard fails - SQL Error

That worked great! Thanks. It got past that part. Now it runs through selecting version of exchange, choosing the account (I'm using Administrator), and selecting the OU (Users). Then it says configuring, then errors out with this:

Failed to reassign the Installer's account to the current user.

You will need to run this installer again.......

I'm going to see if I can find something on this on CCO, but if you have any quick ideas, I'd be happy to hear them.

Thanks

OK - I tried this:

D:\CommServer>grantunityaccess -u spirenet\administrator -s EAdministrator

Failed getting subscriber's object ID from database.

-- Operation FAILED --

Logfile generated: D:\CommServer\logs\GrantUAccess_3d593c60.txt

Here is content of the GrantUAccess_3d593c60.txt file:

Tue Aug 13 12:05:36.66 Entering Initialize \ConnectorClientBase.cpp (line 48)

Tue Aug 13 12:05:38.129 Exiting Initialize \ConnectorClientBase.cpp (line 89)

Tue Aug 13 12:05:38.750 GetDC returning '\\spirewin2k.spirenet.com' (dwErr = 0) \GrantAccess.cpp (line 134)

Tue Aug 13 12:05:38.880 Using local DC \\spirewin2k.spirenet.com \GrantAccess.cpp (line 153)

Tue Aug 13 12:05:39.170 GetDC returning '\\SPIREWIN2K' (dwErr = 0) \GrantAccess.cpp (line 134)

Tue Aug 13 12:05:39.671 Using user's domain DC \\SPIREWIN2K \GrantAccess.cpp (line 163)

Tue Aug 13 12:05:39.911 Entering GetSimpleFilter \ConnectorClientBase.cpp (line 412)

Tue Aug 13 12:05:40.452 Exiting GetSimpleFilter \ConnectorClientBase.cpp (line 428)

Tue Aug 13 12:05:41.604 Entering GetRowSet \ConnectorClientBase.cpp (line 105)

Tue Aug 13 12:05:43.446 Exiting GetRowSet \ConnectorClientBase.cpp (line 121)

Tue Aug 13 12:05:44.948 Entering GetOneRow \ConnectorClientBase.cpp (line 127)

Tue Aug 13 12:06:10.324 spRowset->Item(0) reports no more rows. Exiting function. \ConnectorClientBase.cpp (line 134)

Tue Aug 13 12:06:12.597 Failed getting rowset for subscriber EAdministrator Exiting Function. 0x8004010f \GrantAccess.cpp (line 344)

Cisco Employee

Re: Unity Server Configuration Wizard fails - SQL Error

sounds like your subscriber table still isn't populated properly and/or it is populated properly but the config mgr couldn't create the users in the directory. This could be because the account you're installing with doesn't have rights to create those containers/users properly...

check in the UnitydB database and look in the subscriber table... if you see the Example Admin in there go and look to see if it got a direcotry ID value. If you don't see anything in the subscriber table, at this point I'd probably back it out and take another run at it... make sure to run the PermissionsWizard before starting the install process to make sure the install account and the directory facing accounts have all the juice they need to get setup complete, that sometimes catches some problems.

New Member

Re: Unity Server Configuration Wizard fails - SQL Error

CommMgr was able to create the users. I just hadn't checked this option (my bad). I used it to create the user, it installed fine. We're up and running on Unity. Thanks a bunch, lindborg!

165
Views
0
Helpful
4
Replies
CreatePlease login to create content