Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Unity Subscriber Template "page cannot be found"

We are experiencing a problem with the SA, but only under the Subscriber Template pages. All other pages are fine. If you go to the main Subscriber Template page, the profile comes up. If you select any of the other sub-menu items, a 404 error comes up. If you click another sub-menu item you get an asp script error message which is below:<br><br>A Runtime error has occurred.<br>Line 76<br>Error: 'top.PageMain.PageBody.frames' is null or not an object.<br><br>Any ideas?<br><br><br>Matt Slaga <img src="/images/icons/wink.gif"><br>Dimension Data US<br><font color=red>MCNE</font color=red>, <font color=blue>MCSE2k</font color=blue>, <font color=purple>CCNP/DA</font color=purple>

7 REPLIES
Anonymous
N/A

Re: Unity Subscriber Template "page cannot be found"

Hmmmm... that's odd. It could be that the corresponding call handler for that template is missing. Subscribers are made up of a Mail User object and a Call Handler object bound together, same deal for the template. If the call handler link were broken or the call handler somehow removed/damaged, it would have problems loading that info.

Can you create a new template or does that fail as well (new vs. based on existing)?

Can you pop into DOHPropTest and look around for me? If you're on 2.4.6 you can do this in read only mode without a password... if not, we'll have to get you to call support and take a look. Go to the "mail user templates" collection and select the one you're having problems with. Select the "Call Handler Object ID" property on the right and make a note of it... this is a superset of the distinguished name which should include the alias of the object in question. It'll be something like "ch_defaulttemplatexxxxx". Then select the "Call handlers" collection and find that object. If it's not there, that's your problem. We can recreate it pretty easily using ConfigMgr (the guy that setup uses to create the default database settings)

If it is there, perhaps a property on there is missing or invalid (not sure how that would happen). In this case we'd need to remove both the template and it's corresponding call handler and then recreate it using ConfigMgr.






Jeff Lindborg
Unity Product Architect/Answer Monkey
Cisco Systems
lindborg@cisco.com
http://www.AnswerMonkey.net (new page for Unity support tools and scripts)

New Member

Re: Unity Subscriber Template "page cannot be found"

Well, according to DOHProptest, the object under the call handlers collection was not there. Like you said, there was no link between the two. I created a new template and it seems to work fine. The original still had errors and I removed it. Thanks for your fast and accurate response, your help IS greatly appreciated!



Matt Slaga
Dimension Data US
MCNE, MCSE2k, CCNP/DA

Anonymous
N/A

Re: Unity Subscriber Template "page cannot be found"

sweet!

score one for the public education system...


Jeff Lindborg
Unity Product Architect/Answer Monkey
Cisco Systems
lindborg@cisco.com
http://www.AnswerMonkey.net (new page for Unity support tools and scripts)

Cisco Employee

Re: Unity Subscriber Template "page cannot be found"

Hello

I have a customer with a very similar situation. They are getting a run-time error everytime they attempt to add a new subscriber (specifically when they hit the blue "+" sign). Since this is a new system, I was hoping running config manager would possibly reset to their defaults. It did not. Yes, I was stretching a bit, but you gotta try.

My next move is to explore DPT. Where would you recommend looking in DPT to see if any related call handler link was broken or damaged? Where is the subscriber page linked in DPT?

For background info, they must have deleted their adminstrator account, so they were locked out of SA. I had them use the back door to get into SA and then try to re-create their administrator account in Exchange and re-import in Unity. Creating the account in Exchange went fine, but when we tried to import the user via SA, it gave us an error that the object had been deleted. This message persisted even after 5-10 minutes (hoping Exchange would synch up). Expecting that this account was deleted, but left an orphaned call handler, I suggested we run Directory Walker. I had the customer download and install. When they ran it, they got 9 errors - nothing major (so I thought). After the fact, I found out they still had SA open - specifically to the Add Subscriber screen. Now when we attempt to return to this location in SA, we get the run time error.

That being said, what are our options?

Thanks in advance.

Jeff Schlesser
CSE
TAC Engineer
408-527-4204

Anonymous
N/A

Re: Unity Subscriber Template "page cannot be found"

What's the error they're getting? What version are you running on? 2.4.5 versions had an issue if the default NT pw was too short for their site's configuration and it would just fail with an "unknown error has occured" thing for instance. Another problem centered around trying to add a user via the template to a distribution list that had a bunch of folks in it (it would time out checking to see if that guys was already a member). A number of possible reasons why such an error would come up... not sure what you mean by "run time error".

Does this happen only when they import certain accounts? When they create new accounts? Have you tried using a different/new template?


Jeff Lindborg
Unity Product Architect/Answer Monkey
Cisco Systems
lindborg@cisco.com
http://www.AnswerMonkey.net (new page for Unity support tools and scripts)

Cisco Employee

Re: Unity Subscriber Template "page cannot be found"

Well, the error they get is a run time error, with a line number - I will get the exact message. But the important part is that it comes everytime they click on the "add subscriber" button - and get no further. So they have no option to using a different template or importing accounts - it never gets that far!!

This is Unity 2.4.6 - brand new installation with really no users added. It appears as they just finished installing Unity and then proceeded to remove the adminstrator account they used to install Unity. Not the best idea, but that is the original reason they opened the case. Once I got them in the back door (using Example Administrator), we checked to see if their Administrator account was in Exchange or in Unity - it was in neither. So I thought I'd help them recreate that account in Exchange and then import it back into Unity, give it the Default Administrator COS and then return the Example Administrator back to its original state (no NT account).

Upon attemping to import the Administrator account into Unity, we could see the account, but it would not let us import it. It stated that this object was deleted. Since we had created the account with the same name as previously, I was led to believe that what we were actually seeing is the old Administrator account that was deleted before they called me! So, here we go again - I had the customer run DB Walker to remove any lingering orphaned accounts. The customer had SA open to the "add subscriber" page - the same page we are no longer able to open. I am thinking that the "add new subscriber" page might have been damaged when we ran DB Walker. Is this possible? I don't know.

Now this comes back to this question - what can we do at this point? Is there a way to work in DPT to see what might have been damaged? Again, this would help if I had the exact error message.....

Since this is a brand new installation and no users have been added, would it be less work if we just tried to uninstall and re-installing Unity at this point? It may be......

Any feedback is welcomed. Criticism is appreciated too, but don't expect me to smile.....

-js

Jeff Schlesser
CSE
TAC Engineer
408-527-4204

Anonymous
N/A

Re: Unity Subscriber Template "page cannot be found"

I don't really know what to tell you to look for... dbWalker only removes stranded call handlers and mail users (and only then if you check the boxes for that) it makes no other write operations. It would be pretty tough to come up with a scenario that would result in what you're seeing. The error message in question would be helpful but if they haven't added any users I think it's a no-brainer to reinstall. Having removed the install account makes me nervous on a few counts and I'd certainly feel better if they installed again.



Jeff Lindborg
Unity Product Architect/Answer Monkey
Cisco Systems
lindborg@cisco.com
http://www.AnswerMonkey.net (new page for Unity support tools and scripts)

149
Views
0
Helpful
7
Replies
CreatePlease to create content