Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

URGENT: QoS Design on Data Center MPLS - MediaNet Question...

Hello,

I am posting this in hopes I can get some guidance from anyone who has done this in the field.  We have a large enterprise customer with 21 sites all around the world, they have Verizon MPLS and are experiencing QoS related issues on their WAN regarding Video/Voice.  We have proposed remediating their network acccording to the Enterprise QoS SRND 3.3 and the new MediaNet SRND to account for Video and TP QoS (     

http://www.cisco.com/en/US/docs/solutions/Enterprise/WAN_and_MAN/QoS_SRND_40/QoSCampus_40.html )

Here is the problem/question that was proposed in our presales meeting and I honestly don't know where to look for an answer... I am not asking for anyone to design a solution for me, just merely point me in the right direction:

The Data Center has a ~40MB MPLS Connection ( full mesh ) into the cloud ( Verizon )

Site A has a 8MB connection

Site B has a 4MB connection

I know on the Service policy and the interfaces at SiteA and SiteB I can assign "Bandwidth xxxx" and use ~95% of the bandwidth to do queuing and shaping/policing ect.  I am not concerned with SiteA and SiteB, that I think I can handle...

Question was posed from the customer, "How can we ensure at the DataCenter level the 40MB MPLS is "chopped" up so that only 8MB of the total speed goes to SiteA ALONG with an attached QoS policy designed for that specific site, as well as ensure only 4MB goes to SiteB with an attached QoS policy.

So I am looking for a way to allocate bandwith per site on the DC 40MB connection going into the cloud ( so that SiteB cannot use more than 4MB ) and attach a MediaNet specific QoS Service policy to that site.  The customer does not have seperate MPLS circuits for each site, they all come into the DC on 40MB shared ethernet connection ( no VC, or dedicated circuits to other sites ). 

Any thoughts on if this is possible? 

Thanks!

Alex

  • Other Collaboration Voice and Video Subjects
1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: URGENT: QoS Design on Data Center MPLS - MediaNet Question..

This is an example I have seen and I hope that is useful to you.

Site A

Subnet: 172.16.1.0/24

Site B

Subnet:172.16.2.0/24

HeadOffice:

ip access-list extended Site_A

permit ip any 172.16.1.0 0.0.0.255

!

ip access-list extended Site_B

permit ip any 172.16.2.0 0.0.0.255

!

class-map match-any Site_A

match access-group name Site_A

class-map match-any Site_B

match access-group name Site_B

!

policy-map To_Spokes

class Site_A

shape average 8000000

service-policy Sub_Policy(Optional)

!

class Site_B

  shape average 4000000

  service-policy Sub_Policy(Optional)

!

class class-default

  shape average 28000000

  service-policy Sub_Policy(Optional)

!

Interface G0/0

Description To MPLS cloud

bandwidth 40000000

service-policy output To_Spokes

interface G0/1

  Description To HeadOffice

bandwidth 40000000

service-policy output To_Spokes

It would be greatly appreciated if someone can correct this or improve it as I am still learning.

Please see the netflow graph from one of our routers using a similar policy as above.

4 REPLIES
New Member

Re: URGENT: QoS Design on Data Center MPLS - MediaNet Question..

This is an example I have seen and I hope that is useful to you.

Site A

Subnet: 172.16.1.0/24

Site B

Subnet:172.16.2.0/24

HeadOffice:

ip access-list extended Site_A

permit ip any 172.16.1.0 0.0.0.255

!

ip access-list extended Site_B

permit ip any 172.16.2.0 0.0.0.255

!

class-map match-any Site_A

match access-group name Site_A

class-map match-any Site_B

match access-group name Site_B

!

policy-map To_Spokes

class Site_A

shape average 8000000

service-policy Sub_Policy(Optional)

!

class Site_B

  shape average 4000000

  service-policy Sub_Policy(Optional)

!

class class-default

  shape average 28000000

  service-policy Sub_Policy(Optional)

!

Interface G0/0

Description To MPLS cloud

bandwidth 40000000

service-policy output To_Spokes

interface G0/1

  Description To HeadOffice

bandwidth 40000000

service-policy output To_Spokes

It would be greatly appreciated if someone can correct this or improve it as I am still learning.

Please see the netflow graph from one of our routers using a similar policy as above.

New Member

Re: URGENT: QoS Design on Data Center MPLS - MediaNet Question..

Tony,

Thank you VERY much for the reply, that does help and will get me on the right track!

Alex

New Member

Re: URGENT: QoS Design on Data Center MPLS - MediaNet Question..

I am glad that helps. This makes my day:)

Just for your information, if you have sub-interfaces defined on the LAN side, for example, int g0/1.10 for Data traffic while G0/1.20 for Voice traffic, then don't apply the same policy statement "service-policy output To_Spokes" to int G0/1.20, because it would cause your voice call even between extensions choppy.

Cisco Employee

Alex,Sorry to hijack your

Alex,

Sorry to hijack your thread, I could not find you email address anywhere else :) 

Could you mail me at akramadh@cisco.com so that I can reply back with the roadmap features for UCCX 11.0? (the Ask-the-Expert event is closed and I could not reply there)

Cheers,

Abhiram Kramadhati

833
Views
0
Helpful
4
Replies