Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Using vibrate uri

Hi everybody,

I've just realized that vibration feature is added as an xml URIs. Based on 7920 Release Notes for Firmware 3.01:

With firmware release 3.01, the Cisco Unified Wireless IP Phone 7920 can now receive a URI message from a third party XML application that activates the vibrate device on the phone. You can use these parameters to customize the vibration sequence:

Vibrate Duration?Sets the vibrate-on interval in milliseconds

Silence Duration?Sets the vibrate-off interval in milliseconds

Count?Sets the number of times to repeat the vibrate on/off sequence

Syntax for the vibrate URI is:

Vibrate:[{vibrateDuration}:{silenceDuration}:{count}]

I am testing a 7920 with cmterm_7920.4.0-03-01 firmware which is newer that 3.01.

In user profile, I have set ?VibratingCallAlert? to ?on? and ?Warning Style? to ?Vibration? and when I call phone, it vibrates.

When I pushed Vibrate URI with this

<ExecuteItem Priority="0" URL="Vibrate:[1000:1000:5]"/>

I do not get error which shows that phone understands the xml. However it does not vibrate.

Anybody has tried this feature?

I appreciate all your feedbacks,

Thanks,

Parisa

4 REPLIES
New Member

Re: Using vibrate uri

I would love to try vibrate feature. Anyone got it working?

New Member

Re: Using vibrate uri

Hi,

I haven't had any success with 7920's, but 7921G's work nice (firmware 1.03)

Cheers,

Sami

New Member

Re: Using vibrate uri

I also got same result. works for 7921 only.

There most be some setting issues on phone. I hope somebody would have experienced and share with us.

Thanks,

Parisa

New Member

Re: Using vibrate uri

I got it working on 7920 and 7921, here is the correct syntax:

163
Views
0
Helpful
4
Replies
CreatePlease to create content