Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VG200 with PRI and Call Manager

Hi there,

I am having a problem to make out bound or getincoming calls via my VG200 Gateway.

Guys this is the first time I am trying this, and using MGCP so I am lost, I had a look at http://www.cisco.com/en/US/tech/tk652/tk701/technologies_configuration_example09186a00800c3246.shtml (How to Configure MGCP with Digital PRI and Cisco CallManager) but it is not helping me much.

When I phone the Primary number, I don't get dial tone or anything, it seems to go though, its quite for a few seconds, and then the phone gives me a busy tone too,

Ok here is my configuration.

My CCM IP is 10.1.1.10

My VG200 Gateway is 10.1.1.11, it has a NM-HDV with Sub Unit VWIC-1MFT-E1 PRI card in it

IP Phone is 10.1.1.12 with Number 2001

This is my configuration from my VG200

Router_A_vg200#show run

Building configuration...

Current configuration : 1488 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router_A_vg200

!

enable password cisco

!

voice-card 1

!

ip subnet-zero

no ip domain-lookup

!

mgcp

mgcp call-agent 10.1.1.10

mgcp dtmf-relay codec all mode out-of-band

call rsvp-sync

isdn switch-type primary-net5

!

voice class codec 1

!

!

!

voice class h323 1

h225 timeout tcp establish 30

!

!

!

ccm-manager switchback graceful

ccm-manager mgcp

!

controller E1 1/0

pri-group timeslots 1-31

description Net5 link to PSTN

!

!

interface FastEthernet0/0

ip address 10.1.1.11 255.255.255.0

no ip mroute-cache

speed 100

full-duplex

!

interface Serial1/0:15

no ip address

no logging event link-status

isdn switch-type primary-net5

isdn incoming-voice voice

isdn T309-enable

no cdp enable

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.1.1.1

no ip http server

ip pim bidir-enable

!

!

voice-port 1/0:15

timeouts interdigit 2

!

dial-peer voice 1 pots

application mgcpapp

destination-pattern 0...

direct-inward-dial

port 1/0:15

forward-digits all

!

dial-peer voice 7 pots

destination-pattern 7T

port 1/0:15

forward-digits 0

!

dial-peer voice 2001 voip

destination-pattern 2001

session target ipv4:10.1.1.10

ip precedence 5

!

gateway

!

!

On my Call Manager I set my Route pattern as follows

Route pattern : 7.@

Gateway/ Route List : S1/DS1-0@10.1.1.11

Discard Digits : PreAt

5 REPLIES
Silver

Re: VG200 with PRI and Call Manager

Can you post sh ccm an sh mgcp from the vg200?What happens to the outgoing calls?What is the ios version?

In general your pots dial-peer (only one per pri!!) is controlled by the callmanager and should be configured like that

!

dial-peer voice 1 pots

application mgcpapp

port 1/0:15

!

And your controller settings are wrong..

Here is the working configuration for you...(also verify if the framing is crc4 or no-crc4 with pstn..)

configuration : 1701 bytes

!

version 12.2

no parser cache

no service single-slot-reload-enable

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname test

!

logging rate-limit console 10 except errors

enable password cisco

!

voice-card 1

!

ip subnet-zero

!

no ip dhcp-client network-discovery

mgcp

mgcp call-agent 10.1.1.10 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode cisco

mgcp sdp simple

mgcp package-capability rtp-package

mgcp package-capability sst-package

no mgcp timer receive-rtcp

no mgcp explicit hookstate

call rsvp-sync

isdn switch-type primary-net5

isdn voice-call-failure 0

!

!

!

!

!

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 10.1.1.10

ccm-manager config

!

controller E1 1/0

framing NO-CRC4

pri-group timeslots 1-31 service mgcp

!

!

interface FastEthernet0/0

ip address 10.1.1.11 255.255.255.0

duplex auto

speed auto

!

interface Serial1/0:15

no ip address

no logging event link-status

isdn switch-type primary-net5

isdn overlap-receiving

isdn incoming-voice voice

isdn bind-l3 ccm-manager

isdn sending-complete

no cdp enable

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.1.1.1

no ip http server

!

!

voice-port 1/0:15

!

dial-peer voice 1 pots

application mgcpapp

port 1/0:15

!

!

line con 0

line aux 0

line vty 0 4

I dont like the discard digits preAt as well, predot is much better

New Member

Re: VG200 with PRI and Call Manager

I have changed most of my configuration to be simlar to yours. as well as putting only one pots dial-peer in. as well as changed my call manager to be predot.

Here is my sh ccm

Router_A_vg200#sh ccm

MGCP Domain Name: Router_A_vg200

Total number of host: 1

Priority Status Host

============================================================

Primary Registered 10.1.1.10

First backup Undefined

Second backup Undefined

Current active Call Manager: 10.1.1.10

Current backup Call Manager: None

Redundant link port: 2428

Failover Interval: 30 seconds

Keepalive Interval: 15 seconds

Last keepalive sent: 1d23h (elapsed time: 00:00:27)

Last MGCP traffic time: 1d23h (elapsed time: 00:00:13)

Last switchover time: None

Switchback mode: Graceful

and sh mgcp

Router_A_vg200#sh mgcp

MGCP Admin State ACTIVE, Oper State ACTIVE - Cause Code NONE

MGCP call-agent: 10.1.1.10 Initial protocol service is MGCP

MGCP block-newcalls DISABLED

MGCP dtmf-relay codec all mode out-of-band

MGCP modem passthrough: CA

MGCP request timeout 500, MGCP request retries 3

MGCP gateway port: 2427, MGCP maximum waiting delay 3000

MGCP restart delay 0, MGCP vad DISABLED

MGCP simple-sdp ENABLED

MGCP undotted-notation DISABLED

MGCP codec type g711ulaw, MGCP packetization period 20

MGCP JB threshold lwm 30, MGCP JB threshold hwm 150

MGCP LAT threshold lwm 150, MGCP LAT threshold hwm 300

MGCP PL threshold lwm 1000, MGCP PL threshold hwm 10000

MGCP playout mode is adaptive 60, 4, 200 in msec

MGCP IP ToS low delay disabled, MGCP IP ToS high throughput disabled

MGCP IP ToS high reliability disabled, MGCP IP ToS low cost disabled

MGCP IP precedence 5, MGCP default package: line-package

MGCP supported packages: gm-package dtmf-package trunk-package line-package

hs-package rtp-package

I have added the VG200 as an MGCP gateway in the call manager as a Cisco VG200 gateway type, and Device protocol = No Required for MGCP, thats the o

When I call from the VoIP side, I get no events, it is as if the Call manager is not sending anything to the gateway.

I have put a debug on MGCP events on when I call from the PSTN here it is

1d23h: mgcpapp_process_ccapi_ev: CALL_SETUP_IND

1d23h: callp : 815484D8, state : 0, call ID : -1, event : 10, minor evt: -213542

5024

1d23h: MGCPAPP state machine: state = 0, event = 10mgcp_process_off_hook:

1d23h: process_det_mgcp_offhook(): callp=815484D8

1d23h: process_event_actions(): callp=815484D8, sig_q 0

1d23h: send_mgcp_notify_msg, voice_if 811C01B4, obs_evt_q_ptr 81547338, endpt S-

32745/DS1-0/2@Router_A_vg200setup_ipsocket: laddr=10.1.1.11, lport=2427, fa

ddr=10.1.1.10, fport=2427

1d23h: mgcp_enq_retx_msg:, voice_if 811C01B4, trans_id 15789, ntfy_ent

1d23h: send_mgcp_notify_msg NTFY Packet sent successfully - S-32745/DS1-0/2

1d23h: mgcp_enable_det_evt_list

1d23h: callp : 815484D8, new state : 1, call ID : 26

Entered mgcp_retx_msg

1d23h: Retx msg:notify_entity=,raddr=10.1.1.10,rport=2427, first_retx=1

1d23h: Retransmit msg to raddr=10.1.1.10,rport=2427 from laddr=0.0.0.0,lpor

t = 0setup_ipsocket: laddr=10.1.1.11, lport=2427, faddr=10.1.1.10, fpo

rt=2427

1d23h: mgcp_retx_msg: SUCCESSFUL retransmission

1d23h: retx msg again, retx_cnt=1

1d23h: MGCP Process timer Complete:Entered mgcp_retx_msg

1d23h: Retx msg:notify_entity=,raddr=10.1.1.10,rport=2427, first_retx=0

1d23h: Retransmit msg to raddr=10.1.1.10,rport=2427 from laddr=0.0.0.0,lpor

t = 0setup_ipsocket: laddr=10.1.1.11, lport=2427, faddr=10.1.1.10, fpo

rt=2427

1d23h: mgcp_retx_msg: SUCCESSFUL retransmission

1d23h: retx msg again, retx_cnt=2

1d23h: MGCP Process timer Complete:Entered mgcp_retx_msg

1d23h: Retx msg:notify_entity=,raddr=10.1.1.10,rport=2427, first_retx=0

1d23h: Retransmit msg to raddr=10.1.1.10,rport=2427 from laddr=0.0.0.0,lpor

t = 0setup_ipsocket: laddr=10.1.1.11, lport=2427, faddr=10.1.1.10, fpo

rt=2427

1d23h: mgcp_retx_msg: SUCCESSFUL retransmission

1d23h: retx msg again, retx_cnt=3

1d23h: MGCP Process timer Complete:MGCP sys msg: (13, 0)

xlate sys msg: (13, 81546590)

sys msg values: (13, 8, 1, 0)

1d23h: CMAPP: process mgcp_handle_cmapp_event

1d23h: CMAPP: mgcp_cmapp_send_keepalive: cm_ipaddr=10.1.1.10 cm_port=2427

1d23h: CMAPP: notify_entity=10.1.1.10:2427

1d23h: gateway host is Router_A_vg200

1d23h: CMAPP: mgcp_cmapp_send_empty_notify_msg: voice_if 80DD93E8, complete_endp

t *@Router_A_vg200setup_ipsocket: laddr=10.1.1.11, lport=2427, faddr=10.1.1.10, fport=2427

1d23h: mgcp_enq_retx_msg:, voice_if 80DD93E8, trans_id 15790, ntfy_ent

1d23h: mgcp_cmapp_send_empty_notify_msg NTFY Packet sent successfully - *Entered

mgcp_retx_msg

1d23h: Retx msg:notify_entity=,raddr=10.1.1.10,rport=2427, first_retx=1

1d23h: Retransmit msg to raddr=10.1.1.10,rport=2427 from laddr=0.0.0.0,lpor

t = 0setup_ipsocket: laddr=10.1.1.11, lport=2427, faddr=10.1.1.10, fpo

rt=2427

1d23h: mgcp_retx_msg: SUCCESSFUL retransmission

1d23h: retx msg again, retx_cnt=1

1d23h: MGCP Process timer Complete:Entered mgcp_retx_msg

1d23h: Retx msg:notify_entity=,raddr=10.1.1.10,rport=2427, first_retx=0

1d23h: Retransmit msg to raddr=10.1.1.10,rport=2427 from laddr=0.0.0.0,lpor

t = 0setup_ipsocket: laddr=10.1.1.11, lport=2427, faddr=10.1.1.10, fpo

rt=2427

1d23h: mgcp_retx_msg: SUCCESSFUL retransmission

1d23h: retx msg again, retx_cnt=2

1d23h: MGCP Process timer Complete:Entered mgcp_retx_msg

1d23h: Retx msg:notify_entity=,raddr=10.1.1.10,rport=2427, first_retx=0

1d23h: Retransmit msg to raddr=10.1.1.10,rport=2427 from laddr=0.0.0.0,lpor

t = 0setup_ipsocket: laddr=10.1.1.11, lport=2427, faddr=10.1.1.10, fpo

rt=2427

1d23h: mgcp_retx_msg: SUCCESSFUL retransmission

1d23h: retx msg again, retx_cnt=3

1d23h: MGCP Process timer Complete:Entered mgcp_retx_msg

1d23h: Retx msg:notify_entity=,raddr=10.1.1.10,rport=2427, first_retx=0

1d23h: Retransmission Counts exceed. No alternate IP Addresses available.

1d23h: MGCP Process timer Complete:

1d23h: callp : 815484D8, state : 1, call ID : 26, event : 11, minor evt: 74

1d23h: MGCPAPP state machine: state = 1, event = 11

1d23h: mgcp_process_on_hook: callp=0x815484D8 call_id=26

1d23h: process_det_mgcp_media_event: callp=815484D8, major_ev_t 12, minor_ev 74

1d23h: mgcp_process_detected_evt: callp=815484D8, event=74 persistent_evts=FALSE

1d23h: mgcp_process_detected_evt: callp=815484D8, event=74 persistent_evts=TRUE

1d23h: mgcp_cleanup_media_evt_lists

mgcp_delete_req_digit_filter_q

mgcp_delete_qb_evt_q:cleanup QB evt q

1d23h: mgcp_disconnect_call_leg O.K. call_id=26

1d23h: callp : 815484D8, new state : 6, call ID : 26

1d23h: callp : 815484D8, state : 6, call ID : 26, event : 8, minor evt: -2135425

024

1d23h: MGCPAPP state machine: state = 6, event = 8

1d23h: mgcp_call_disconnected: callp=0x815484D8 call_id=26

1d23h: mgcp_call_disconnected: voice_if->ntfy_queue=811C01D8, ntfy_qhead=0, ntfy

_qtail=0

1d23h: callp : 815484D8, new state : 0, call ID : -1

Entered mgcp_retx_msg

1d23h: Retx msg:notify_entity=,raddr=10.1.1.10,rport=2427, first_retx=0

1d23h: Retransmission Counts exceed. No alternate IP Addresses available.

1d23h: MGCP Process timer Complete:MGCP sys msg: (13, 0)

xlate sys msg: (13, 814775E0)

New Member

Re: VG200 with PRI and Call Manager

Here is a trace on h.245 debug.

This is when I phone from the PSTN into the gateway, Could this mean that there is a problem with my Configuration of the call manager, and not the gateway ??? Cause from this what I think I see is that the Gateway sends the messages, but the call manager does not accept it ??? Am I wrong ???

Router_A_vg200(config)#Changing to new event: CONNECT

h323chan_chn_connect: connecting to 10.1.1.10:1720

2d18h: h323chan_gw_conn: connect in progress on socket [1]h323chan_chn_con

nect: using fd 1, owner_data(ccb) 0x811CBA40

changing from NONE state to CONNECTING state

h323chan_chn_process_read_socket: fd (1) of type CONNECT_PENDING has data

Changing to new event: CONNECTED

changing from CONNECTING state to CONNECTED state

Hex representation of the SETUP TPKT to send.030000C0080200060504039090A37005813

23030317E00A8052080060008914A00020880013C050100002B7277B3171D11CC8068B4EE0E1B7C7

300451C0700C40FDC7B414611002B7277B3171D11CC8069B4EE0E1B7C733202120000000D4001800

A04000100C40FDC7B45811D400000060401004D4001801114000100C40FDC7B458000C40FDC7B458

10100010006A001002D0140B500001226E001010001A116A104039090A31803A9838E1E028483700

58133353030028006000400000003

2d18h: h225SetupRequest: Q.931 SETUP sent from socket [1]h323chan_chn_process_re

ad_socket: fd (1) of type CONNECTED has data

2d18h: H323chan Lib: No Data on socket [1]:

PROCESS_READ: NOT COMPLETE, rc 10, fd=1

h323chan_chn_process_read_socket: fd (1) of type CONNECTED has data

2d18h: h323chan_recvdata:Connection lost socket [1]

2d18h: h323chan_close: TCP connection from socket [1] closedh225TerminateR

equest: Unidentifiable socket -1

Silver

Re: VG200 with PRI and Call Manager

The show ccm output you posted does not show all the info, could you post the full output,please? The second part of it would show us the config downloading information .

On the gateway configuration page, what is the gateway's registration status?

It looks to me as there is something wrong with callmanager configuration.

Another thing to verify is vg200 host name should match the gateway name that is specified in the CallManager configuration (Router_A_vg200 in your case).Can you try to ping vg200 from the callmanager and if you can't ping it by the hostname ,please add the hostname to the hosts file..

New Member

Re: VG200 with PRI and Call Manager

Hi,

When you add the VG200 as a MGCP gateway to CallManager you must enter it with the exact name (no IP address) of the router - in your sample config this was "Router_A_vg200".

If you have an "ip domain ...." statement configured on the router this must be appended too - the gateway name in CallManager would then be " Router_A_vg200.domainnamesample.com". You will then need to rework the route pattern.

A "show ccm-manager" will tell you if the gateway is registered, along with looking at the MGCP endpoints info on the gateway config in Callmanager.

Good luck... Phil.C

364
Views
3
Helpful
5
Replies
CreatePlease login to create content