Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

VIDEO OVER IP NETWORK...IS IT WORK..?

I've set up a video conferencing system that consists of Polycom viewstation FX(end point) for 15 sites, Meeting Point(as a conference server) and IP network.

This IP network are like a star topology through 2620 and 3640 routers and all connected to the 7500 router. This network also use for our data and voip. I've also applied the QOS and give priority 5 and 1518 bytes bandwidth to all end point as I have 2MB link to all that point. There are only 2/3 hops router before its go to 7500.

The problem is... the video quality still not good and there are video packet loss up to 2Kbytes.

Do you have any idea to improve my system..?

Your advise is very greatly appreciated.

Example config:

class-map OFIS_TO_MCU

match access-group 100

class-map MCU_TO_OFIS

match access-group 101

!

!

policy-map TO_MCU

class OFIS_TO_MCU

priority 1518

class class-default

fair-queue

policy-map TO_OFIS

class MCU_TO_OFIS

priority 1518

class class-default

fair-queue

interface Serial0/0

description 2MB LINK TO HQ

bandwidth 2048

ip address 192.129.6.5 255.255.255.252

no ip directed-broadcast

no ip mroute-cache

service-policy output TO_MCU

access-list 100 permit udp host 129.6.20.20 host 129.2.20.34 range 2400 3500

access-list 100 permit tcp host 129.6.20.20 host 129.2.20.34 range 2400 3500

access-list 101 permit udp host 129.2.20.34 range 2400 3500 host 129.6.20.20

access-list 101 permit tcp host 129.2.20.34 range 2400 3500 host 129.6.20.20

8 REPLIES
Community Member

Re: VIDEO OVER IP NETWORK...IS IT WORK..?

When do the problems happen? are they when multiple end stations join or just one? What version of Code are you running?

Also, The 2 lines in your access-list 101 aren't necessary if that device is remote to you. You need that remote side to match the host and then apply the LLQ to the remote side as an output service-policy on the wan link pointing back towards you.

Hope that helps.

Community Member

Re: VIDEO OVER IP NETWORK...IS IT WORK..?

Its happen when multiple stations join. All router running on version 12.0(7)T on 2620 and 3640.

I did a test which I connected all 15 end stations on one switch 3524 and it works fine. Thats mean that the conference server is functioning good.

Does it mean that i don't need ACL 101 at all..? Does it mean that you apply the LLQ towards the remote side only ..?

This my config, can u give the best solution..? I've also make sure that all f/a and serial interface have no input/output errors.

HQ : Router 1(7507)

In between router : Router 2(3640)

Remote side : Router 3(2620)

HQ : Router 1

class-map match-all OFIS_TO_MCU

match access-group 100

class-map match-all MCU_TO_OFIS

match access-group 101

!

policy-map TO_MCU

class OFIS_TO_MCU

priority 1518

set ip precedence 5

class class-default

fair-queue

policy-map TO_OFIS

class MCU_TO_OFIS

priority 1518

set ip precedence 5

class class-default

fair-queue

!

interface FastEthernet1/0/0

no ip address

ip route-cache policy

no ip route-cache distributed

full-duplex

!

interface FastEthernet1/0/0.1

description HQ1 LAN

encapsulation dot1Q 1

ip address 129.2.80.21 255.255.0.0

service-policy output TO_MCU

!

interface Serial1/0/0

description Router 1 to ROUTER 2

ip address 206.141.24.1 255.255.255.0

ip route-cache policy

no ip route-cache distributed

service-policy output TO_OFIS

!

access-list 100 permit ip host 141.2.20.20 host 129.2.20.34 precedence critical

access-list 101 permit ip host 129.2.20.34 host 141.2.20.20 precedence critical

!

In between router : Router 2

class-map OFIS_TO_MCU

match access-group 100

class-map MCU_TO_OFIS

match access-group 101

!

!

policy-map TO_MCU

class OFIS_TO_MCU

priority 1518

class class-default

fair-queue

policy-map TO_OFIS

class MCU_TO_OFIS

priority 1518

class class-default

fair-queue

!

interface Serial2/0

description Router 2 to Router 1

bandwidth 2048

ip address 206.141.24.2 255.255.255.0

no ip directed-broadcast

ip route-cache policy

no ip mroute-cache

service-policy output TO_MCU

!

interface Serial2/1

description Router 2 to Router 3

bandwidth 2048

ip address 218.141.2.1 255.255.255.0

no ip directed-broadcast

ip route-cache policy

service-policy output TO_OFIS

!

access-list 100 permit ip host 141.2.20.20 host 129.2.20.34 precedence critical

access-list 101 permit ip host 129.2.20.34 host 141.2.20.20 precedence critical

Remote side : Router 3

class-map OFIS_TO_MCU

match access-group 100

class-map MCU_TO_OFIS

match access-group 101

!

!

policy-map TO_MCU

class OFIS_TO_MCU

priority 1518

class class-default

fair-queue

policy-map TO_OFIS

class MCU_TO_OFIS

priority 1518

class class-default

fair-queue

!

interface FastEthernet0/0

ip address 141.2.81.20 255.255.0.0

no ip directed-broadcast

ip route-cache policy

speed 100

full-duplex

!

interface Serial0/0

description Router 3 To Router 2

bandwidth 2048

ip address 218.141.2.2 255.255.255.0

no ip directed-broadcast

ip route-cache policy

no ip mroute-cache

service-policy output TO_MCU

!

access-list 100 permit ip host 141.2.20.20 host 129.2.20.34 precedence critical

access-list 101 permit ip host 129.2.20.34 host 141.2.20.20 precedence critical

Your reply is greatly appreciate..

Community Member

Re: VIDEO OVER IP NETWORK...IS IT WORK..?

This may be an obvious item, but thought I'd mention it. Make sure your endpoints and the switch port they are connected to are both forced to the same speed and duplex, rather than AUTO/AUTO. We ran into issues with this, initially thought we had a bum MCU; forcing these settings (duplex having the most drastic effect) cleared up all problems. I've had conferences running for *days* w/o a single lost packet, in a network of similar topology to what you described, once we did this.

Hope this helps,

Mike

Community Member

Re: VIDEO OVER IP NETWORK...IS IT WORK..?

I agree with Mike. I just ran into a similar situation today in fact where we were seeing deferred packets on one side of a wan link. Side A is a 1750, frame-relay wan connection in the middle, and a 2621 on the other end. I was not seeing the deferrals on the 1750 side but I was on the 2600. We forced the fast ethernet connection on the 2600 to 100/full and the switch port to be the same and it seems to have eliminated our issue. Prior to that, we were running into freezing issues with the video streams.

As for your question about the best recommendation, I am looking at your configs now, I will post a response once I check them out more closely.

Regards,

Chris

Community Member

Re: VIDEO OVER IP NETWORK...IS IT WORK..?

Just took a look at the configs. First thing, there is no service policy on the ethernet connection on router 3. Not necessarily a big deal, although you do have it on the fast ethernet on the HQ router. Second thing. How many stations are at each site and at what rate are they calling at? If you have 4 calls up at 384k that's a t1's worth of bandwidth and that's not considering overhead of 20% per call. Your access-list is very specific so the question is is this a test access-list and if so, are you having problems with only one head-end placing a call or what? If you oversubscribe your priority queue (which can happen), you can drop packets in excess of the provisioned queue depth. As a rule, use 20% overhead for each call so for a 384k call, use 460k as the queue depth.

You should probably consider a gatekeeper to provide Call Admission control on your network so you can't oversubscribe it.

One last thing. When you are experiencing drops I am guessing you're looking at that on the polycoms? Check the priority queues to see if they are full and dropping any packets..

Hope this helps..

Chris

Community Member

Re: VIDEO OVER IP NETWORK...IS IT WORK..?

Thank a lot for u all. My conferencing is almost succesful. To be answer yr question;

a. I still looking for that configuration (QOS on ethernet)

b.Each site only have 1 station, calls at 384 only (I try to call at 768 but the video quality become bad)

c.Yes I got some other problem..sometimes its happen when I checked (show policy interface Serial...) there is no matched packet on that interface. Sometimes it showed very small matched packet increased. Sometimes it showed ver slow increased)

Do u have any good example how to configure the Cisco 2924/2900 switch so that the video packet can be priotize on the LAN.?

Need some more helps..

Community Member

Re: VIDEO OVER IP NETWORK...IS IT WORK..?

Syahiran and S7077 is the same person...

1. Is it logic that the video packet pass through the router is about 250 packet per second...

2. What is the relation between the video packets and the bandwidth usage for calls ? Does it mean the higher bandwith used will increase the video packet..? As we all know that the 2620 router throughput is about 25 million pps, so that there is nothing compared to 250 pps for the video packet.

Regards..

Community Member

Re: VIDEO OVER IP NETWORK...IS IT WORK..?

Chris,

I also have a similar design where there are 8 remote sites all connecting over frame relay back to our WHQ. I would like to set up QoS on these WAN links to ensure that I am providing my video traffic with at least 480k worth of BW. The data traffic should be alright as the circuit is 768 access, 512 CIR.

I was thinking about applying LLQ with FRTS, but what I've found out is that the WHQ end has one physical interface with several - 100+ - subinterfaces. I've read that I should apply FRTS in this instance as it will apply a default FRTS group where 56k is the default. Is this correct.

Sample config...

conf t

class-map match-all ipvc

match access-group 110

exit

policy-map video

class ipvc

priority 480

class class-default

fair-queue

exit

exit

map-class frame-relay video-policy

no frame-relay adaptive-shaping

frame-relay cir 512000

frame-relay bc 5120

frame-relay be 0

frame-relay mincir 512000

service-policy output video

exit

access-list 110 permit ip host 10.110.x.x host 10.10.y.y

access-list 110 permit ip host 10.10.y.y host 10.110.x.x

interface Serial0/0

bandwidth 768

frame-relay traffic-shaping

exit

interface Serial0/0.1 point-to-point

frame-relay class video-policy

interface Serial0/0.2 point-to-point

frame-relay class video-policy

ctrl + z

If this is the case, what are my other options for QoS on the WAN? Priority Queueing? Custom Queueing?

Thanks.

143
Views
0
Helpful
8
Replies
CreatePlease to create content