Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

View Mail not executing when opening a Voice Mail

Unity 2.4.6, Call Manager 3.0.8<br>I have a user with Outlook 97 with View Mail installed. When she receives a voice mail though, she receives an email with an attached WAV file. The ViewMail within outlook doen not even appear when she receives a voice mail. When she double clicks on the email, the view mail form doesn't pop up. I have also reinstalled the view mail on her machine. Any ideas?<br><br>

8 REPLIES
Anonymous
N/A

Re: View Mail not executing when opening a Voice Mail

Check the message class of the email... all custom forms in outlook have to trigger of message classes and I'm guessing the mail is coming through as an IPM.NOTE (i.e. a generic email) v.s. IPM.Note.Voice.Unity.

here's a link on how to check the message class in Outlook:

http://avforums.isomedia.com/cgi-bin/showthreaded.pl?Cat=&Board=unityent&Number=571&Search=true&Forum=All_Forums&Words=message class&Match=Entire Phrase&Searchpage=0&Limit=25&Old=allposts&Main=479

If it's showing up as IPM.Note, then I'm guessing you're using POP3 or something similiar to get messages to this client (which strips that info). If not, we'll have to take a look at why the VMO form isn't properly registering for that client.


Jeff Lindborg
Unity Product Architect/Answer Monkey
Cisco Systems
lindborg@cisco.com
http://www.AnswerMonkey.net (new page for Unity support tools and scripts)

New Member

Re: View Mail not executing when opening a Voice Mail

I checked her message class and the email is set to IPM.NOTE.VOICE.UNITY. Her icon, instead of being a VMO icon, is a normal mail icon.

Anonymous
N/A

Re: View Mail not executing when opening a Voice Mail

Well... if the message class is correct then the VMO extensions must not be properly registered. When we install we tell Outlook to associate all messages with that message class with our icon and to fire up our forum when the user opens it.

You should probably get a call into TAC and have someone help you out... you can also use the "VMO Cleaner" tool Monica put together that's out on my web site. Run this and make sure all the residual VMO files and forms are gone before trying to reinstall again. If that doesn't work, someone will need to check that particular box to figure out what's going on (I assume this is an isolated work station issue and not something happening all over your network).


Jeff Lindborg
Unity Product Architect/Answer Monkey
Cisco Systems
lindborg@cisco.com
http://www.AnswerMonkey.net (new page for Unity support tools and scripts)

Cisco Employee

Re: View Mail not executing when opening a Voice Mail

I have a customer that had a hard Exchange server crash. So hard that he had to rebuild the message store and PIV(?). Basically it was a tape restore and everything works except for viewmail.

Now when his users try to use viewmail, they get the error message, "Cannot find c:\program files\viewmail\tftxext32.dll" even though it does exist. Then it continues with, "The custom form cannot be used. Outlook with use the Outlook form installed." At which point the email changes to a Media Player attachment and they play the message via this application.

It looks like the restore to their Exchange server overwrote the custom form that Unity created when installed.

Will VMO cleaner fix this - and re-create the custom form that should be used to listen to viewmail? If not, how can we re-create the custom form?

This is Unity 2.4.6 by the way.
Thanks

Jeff Schlesser
CSE
TAC Engineer
408-527-4204

Anonymous
N/A

Re: View Mail not executing when opening a Voice Mail

The VMO install that comes with 2.4.6 SHOULD be smart enough to clean out everything first... have you tried just uninstalling VMO and reinstalling it again? It that doesn't work you can try the VMO cleaner, but the code for VMO cleaner was added to the client install in 2.4.6 so you shouldn't have to run it seperately.


Jeff Lindborg
Unity Product Architect/Answer Monkey
Cisco Systems
lindborg@cisco.com
http://www.AnswerMonkey.net (new page for Unity support tools and scripts)

Cisco Employee

Re: View Mail not executing when opening a Voice Mail

Problem still exists. Customer has WinNT 4.0 clients with SP6a, Office 2000 SR1 with Outlook 2000 client installed. He has attempted to run VMO cleaner, which will succeed in cleaning as far as he can tell. Then the client is rebooted. Once rebooted, the customer will attempt to re-install VMO 2.4.6 client. He reports that the install gets about a third of the way through (using the progress bar), then reports that VMO has finished installing. But upon retrying to bring up a VMO email gets the same results: Cannot find C:\Program files\viewmail\tftxext32.dll. Customer has verified this file does exist here on the system. He has attempted to remove the frmcache.dat file with no luck.

Is there a registry setting that we can examine on this? Obviously Outlook is not looking for this dll in the right spot. I now have two cases on this error, but very different environments. This one seems to be more consistent. NT 4 workstation with IE 5.5, Office 2000, Outlook 2000.

I have examined the Application and system logs to see if there was anything reported when this error comes up. There is absolutely nothing to see. Is there some logging we can enable on their client machines to see if we can get any more feedback?

Thank you.

Jeff Schlesser
CSE
TAC Engineer
408-527-4204

Anonymous
N/A

Re: View Mail not executing when opening a Voice Mail

Jeff,

What would need to be done to use VMO with a client that is using POP3 so that it wont strip the info out of the message class area? Thanks

Anonymous
N/A

Re: View Mail not executing when opening a Voice Mail

POP3 is going to bring you to grief because it just doesn't preserve custom message classes. Not part of the spec. IMAP, however, can be configured to do this for you if you're able to use it.

Here's a thread on just that topic where the folks were able to get it to work using IMAP4:

http://avforums.isomedia.com/cgi-bin/showthreaded.pl?Cat=&Board=unityent&Number=2514&page=&view=&sb=&vc=1#Post2514

-JL


Jeff Lindborg
Unity Product Architect/Answer Monkey
Cisco Systems
lindborg@cisco.com
http://www.AnswerMonkey.net (new page for Unity support tools and scripts)

148
Views
0
Helpful
8
Replies