Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Voice Banwidth Delay

Dear All ,

I am Facing Voice delay in Cisco Call manager ,Recently we shifted our New Office ....Still on off my Voice Gateway is Connecting Through Data link Connection ....Mostly I am Face Delay ....Like when ever i am calling any External Number ,the receiver cannot able to hear my Voice ...

Is there is Any Way to solve this is issue and this High Priority ............

2 REPLIES
Hall of Fame Super Gold

Re: Voice Banwidth Delay

Assuming that you are the end user, and not a Voice Networking Engineer, do you work with a reputable consultant, or UC certified Cisco Partner?

If not, you should, because experience and knowledge are required when working on IP voice systems.

Cisco Employee

Voice Banwidth Delay

The following QoS configuration was put in place and the issue was resolved:

------------------

QOS: MQC  - apply in THIS order

 

step 1 (optional) define ACL

step 2 define class-map 

         call ACL above or match something like rtp, dscp, prec)

step 3 define policy-map

         call class-map(s) above and allocated bandwidth & set action

step 4 apply the policy-map on step 3 to interfaces or DLCI

--------------------

 

MQC EXAMPLE (logical presentation - be sure to apply in the order listed
ABOVE)

==============

 

!! this first part is the shaper which then calls the QoS service policy
further down

policy-map MQC       

  class class-default

    shape average 1425000  << based on 1.5 Meg pipe 95% of uplink speed
<< 

    service-policy QOS

 

 

 

policy-map QOS

  class voice-RTP 

    priority 1050 << based on leaving 375K of a 1.5 Meg link available.

    set dscp ef 

!! more details of voice-RTP in the class-map below

 

  class voice-control   

    bandwidth 75    << based on leaving 375 K of a 1.5 Meg link
available.

    set dscp af31

!! more details of voice-control in the class map below

 

  class class-default

    fair-queue

 

!! end policy-map QoS

!! class-map details below

 

class-map match-any voice-control

  match ip dscp af31

  match ip dscp cs3

  match access-group 101

!! more details on the access list below - choose type of control
h323/sip/mgcp, etc

 

class-map match-any voice-RTP

  match ip dscp ef

  match ip rtp  16384 16383

  match access-group name AutoQos-VOIP-RTP

!! more details on the access list below - deals with the ports 16384
through 32767

 

!

!

 

ip access-list extended AutoQos-VoIP-RTP

   permit udp any any range 16384 32767

 

!

!

 

!! details on ACCESS-LIST 101 depends upon type of control we are using.

 

!For MGCP

access-list 101 permit udp any any eq 2427

access-list 101 permit tcp any any eq 2428

 

!For H.323

access-list 101 permit tcp any any range 1718 1720

access-list 101 permit tcp any any eq 1731

 

!For Skinny (phones registered to CCM)

access-list 101 permit tcp any any eq 2000

 

!For Sip

access-list 101 permit tcp any any eq 5060

 

 

!!-------------------------------

!! DO NOT FORGET TO APPLY MQC (or QoS if you choose not to shape) TO AN
INTERFACE

!!-------------------------------

interface x/x

service-policy output MQC

 

 

******

end MQC EXAMPLE

******
525
Views
1
Helpful
2
Replies
CreatePlease login to create content