Cisco Support Community
Community Member

Voice/Data Vlan

I have 2950 switches with one data vlan 20 and one voice vlan 200. Data is on and non-cisco IP phones on subnets. The 6509 is a doing an InterVlan routing.

Some of the phones will have PC connected to it and some won't. For minimizing adminstrative issues, I have enable all ports in this

fashion to carry both voice and data VLANS. Is it the write approach?

For example, Port 1 48 on 2950 have this configuration,

int fastethernet 0/1

switchport mode access ---> making port an access port

switchport access vlan 10 ---> assign port to data vlan 10 and carry data traffic

switchport voice vlan 200 ----> to carry voice traffic

switchport priority extend cos 5 -----> prioritize voice traffic

Please tell me if this is the right approach to efficiently carry both voice/data traffic. Voice with high priority.

Am I gonna need any QOS service configured on 6500 switch?


Community Member

Re: Voice/Data Vlan


You did the wrong configuration for carring voice an data on different vlan.

It should be like that:

int fastethernet 0/1

switchport mode trunk ---> making a trunk connection

switchport trun encapsulation dot1q ---> dot1q trunk between phone an switch

switchport voice vlan 200 ----> to carry voice traffic

swithcport trunk native vlan 20 ----> to specify the data vlan for PC connected to the IP phone

switchport priority extend cos 5 -----> prioritize voice traffic

Management vlan is still vlan1.

Best regards,

Aleksander Kocelj

Community Member

Re: Voice/Data Vlan

Thanks ! I will make the change as you mentioned. I tested by plugging my PC to the Phone, and Phone to the Switch, and I am able to route both data and traffic with my configuration. Was it not supposed to work it all the way I did it?

2) Do I need to do any QOS on my 6509 switch as well?

Please shed some lights.


Community Member

Re: Voice/Data Vlan

Yep. You do need it everywhere on your voip network.

One more remark about your config:

switchport priority extend cos 5

This command does not change voice prio. It sets the DATA traffic of a PC attached to the phone-switchport to COS 5.

Set this value to 0 or to trust. What you do with cos 5 is giving data traffic the same cos as voice traffic!!!!!

Re: Voice/Data Vlan

You don't actually need all the Trunking configuration on the switchports - it will work without it:

Interface FastEthernet0/1

switchport mode access

switchport access vlan 20

switchport voice vlan 200

mls qos trust cos/dscp

This configuration makes the port a 'psuedo trunk' it is the equivilent of the config:

Interface FastEthernet0/1

switchport mode trunk

switchport trunk encapsulation dot1q

switchport native vlan 20

switchport trunk allowed vlan 20,200

mls qos trust cos/dscp


With the 2950 you can only trust DSCP if you run the EI image, also the 2950 can only 'see' and write certain DSCP values:

0 8 10 16 18 24 26 32 34 40 46 48 56

Depending on your IP Phones you can trust the CoS/DSCP received or reset it with a Serive-Policy.


CreatePlease to create content