Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Voice gateway registration rejected

Hi - I'm working on setting up our test lab with a 3825 router and call manager.  Our end goal is to configure a backup voicemail system that mirrors production.  This requires that all the work be done off the production network so everything needs to be setup from scratch.  I have call manager 7.15 installed as a VM and configured.  IP phone to IP phone communications are setup and working.  

 

The 3825 has a VWIC2-2MFT-T1/E1 and a PVDM2-64 installed.  I have a t1 crossover table connecting port 0/0/0 to the dialogic card on the voicemail server.  With the current configuration the green light is lit on the VWIC and the voicemail server shows the circuit as up and available.  show mcgp endpoints lists the 24 ports.  From what I can tell everything is right with the exception of the connection between call manager and the gateway.  

Below is the 3825 config.  I must be making a dumb mistake, hopefully someone can point me in the right direction.

VOIPGW1#show running-config
Building configuration...

Current configuration : 2350 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname VOIPGW1
!
boot-start-marker
boot-end-marker
!
card type t1 0 0
! card type command needed for slot/vwic-slot 1/0
!
no aaa new-model
memory-size iomem 15
network-clock-participate wic 0 
ip cef
!
!
!
!
no ip domain lookup
voice-card 0
 no dspfarm
!
!
!
voice rtp send-recv
!
voice service voip 
 allow-connections h323 to h323
 h323
 no h225 timeout keepalive 
 modem passthrough nse codec g711alaw
!
!
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g729r8
!
!
!
voice class h323 11
 h225 timeout tcp establish 3
 h225 timeout setup 3
!
!
!
!
!
!
!
!
!
!
!
controller T1 0/0/0
 framing sf
 linecode b8zs
 ds0-group 1 timeslots 1-24 type e&m-wink-start
!
controller T1 0/0/1
 framing esf
 linecode b8zs
!
!
!
interface GigabitEthernet0/0
 ip address 10.1.0.240 255.255.255.0
 duplex auto
 speed auto
 media-type rj45
 no keepalive
 h323-gateway voip interface
 h323-gateway voip bind srcaddr 10.1.0.240
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
 media-type rj45
 no keepalive
!
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
voice-port 0/0/0:1
!
ccm-manager mgcp
no ccm-manager fax protocol cisco
ccm-manager music-on-hold
!
mgcp
mgcp call-agent 10.1.0.230 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp ip qos dscp cs3 signaling
mgcp package-capability rtp-package
no mgcp package-capability res-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp bind control source-interface GigabitEthernet0/0
mgcp bind media source-interface GigabitEthernet0/0
!
mgcp profile default
!
sccp local GigabitEthernet0/0
sccp ccm 10.1.0.230 identifier 1 
sccp
!
sccp ccm group 10
 bind interface GigabitEthernet0/0
 associate ccm 1 priority 1
 associate profile 21 register GW1-MTP
!
dspfarm profile 21 mtp
 codec g711ulaw
 associate application SCCP
 shutdown
!
!
dial-peer voice 999031991 pots
 service mgcpapp
 port 0/0/0:1
!
!
!
line con 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
!
scheduler allocate 20000 1000
!
end

 

 

 

Everyone's tags (1)
13 REPLIES
VIP Purple

Hi, I am bit new to the kind

Hi,

 

I am bit new to the kind of setup u are doing with Dialogic card & VWIC T1 card. But if it is just pinout , can u cross-check the pairs u are using?

1----------->4
2----------->5
4----------->1
5----------->2

regds,

aman

New Member

Hi Aman, That is the pinout I

Hi Aman,

 

That is the pinout I am using.  Our setup is interesting, we are going from the VWIC to a dialogic d/240jct-t1  installed in a server 08 box.  This box is running an old version of Intel CT ADE with a home brew voice mail application.  This is not ideal at all but it works in production so this must be an issue with my config.  

 

Thanks,

Jeremy

VIP Purple

Hi Jeremy, Is the T1

Hi Jeremy,

 

Is the T1 controller UP?

 

can u share output of show ccm-manager and show ccm-manager hosts ?

 

regds,

aman

New Member

Here are the outputs.  The T1

Here are the outputs.  The T1 controller is up.  I have also put the first few lines of sho mgcp endpoint.

 

sho ccm-manager
MGCP Domain Name: VOIPGW1
Priority        Status                   Host
============================================================
Primary         Registered               10.1.0.230
First Backup    None                     
Second Backup   None                     

Current active Call Manager:    10.1.0.230
Backhaul/Redundant link port:   2428
Failover Interval:              30 seconds
Keepalive Interval:             15 seconds
Last keepalive sent:            16:38:47 UTC Oct 22 2014 (elapsed time: 00:00:06)
Last MGCP traffic time:         16:38:47 UTC Oct 22 2014 (elapsed time: 00:00:06)
Last failover time:             None
Last switchback time:           None
Switchback mode:                Graceful
MGCP Fallback mode:             Not Selected
Last MGCP Fallback start time:  None
Last MGCP Fallback end time:    None
MGCP Download Tones:            Disabled 

 --More--         Configuration Error History:
FAX mode: disable


VOIPGW1#show ccm-manae ger hosts
MGCP Domain Name: VOIPGW1
Priority        Status                   Host
============================================================
Primary         Registered               10.1.0.230
First Backup    None                     
Second Backup   None          

 

          

VOIPGW1#sho mgcp endpoint 

Interface T1 0/0/0

 

             ENDPOINT-NAME    V-PORT     SIG-TYPE   ADMIN

  S0/SU0/ds1-0/1@VOIPGW1   0/0/0:1    e&m-wnk    up    

VIP Purple

Your GW shows registered to

Your GW shows registered to CUCM.

 

Did not understand what is the issue?can u please elaborate if I can help u.

 

rgeds,

aman

New Member

When I go into the call

When I go into the call manager and select the gateway endpoints the 0/0/0 T1 interface shows as rejected.  I have attached a screenshot.

VIP Purple

Did u reset GW from CUCM?

Did u reset GW from CUCM?

 

regds,

aman

New Member

Yes I did.  I also did a no

Yes I did.  I also did a no mgcp, mgcp and power cycled the gateway.  Neither of those helped unfortunately.  

 

Thanks,

Jeremy

I think you have to issue a

I think you have to issue a no mgcp, reset the gateway from CUCM till you get the "unregistered" message and then issue the "mgcp" command.

Please rate useful posts.
VIP Purple

Hi , can u try adding isdn

Hi ,

 

can u try adding isdn bind l3 ccm-manager under serial port of T1?

 

regds,

aman

New Member

Hi Aman,

Hi Aman,

We are facing same issue where one MGCP end point is in rejected state.

Checked and found isdn bind I3 ccm-manager command is already added. Please see below config related to ports

//


!
controller E1 0/0/0  //Working PRI
framing NO-CRC4
pri-group timeslots 1-31 service mgcp
description *** First PRI ***
!
controller E1 0/0/1          //Affected PRI
pri-group timeslots 1-31 service mgcp
description *** Second PRI ***
!
!
!
!
!
!
interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
isdn bind-l3 ccm-manager
no cdp enable
!
interface Serial0/0/1:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
isdn bind-l3 ccm-manager
no cdp enable
!
!

//

New Member

hello Aman,

hello Aman,

This is fixed now.

Inserted command "framing NO-CRC4" on affected PRI and it came up.

Thanks

VIP Purple

[+5]

[+5]

thanks for update.

regds,

aman

346
Views
15
Helpful
13
Replies