Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Voice over Frame Relay Quality of service

Hi, my name is Raymond. I have a few questions regarding vofr qos. Recently I had implemented vofr in one of my customer. Here is a brief description about it. One HQ with two branches, each using Cisco 3640. The router in HQ is connected to Lucent PBX with NM-HDV-1E1-30 modul. Each of the branches have 12 FXO ports. The backhaul bandwidth in use in HQ are 512K with 256K CIR for voice and 128K with 64K CIR for data, split into two for each branch. Currently I am using subinterfaces to split the voice and data. Because the bandwidth in each branch still 128K each then I am only using 10 FXO ports. I will also attach each configuration. But my customer is still complaining about the quality of voice and the data itself when there are 20 concurrent calls. It is a call center so the vofr must be able to support 20-24 concurrent calls. Kindly give me an advise about my configuration. tx

Rgrds

Ray

This is the HQ config :

sh run

Building configuration...

Current configuration : 6656 bytes

!

version 12.2

no parser cache

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

!

logging rate-limit console 10 except errors

!

!

!

voice-card 2

!

ip subnet-zero

!

!

no ip domain-lookup

!

no ip dhcp-client network-discovery

isdn switch-type basic-5ess

call rsvp-sync

!

voice service vofr

!

!

!

!

!

!

!

controller E1 2/0

framing NO-CRC4

ds0-group 0 timeslots 1-6 type e&m-melcas-immed

ds0-group 1 timeslots 7-12 type e&m-melcas-immed

ds0-group 2 timeslots 13-15,17-19 type e&m-melcas-immed

ds0-group 3 timeslots 20-25 type e&m-melcas-immed

!

!

!

interface FastEthernet1/0

ip address 3.241.28.6 255.255.252.0

speed auto

half-duplex

no cdp enable

no mop enabled

!

interface Serial1/0

mtu 200

no ip address

encapsulation frame-relay

no ip mroute-cache

frame-relay traffic-shaping

frame-relay ip rtp header-compression

!

interface Serial1/0.1 point-to-point

description 'FR to BDG'

bandwidth 128

ip address 3.244.159.241 255.255.255.252

no cdp enable

frame-relay interface-dlci 21

class VOIPovFR

vofr cisco

!

interface Serial1/0.2 point-to-point

description 'FR to SBY'

bandwidth 128

ip address 3.241.32.5 255.255.255.252

no cdp enable

frame-relay interface-dlci 20

class VOIPovFR

vofr cisco

!

interface Serial1/0.3 point-to-point

description 'f/r data to surabaya'

bandwidth 32

ip address 3.244.159.201 255.255.255.252

no cdp enable

frame-relay interface-dlci 22

class Data

!

interface Serial1/0.4 point-to-point

description 'f/r data to bandung'

bandwidth 32

ip address 3.244.159.197 255.255.255.252

no cdp enable

frame-relay interface-dlci 23

class Data

!

interface Serial1/1

no ip address

shutdown

clockrate 2000000

!

interface Serial1/2

no ip address

shutdown

clockrate 2000000

!

interface Serial1/3

no ip address

shutdown

clockrate 2000000

!

interface BRI3/0

description *** ISDN Back Up Link from Jakarta to Surabaya ***

bandwidth 128

ip unnumbered Loopback2

encapsulation ppp

ip tcp header-compression iphc-format

no ip mroute-cache

dialer idle-timeout 300

dialer map ip 3.140.106.1 name gdn_hsg_singapore1 broadcast

dialer load-threshold 5 either

dialer-group 10

isdn switch-type basic-5ess

fair-queue 64 16 0

no cdp enable

ppp authentication chap

ppp multilink

ppp multilink fragment-delay 20

ppp multilink interleave

ip rtp header-compression iphc-format

ip rtp priority 16384 16383 40

!

interface BRI3/1

description *** ISDN Back Up Link from Jakarta to Bandung ***

bandwidth 128

ip unnumbered Loopback1

encapsulation ppp

ip tcp header-compression iphc-format

no ip mroute-cache

dialer idle-timeout 300

dialer map ip 3.244.159.242 name gecgcfidrtrbdg1 0224250124

dialer load-threshold 5 either

dialer-group 10

isdn switch-type basic-5ess

fair-queue 64 16 0

no cdp enable

ppp authentication chap

ppp multilink

ppp multilink fragment-delay 20

ppp multilink interleave

ip rtp header-compression iphc-format

ip rtp priority 16384 16383 40

!

interface BRI3/2

no ip address

shutdown

isdn switch-type basic-5ess

!

interface BRI3/3

no ip address

shutdown

isdn switch-type basic-5ess

!

router eigrp 251

network 3.0.0.0

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip route 0.0.0.0 0.0.0.0 3.241.28.1

ip route 3.241.36.0 255.255.252.0 Serial1/0.3

ip route 3.244.152.0 255.255.255.0 Serial1/0.4

no ip http server

!

!

map-class frame-relay VOIPovFR

no frame-relay adaptive-shaping

frame-relay cir 128000

frame-relay bc 1000

frame-relay be 0

frame-relay mincir 128000

frame-relay fair-queue

frame-relay voice bandwidth 128000

frame-relay fragment 160

!

map-class frame-relay Data

no frame-relay adaptive-shaping

frame-relay cir 32000

frame-relay mincir 32000

access-list 1 deny 0.0.0.0

access-list 1 deny 3.0.0.0

access-list 1 permit any

access-list 199 deny ip host 255.255.255.255 any

access-list 199 permit ip any any

dialer-list 10 protocol ip list 199

!

!

snmp-server community gecgcfid RO

snmp-server enable traps isdn call-information

snmp-server enable traps isdn layer2

snmp-server enable traps isdn chan-not-avail

snmp-server host 3.241.28.82 inform version 2c gecgcfid

snmp-server host 3.241.28.82 version 2c gecgcfid

!

voice-port 2/0:0

input gain 14

output attenuation 14

!

voice-port 2/0:1

input gain 14

output attenuation 14

!

voice-port 2/0:2

input gain 14

output attenuation 14

!

voice-port 2/0:3

input gain 14

output attenuation 14

!

dial-peer cor custom

!

!

!

dial-peer voice 1 pots

destination-pattern 225....

port 2/0:0

!

dial-peer voice 2 pots

preference 1

destination-pattern 225....

port 2/0:0

!

dial-peer voice 3 pots

preference 2

destination-pattern 225....

port 2/0:0

!

dial-peer voice 4 pots

preference 3

destination-pattern 225....

port 2/0:0

!

dial-peer voice 5 pots

preference 4

destination-pattern 225....

port 2/0:0

!

dial-peer voice 6 pots

preference 5

destination-pattern 225....

port 2/0:0

!

dial-peer voice 7 pots

destination-pattern 223....

port 2/0:1

!

dial-peer voice 8 pots

preference 1

destination-pattern 223....

port 2/0:1

!

dial-peer voice 9 pots

preference 2

destination-pattern 223....

port 2/0:1

!

dial-peer voice 10 pots

preference 3

destination-pattern 223....

port 2/0:1

!

dial-peer voice 11 pots

preference 4

destination-pattern 223....

port 2/0:1

!

dial-peer voice 12 pots

preference 5

destination-pattern 223....

port 2/0:1

!

dial-peer voice 13 pots

destination-pattern 315....

port 2/0:2

!

dial-peer voice 14 pots

preference 1

destination-pattern 315....

port 2/0:2

!

dial-peer voice 15 pots

preference 2

destination-pattern 315....

port 2/0:2

!

dial-peer voice 16 pots

preference 3

destination-pattern 315....

port 2/0:2

!

dial-peer voice 17 pots

preference 4

destination-pattern 315....

port 2/0:2

!

dial-peer voice 18 pots

preference 5

destination-pattern 315....

port 2/0:2

!

dial-peer voice 19 pots

destination-pattern 313....

port 2/0:3

!

dial-peer voice 20 pots

preference 1

destination-pattern 313....

port 2/0:3

!

dial-peer voice 21 pots

preference 1

destination-pattern 313....

port 2/0:3

!

dial-peer voice 22 pots

preference 2

destination-pattern 313....

port 2/0:3

!

dial-peer voice 23 pots

preference 3

destination-pattern 313....

port 2/0:3

!

dial-peer voice 24 pots

preference 4

destination-pattern 313....

port 2/0:3

!

!

line con 0

line aux 0

line vty 0 4

login

!

!

end

this is the 1st branch config :

sh run

Building configuration...

Current configuration : 3234 bytes

!

version 12.2

no parser cache

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

!

!

ip subnet-zero

!

!

no ip domain-lookup

!

isdn switch-type basic-5ess

call rsvp-sync

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 3.244.152.1 255.255.255.0

no ip mroute-cache

speed auto

half-duplex

no cdp enable

no mop enabled

!

interface Serial0/0

mtu 200

no ip address

encapsulation frame-relay

no ip mroute-cache

frame-relay traffic-shaping

frame-relay ip rtp header-compression

!

interface Serial0/0.1 point-to-point

bandwidth 128

ip address 3.244.159.242 255.255.255.252

no ip mroute-cache

no cdp enable

frame-relay interface-dlci 21

class VOIPovFRtoJKT

vofr cisco

!

interface Serial0/0.2 point-to-point

bandwidth 32

ip address 3.244.159.198 255.255.255.252

no ip mroute-cache

no cdp enable

frame-relay interface-dlci 23

class Jktdata

!

interface BRI0/0

ip unnumbered Loopback1

encapsulation ppp

ip tcp header-compression iphc-format

no ip mroute-cache

shutdown

dialer load-threshold 5 either

isdn switch-type basic-5ess

fair-queue

no cdp enable

ppp authentication chap

ppp multilink

ppp multilink fragment-delay 20

ppp multilink interleave

ip rtp header-compression iphc-format

ip rtp priority 16384 16383 40

!

interface Serial0/1

no ip address

no ip mroute-cache

shutdown

clockrate 2000000

!

router eigrp 251

network 3.0.0.0

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0/0.2

no ip http server

ip pim bidir-enable

!

!

map-class frame-relay VOIPovFRtoJKT

no frame-relay adaptive-shaping

frame-relay cir 128000

frame-relay bc 1000

frame-relay be 0

frame-relay mincir 128000

frame-relay fair-queue

frame-relay voice bandwidth 128000

frame-relay fragment 160

!

map-class frame-relay Jktdata

no frame-relay adaptive-shaping

frame-relay cir 32000

frame-relay mincir 32000

snmp-server community gecgcfid RO

snmp-server location Bandung

snmp-server contact Ruliyanto

snmp-server enable traps isdn call-information

snmp-server enable traps isdn layer2

snmp-server enable traps isdn chan-not-avail

snmp-server host 3.241.28.82 gecgcfid

!

voice-port 1/0/0

connection plar 2255225

!

voice-port 1/0/1

connection plar 2255225

!

voice-port 1/1/0

connection plar 2255225

!

voice-port 1/1/1

connection plar 2255225

!

voice-port 2/0/0

connection plar 2255225

!

voice-port 2/0/1

connection plar 2255225

!

voice-port 2/1/0

connection plar 2233663

!

voice-port 2/1/1

connection plar 2233663

!

voice-port 3/0/0

connection plar 2233663

!

voice-port 3/0/1

connection plar 2233663

!

voice-port 3/1/0

connection plar 2233663

!

voice-port 3/1/1

connection plar 2233663

!

dial-peer cor custom

!

!

dial-peer cor list name

!

!

dial-peer voice 3 vofr

destination-pattern 225....

session target Serial0/0 21

dtmf-relay

!

dial-peer voice 4 vofr

destination-pattern 223....

session target Serial0/0 21

dtmf-relay

!

!

line con 0

line aux 0

line vty 0 4

login

!

end

This is the 2nd branch config :

sh run

Building configuration...

Current configuration : 3310 bytes

!

version 12.2

no parser cache

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

!

logging rate-limit console 10 except errors

!

!

ip subnet-zero

!

!

no ip domain-lookup

!

no ip dhcp-client network-discovery

isdn switch-type basic-5ess

call rsvp-sync

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 3.241.36.1 255.255.252.0

no ip mroute-cache

speed auto

half-duplex

no cdp enable

no mop enabled

!

interface Serial0/0

mtu 200

no ip address

encapsulation frame-relay

no ip mroute-cache

frame-relay traffic-shaping

frame-relay ip rtp header-compression

!

interface Serial0/0.1 point-to-point

bandwidth 128

ip address 3.241.32.6 255.255.255.252

no ip mroute-cache

no cdp enable

frame-relay interface-dlci 20

class VOIPovFRtoJKT

vofr cisco

!

interface Serial0/0.2 point-to-point

bandwidth 32

ip address 3.244.159.202 255.255.255.252

no ip mroute-cache

no cdp enable

frame-relay interface-dlci 22

class Sbydata

!

interface BRI0/0

ip unnumbered Loopback1

encapsulation ppp

ip tcp header-compression iphc-format

no ip mroute-cache

dialer load-threshold 5 either

isdn switch-type basic-5ess

fair-queue

no cdp enable

ppp authentication chap

ppp multilink

ppp multilink fragment-delay 20

ppp multilink interleave

ip rtp header-compression iphc-format

ip rtp priority 16384 16383 40

!

interface Serial0/1

no ip address

shutdown

clockrate 2000000

!

router eigrp 251

network 3.0.0.0

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0/0.2

no ip http server

!

!

map-class frame-relay VOIPovFRtoJKT

no frame-relay adaptive-shaping

frame-relay cir 128000

frame-relay bc 1000

frame-relay be 0

frame-relay mincir 128000

frame-relay fair-queue

frame-relay voice bandwidth 128000

frame-relay fragment 160

!

map-class frame-relay Sbydata

no frame-relay adaptive-shaping

frame-relay cir 32000

frame-relay mincir 32000

!

!

snmp-server community gecgcfid RO

snmp-server location Bandung

snmp-server contact Ruliyanto

snmp-server enable traps isdn call-information

snmp-server enable traps isdn layer2

snmp-server enable traps isdn chan-not-avail

snmp-server host 3.241.28.82 gecgcfid

!

voice-port 1/0/0

connection plar 3155225

!

voice-port 1/0/1

connection plar 3155225

!

voice-port 1/1/0

connection plar 3155225

!

voice-port 1/1/1

connection plar 3155225

!

voice-port 2/0/0

connection plar 3155225

!

voice-port 2/0/1

connection plar 3155225

!

voice-port 2/1/0

connection plar 3133663

!

voice-port 2/1/1

connection plar 3133663

!

voice-port 3/0/0

connection plar 3133663

!

voice-port 3/0/1

connection plar 3133663

!

voice-port 3/1/0

connection plar 3133663

!

voice-port 3/1/1

connection plar 3133663

!

dial-peer cor custom

!

!

dial-peer cor list name

!

!

dial-peer voice 3 vofr

destination-pattern 315....

session target Serial0/0 20

dtmf-relay

!

dial-peer voice 4 vofr

destination-pattern 313....

session target Serial0/0 20

dtmf-relay

!

!

line con 0

line aux 0

line vty 0 4

login

!

!

end

6 REPLIES

Re: Voice over Frame Relay Quality of service

Since there has been no response to your post, it appears to be either too complex or too rare an issue for other forum members to assist you. If you don't get a suitable response to your post, you may wish to review our resources at the online Technical Assistance Center (http://www.cisco.com/tac) or speak with a TAC engineer. You can open a TAC case online at http://www.cisco.com/tac/caseopen

If anyone else in the forum has some advice, please reply to this thread.

Thank you for posting.

New Member

Re: Voice over Frame Relay Quality of service

Have you worked this out yet? In looking at your configs, I'd suggest a few things -

Make sure you shape the data PVCs as well as the voice PVCs. Currently, traffic on your data PVCs could delay the transmission of voice packets. This is probably the issue that is biting you.

I typically use the following values for the frame-relay map-class

1) cir = cir of PVC

2) mincir = cir

3) be = 0

4) bc = cir/100 (this gives you a 10ms Tc)

5) frag = appropriate value for lowest access

speed on either end of PVC

It looks like you have a 512K FT1 with 4 PVCs (2 @ 128K CIR and 2 @ 32K CIR) at your HQ, and a ???K FT1 with 2 PVCs (128K CIR and 32K CIR) at each branch. Is this right? The port speed at the branch sites is probably 256K then. This would allow you to increase the fragment size to 320 bytes.

Good luck!

- Paul

New Member

Re: Voice over Frame Relay Quality of service

Hi Ray

Try

frame-relay ip rtp priority 16384 16383 bw

instead of frame-relay voice bandwidth

and there is no need to configure mtu 200,

you have already done frame relay fragmentaion

Regards

Juergen

New Member

Re: Voice over Frame Relay Quality of service

Ray is attempting VoFR, not VoIP. He'll need to use layer 2 QoS methods (FRF.11 and FRF.12) rather than layer 3 methods (RTP priority, LLQ, MQC, etc).

I agree that the 'mtu 200' statement should be removed. Since he's using frame-relay fragmentation there is no need for this.

- Paul

New Member

Re: Voice over Frame Relay Quality of service

Paul and Juergen thanks for your suggestion.

Paul regarding your suggestion I have a few question. Hope it doesn't botter you and you don't mind to answer it.

You said that I need to shape both data and voice PVC. Does it mean I gotta made separate 'frame-relay map-class' for the data PVC? If currently the data PVC bandwidth only 32kb, then what should the 'frame-relay fragment' be? Right now I already made those separate but without add the 'frame-relay be, bc, fragment and fair-queue' on 'frame-relay map-class' for data PVC. Does it matter??

When there are only 5 concurrent calls then all the 5 calls are fine. The problem arise when there are more then 5 calls. All the conversation then would suffer as if 'there isn't enough bandwidth' (with 128kb using the standard ios codec, I should have 10 calls simultaneously right?)

Just as you said, I think the data traffic (even if they are separate by different PVC) cause this. If I physically separate the serial for voice and data would it be helpful?

Anyway tx a lot.

Rgrds,

Ray

New Member

Re: Voice over Frame Relay Quality of service

Ray,

Yes, you should take the map-class you have for data on each router and enable FRF.12 (via the frame-relay fragment statement). Even though voice and data are on seperate PVCs, they still travel across the same serial interface and are intermingled.

The fragment size is dependant on the port speed (ie - how quickly will the frame be serialized). Whatever your CIR is, Cisco recommends 160 bytes as a starting point for a 128K access rate, 320 bytes for a 256K access rate, etc... so that no packet takes longer than 10ms to serialize at each interface. Determine the access rate at each end of the PVC and use the slower rate to determine your fragment size for this PVC.

Yes, if all that was running across the serial interface was a PVC hadling FRF.11 voice you could avoid QoS issues involving data. However, you are back to having a seperate network for voice and data. You lose the advantage of a multiservice network.

170
Views
0
Helpful
6
Replies
CreatePlease login to create content