Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Voice QoS on a router with VLANs on Fastethernet

Hi All,

I have Cisco router 2811 (IOS Version 12.3(14)T7) with a switch-module.

This switch placed on datacom premisses acts as a junction of multiply channels (VLANs) from branch offices. All VLANs comes through 1 fastethernet port fa 0/0/0 on a switch module.

Current config of 2811:

class-map match-all data-stream

match ip dscp default

class-map match-any voice-signaling

match ip dscp af31

match ip dscp cs3

class-map match-any network-control

match ip dscp cs6

match ip dscp cs2

match access-group name IKE

class-map match-all voice-stream

match ip dscp ef

class-map match-any VIP

match access-group name VIP

policy-map WAN-RELATIVE

class voice-stream

priority percent 50

class voice-signaling

bandwidth remaining percent 5

class network-control

bandwidth remaining percent 5

class data-stream

bandwidth remaining percent 15

class VIP

bandwidth remaining percent 20

class class-default

fair-queue

policy-map 128K

class class-default

shape average 128000

service-policy WAN-RELATIVE

interface Vlan514

description << VLAN 514 >>

bandwidth 128

ip address 172.22.0.17 255.255.255.252

load-interval 30

crypto map CRYPTOMAP

service-policy output 128K

!

interface FastEthernet0/0/0

description << TRUNK >>

switchport trunk allowed vlan 1,241,379,402,415,419,444,514,521,640,1002-1005

switchport trunk allowed vlan add 641,830,834,904

switchport mode trunk

load-interval 30

duplex full

speed 100

All cryptomaps are configured with "qos pre-classify"

branch routers - Cisco 1811 (IOS Version 12.4(6)T2) are configured in the same manner. ADSL modem with fastethernet port is connected to the fastethernet0 port on Cisco1811.

Here is a part of the 1811's config

class-map match-all data-stream

match ip dscp default

class-map match-any voice-signaling

match ip dscp af31

match ip dscp cs3

class-map match-any network-control

match ip dscp cs6

match ip dscp cs2

match access-group name IKE

class-map match-all voice-stream

match ip dscp ef

class-map match-any VIP

match access-group name VIP

policy-map WAN-RELATIVE

class voice-stream

priority percent 50

class voice-signaling

bandwidth remaining percent 5

class network-control

bandwidth remaining percent 5

class data-stream

bandwidth remaining percent 15

class VIP

bandwidth remaining percent 20

class class-default

fair-queue

policy-map 128K

class class-default

shape average 128000

service-policy WAN-RELATIVE

interface FastEthernet0

bandwidth 128

ip address 172.22.0.18 255.255.255.252

load-interval 30

duplex auto

speed auto

crypto map CRYPTOMAP

service-policy output 128K

!

But QoS doesn't work!

While executing command on 2811 "sh policy-map int vlan514" i can see that traffic in class map default exceeds 128K and no drops occurred! Also voice quality is extremely poor. Even phone registration drops!

Partially output from the command ?sh policy-map int vlan514? executed on Cisco 2811

Class-map: class-default (match-any)

1568 packets, 1495583 bytes

30 second offered rate 224000 bps, drop rate 0 bps

Match: any

Queueing

Flow Based Fair Queueing

Maximum Number of Hashed Queues 16

1 REPLY
New Member

Re: Voice QoS on a router with VLANs on Fastethernet

OK. Now I know why CBWFQ doesn't work on switching module in 2811.

According to this http://www.cisco.com/en/US/products/ps5854/products_qanda_item0900aecd8016c026.shtml

863
Views
0
Helpful
1
Replies
CreatePlease to create content