Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

cwy
New Member

Voice QoS

I enabled QoS in my router to let the voice traffic have better quality. However it seems not work. The tool I used was "set ip precedence" for the incoming and out-going packet. However can I know the packet has the right precedence. Ask my Internet service provider or I can check out by myself? Attached the router configuration. Anyone can help?

ip subnet-zero

ip cef

!

class-map match-all voice

match access-group 101

!

policy-map voice

class voice

set ip precedence 5

!

interface FastEthernet0/0

ip address 192.168.10.254 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

ip address 10.0.0.1 255.255.255.0

ip nat outside

encapsulation frame-relay IETF

frame-relay traffic-shaping

--Omitted--

frame-relay interface-dlci 20

class normal

frame-relay interface-dlci 21

class normal

frame-relay lmi-type ansi

frame-relay interface-queue priority

!

interface Serial0/0.10 point-to-point

ip address 10.114.0.14 255.255.255.252

service-policy output voice

frame-relay interface-dlci 503 IETF

class test

!

ip classless

ip route 192.168.20.0 255.255.255.0 Serial0/0.10

no ip pim bidir-enable

!

map-class frame-relay normal

no frame-relay adaptive-shaping

frame-relay cir 128000

!

map-class frame-relay test

no frame-relay adaptive-shaping

frame-relay cir 128000

frame-relay priority-group 1

frame-relay interface-queue priority medium

access-list 101 permit ip host 192.168.10.2 host 192.168.20.2

5 REPLIES

Re: Voice QoS

Since there has been no response to your post, it appears to be either too complex or too rare an issue for other forum members to assist you. If you don't get a suitable response to your post, you may wish to review our resources at the online Technical Assistance Center (http://www.cisco.com/tac) or speak with a TAC engineer. You can open a TAC case online at http://www.cisco.com/tac/caseopen

If anyone else in the forum has some advice, please reply to this thread.

Thank you for posting.

Cisco Employee

Re: Voice QoS

Typically, you should not have to use a route-map to set the IP Precedence bits; usually the voice endpoint is smart enough to do that. What is the host 192.168.10.2 that is sending voice packets in your access-list? What application is sending voice? Are you sure they are not getting marked already?

Also, since you are doing frame-relay traffic-shaping, if you want to give voice a strict priority over data packets, you should consider using LLQ (Low Latency Queuing).

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121newft/121t/121t2/dtfrpqfq.htm

New Member

Re: Voice QoS

In addition, you need to think what will happen with voice packets at the other end, when the router will receive them, the L2 FR header will be dropped and L2 Ethernet header will be built.

Where the voice traffic going after that? Is it going out via Ethernet port of the router?

I presume yes and if it is, then you may have a problem in the LAN too. In this case you probably need to consider to enable L2 classification for traffic outgoing the Ethernet interface by marking the proper COS value.

Just a suggestion to look at the whole picture.

In addition I would strictly recommend LLQ instead of FR interface queuing.

Regards,

Vakhtang.

New Member

Re: Voice QoS

Setting the precedence may not be the way to go unless you are sure it will be honored up the network. You might want to try something like what I use in addition to precedence.

add "priority-group 1 " to serial 0.10

add...

access-list 100 permit ip any host 192.168.10.2

access-list 100 permit ip any host 192.168.10.3

access-list 101 permit ip any any

priority-list 1 protocol ip high list 100

priority-list 1 protocol ip low list 101

priority-list 1 default low

New Member

Re: Voice QoS

Hello All,

Infact my setup is also a similar kind.

telephone

|

|

Multi Tech VOIP Box 172.23.162.74

(FXS)

|

|

switch

|

|

router 1

|

| /|

|/ | (Lease Line 128K)

|

|

router 2

|

|

switch

|

|

Multi Tech VOIP Box (FXS)

|

|

telephone

I have already implemented the "priority-group 1" solution at both ends.

But still the voice BREAKS a lot.

e.g:-

****at my end****

access-list 103 permit ip host 172.23.162.74 any

priority-list 1 protocol ip high list 103

*******************

Any feedback is highly appreciated.

regards,

Vijayendra K. Sharma

90
Views
0
Helpful
5
Replies
CreatePlease login to create content