Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Voice Vlan on 2950-24 Switch

Hello All,

We are having a Cat 2950-24 which we want to use it for our VoIP training LAB and it looks that while we are creating data Vlan and voice Vlan and added under Switch fast interfaces , the IP phones are stoping to work and we are wondering why?

The Switch has IOS version c2950-i6q4l2-mz.121-22.EA6.bin.

The documentation on Cisco web site said that is possible but for some reasons doesn't work right in our case.

Does anyone else has seeing or encounter this issue?

http://www.cisco.com/en/US/partner/products/hw/switches/ps628/products_configuration_guide_chapter09186a00800c6f0d.html

Thanks for for input in advance.

Mike

6 REPLIES

Re: Voice Vlan on 2950-24 Switch

Mike,

Can you paste your configs ?

Re: Voice Vlan on 2950-24 Switch

Hi there,

There's not that much to the voice vlan:-

int fast 0/1

sw mo acc

sw acc vlan 10

sw voice vlan 110

and that should be pretty much it... Have you got static vlans on the phones or are they told by a dhcp to use a different vlan?

Failing that - paste the configs and we'll sort it.

Regards,

LH

Please rate all posts

Community Member

Re: Voice Vlan on 2950-24 Switch

I had a similar problem with 3548XL with much older version of IOS 12.0(5.3)WC1.

Phones were not getting DHCP IP Address with the 'voice vlan' command. Had to put the phone on 'sw acc vlan 1'.

Re: Voice Vlan on 2950-24 Switch

With 3548/24, each switch port has to be configured as a dot1q trunk.

int fa0/1

switchport mode trunk

switchport trunk encap dot1q

switchport trunk native vlan 100

switchport voice vlan 200

HTH

Sankar

PS: please rate all posts!

Community Member

Re: Voice Vlan on 2950-24 Switch

Hello All,

First of all I would like to thanks to each of you for your help.

The switch is working fine if I use only one vlan in this case data vlan 1.

According to cisco.com docs I should be able to use two VLAN's (data, voice) but that fail to work for some reasons.

Also I forgot to add that we are using DHCP.

It looks to me that the phones are not getting DHCP IP addreses with the "voice vlan" command.

Here is the partial config of the CAT 2950-24 Switch at the moment which is working:

.................

interface FastEthernet0/3

switchport mode access

spanning-tree portfast

interface FastEthernet0/10

switchport mode access

switchport voice vlan 20

spanning-three portfast

shutdown

interface fastEthernet 0/19

switchport mode access

switchport voice vlan 20

switchport access vlan 1

spanning-three portfast

shutdown

interface Vlan1

description Data VLAN

ip address 192.168.20.25 255.255.255.0

no ip redirects

no ip route-cache

!

!

interface Vlan20

description Voice VLAN

ip address 192.168.20.25 255.255.255.0

no ip redirects

no ip route-cache

shutdown

!

ip default-gateway 192.168.20.1

.......................

Note: Once again if I use voice vlan command and not data VLAN 1 it will not work.

Configuration for Non-Cisco IP phone ports :

---------

switch trunk encapsulation dot1q

switchport mode trunk

switchport trunk native vlan x

switchport trunk allowed vlan x,y

auto qos voip trust

Configuretion for the Cisco IP phone ports :

---------

switchport access vlan x

switchport voice vlan y

Thanks again for your input.

Regards,

Mike

Community Member

Re: Voice Vlan on 2950-24 Switch

The switch can only handle one "active" interface vlan. The "active" interface VLAN is Native, or becomes the default vlan for management. You can set up DHCP services for several scopes, but the switch will only respond to the DHCP request from the "active" vlan. So if you have a data vlan 10.x.x.x and a voice vlan 192.x.x.x, you will need a router between the vlans. The layer 2/3 switches will route for you, but this switch will not. Do not give up on the double VLAN trunking to the phone.

Turn on trunking to the phone. ?switch mode trunk?

Configuration and design?

515
Views
0
Helpful
6
Replies
CreatePlease to create content