Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

VoIP and QoS issue

My client has imoplemented A Telstra IP Telephony (TIPT) solution with Polycom handsets at all sites, and Telephony service in the Telstra cloud.  For the most part, it is working fine, with DSCP markings on voice and call signaling streams.  We have implemented outbound QoS policies at the WAN edge.  There are a couple of sites where voice quality can regularily be poor (lost bits of voice).  We do not see any dropped voice packets in the policy.  We have identify that this seems to occur at the same time a site is receving large email flows (SMTP inbuond, Notes 1352 traffic in and outbound).  Within in the QoS policy, we have shaped this mail traffic to a peak value in an attempt to mitigate it from utilizing all of the bandwidth.  I have been runing NBAR on the WAN interface of the worst effected site, and can see that the 5min Max Bit Rate on SMTP(Input) and Notes (Input and Output) have reached 75% of the actual bandwidth, which also exceeds the peak rate configured in the policy by more than double.

How can I improve the voice quality and what am I doing wrong such that mail traffic is not been limited to the peak rate?

WAN Interface:

!

interface FastEthernet0/1

description Telstra BDSL TPIPS Access

ip address 172.16.254.41 255.255.255.252

ip nbar protocol-discovery

rate-limit output 512000 512000 512000 conform-action transmit exceed-action drop

ip ospf network point-to-point

speed 100

full-duplex

service-policy output TPIPS

!

Policy-map

!

policy-map TPIPS_in

class IPWAN_mail

  shape peak 128000

  bandwidth 128

policy-map TPIPS

class Telnet

  bandwidth 256

class IPWAN_mail

  shape peak 128000

  bandwidth 128

class Voice

  priority 144

class Voice-ctrl

  bandwidth 16

class class-default

  fair-queue

  random-detect

!

Class-maps

!

class-map match-all IPWAN_mail

match access-group 101

class-map match-all HTTP

match access-group 151

class-map match-all Telnet

match access-group 100

class-map match-any Voice

match  dscp ef

match access-group name Voice

class-map match-any Voice-ctrl

match  dscp af31

match access-group name Voice-ctrl

!

access-list 101

!

access-list 101 permit tcp host 172.16.4.254 eq smtp any

access-list 101 permit tcp host 172.16.4.254 eq 1352 any

access-list 101 permit tcp host 172.16.4.254 any eq 1352

access-list 101 permit tcp host 172.16.4.254 any eq smtp

!

1 REPLY
Gold

VoIP and QoS issue

Hi

This is not an uncommon scenario.

Your config shapes outbound traffic from your gateway, and doesn't have any impact on inbound traffic. If the Telstra backbone is not performing similar outbound shaping on its connection to the site then you will find that traffic in that direction (WAN to remote site) is not being subjected to QoS and can result in the symptoms that you are seeing. Remember that voice is full duplex and requires QoS in each direction.

In order for QoS to really work, it needs to be performed end to end - and unfortunately in this instance it also needs your carrier to do it as well on each of their nodes.

HTH

Barry Hesk

Intrinsic Network Solutions

380
Views
0
Helpful
1
Replies
CreatePlease to create content