Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VoIP MPPP w/bundled T1's

Can you run VoIP over Multilink PPP bundled T1's? What type of Qos method should be used to ensure voice quality.

Is there any documentation referencing example configurations using Multilink grouping of multiple T1's as well as the Qos method?

2 REPLIES

Re: VoIP MPPP w/bundled T1's

Often times complex configuration issues are best addressed in an interactive session with one of our trained technical assistance engineers. While other forum users may be able to help, it’s often difficult to do so for this type of issue.

To utilize the resources at our Technical Assistance Center, please visit http://www.cisco.com/tac and to open a case with one of our TAC engineers, visit http://www.cisco.com/tac/caseopen

If anyone else in the forum has some advice, please reply to this thread.

Thank you for posting.

New Member

Re: VoIP MPPP w/bundled T1's

As a matter of fact MLP (Multilink PPP) is the prefered way for running voice packets over load balanced T1s.

Do NOT do per-packet load balaning!

As far as QOS, you should use LLQ.

Define what protocols (netwoks, or specific IPaddress) you need to priorotize and the map it to class-maps which in turn shuold be maped to a policy-map.

By doing this you map ToS and CoS bits to needed packets, prioritize them and queue them.

Here's a sample:

interface Multilink1

ip address 0.0.0.0 255.255.255.252

service-policy output VoIP

ppp multilink

ppp multilink fragment-delay 10

ppp multilink interleave

multilink-group 1

interface Serial1/0

bandwidth 1544

encapsulation ppp

ppp multilink

multilink-group 1

interface Serial1/1

bandwidth 1544

encapsulation ppp

ppp multilink

multilink-group 1

class-map VoIP-RTP

match ip rtp 16384 16383

match access-group 100

class-map VoIP-Control

match access-group 122

policy-map VoIP

class VoIP-RTP

set ip dscp 46

priority 1440

class VoIP-Control

set ip dscp 26

bandwidth 30

access-list 100 permit ip any any precedence critical

access-list 100 permit ip any any dscp ef

access-list 122 permit tcp any any range 2000 2002

access-list 122 permit tcp any range 2000 2002 any

access-list 122 permit tcp any any eq 1720

access-list 122 permit tcp any eq 1720 any

access-list 122 permit tcp any any range 11000 11999

access-list 122 permit tcp any range 11000 11999 any

access-list 122 permit udp any any eq 2427

access-list 122 permit udp any eq 2427 any

access-list 122 permit tcp any any eq 2748

access-list 122 permit tcp any eq 2748 any

The bandwidths are based on 60 simultaneous G.729 calls

(RTP: 60 channels x 24 kbps = 1440 kbps and Signaling: 60 x 0.5 kbps = 30 kbps).

If you're not using compression then : G.711 - 80kbps x 60 = 4800kbps

Than change the priority value under the policy map from 1400 to 4800kbps.

Keep in mind that you might not need to use all access-groups.These access lists are for signaling protocols such as Skinny, MGCP, H.323.

Also, if you have less b/w on your links than DS0 voice channels, than make sure that you implement, CAC (call admission control) to limit # of voice calls over your T1s, so they wont saturate the link and that will degrade the quality of your voice calls.

Good Luck

111
Views
0
Helpful
2
Replies
CreatePlease login to create content