Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

VoIP QOS over 10mb Lan Extension.

Hi,

We've got a 10mb Lan extension between two sites and we are going to start running Voice between them. What is the best way to prioritize the voice traffic between the two sites? the Lan extension runs fro router to Router via the ethernet ports. There will be two Vlans voice and Data.

Thanks

Gus

3 REPLIES
Bronze

Re: VoIP QOS over 10mb Lan Extension.

Let me guess, are you use Wireless connection??

If thats the case, you really dont need QoS on ethernet interface. However, you can configure LLQ between 2 sites and apply "policy-map" at the Ethernet interface.

According cisco website, we really dont need LLQ on ethernet, it is because ethernet interface is faster than serial interface.

Correct me if I am wrong.

Ken

New Member

Re: VoIP QOS over 10mb Lan Extension.

Hi,

It's not wireless. It's a service BT supply if your two sites are on the same exchange. it's just a straight wire between the two routers. We tried two voice calls at G711 and transfered a lot of data and there were a few dropped voice packets.

I'll have a look at applying LLQ.

Thanks

Bronze

Re: VoIP QOS over 10mb Lan Extension.

If you have few dropped voice packets, I think you have to apply LLQ. Before apply LLQ, you have to "mark the traffic" and configure different VLAN just for voice. It really depends what kind of Cisco switch you have.

If you have switch that can do CoS-to-DSCP

Configure mapping and QoS on switch:

qos map cos 3 to dscp 26

qos map cos 4 to dscp 34

qos map cos 5 to dscp 46

interface FastEthernet3/4

switchport access vlan 4 <-- data vlan

switchport mode access

switchport voice vlan 6 <-- voice vlan

duplex full

qos trust cos

tx-queue 3

priority high

spanning-tree portfast

configure LLQ on router:

class-map match-all voice

match ip dscp ef

class-map match-all signaling

match ip dscp af31

!

!

policy-map voice-priority

class voice

priority percent 33

class signaling

bandwidth percent 2

class class-default

fair-queue

interface Serial0/1:0

bandwidth 1544

ip address 192.168.254.57 255.255.255.252

encapsulation ppp

no ip route-cache

service-policy output voice-priority <-- apply llq

If you switch doesnt have CoS-to-DSCP mapping capability (still need QoS on FastEthernet on switch), you have do mapping and LLQ both on router:

class-map match-all EF <--mapping

match ip dscp ef

class-map match-all AF31

match ip dscp af31

class-map match-all cos5

match cos 5

class-map match-all cos3

match cos 3

class-map match-all voice <--llq

match ip dscp ef

class-map match-all signaling

match ip dscp af31

!

!

policy-map map-cos-to-dscp <--mapping

class cos5

set ip dscp ef

class cos3

set ip dscp af31

class class-default

set ip dscp default

policy-map map-dscp-to-cos <--mapping

class EF

set cos 5

class AF31

set cos 3

class class-default

set cos 0

policy-map voice-priority <--llq

class voice

bandwidth percent 33

class signaling

bandwidth percent 2

class class-default

fair-queue

interface FastEthernet1/0.6

description west_hall_VOIP_vlan

encapsulation dot1Q 6

ip address 10.3.6.1 255.255.254.0

ip helper-address 10.0.0.20

service-policy input map-cos-to-dscp <--apply mapping

service-policy output map-dscp-to-cos <--apply mapping

interface ethernet 0/0

ip address 192.168.254.146 255.255.255.252

service-policy output voice-priority <--apply llq

I hope those configurations are not confuse you.

Let me know if you need help.

147
Views
0
Helpful
3
Replies