Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

VoIP & Qos & RTP priority

Hello,

I have 2 routers 1750-4V (1 FXO & 1 FXS each other) and because I have

a low speed link (64 Kbps) I have to use QoS, and define Voip traffic with

high priority. I define multilink ppp, and ip rtp, like :

> ip rtp header-compression iphc-format

> ip rtp priority 16384 16383 40

So when there is Voip traffic I want to reserve 40Kbps for it, but when

there is no Voip traffic, I want to have all the 64 Kbps available for data

traffic, and feel is not working like that, because is too slow.

My question is, this rtp command reserve a fixed bandwidth,although is

there not Voip traffic ?

So which other QoS can I use to reserve 40Kbps only when I have Voip

traffic, and have all the 64 Kbps available when there is only data traffic

?

Thanks a lot for your suggestions.

Regards,

Anacelia

1 REPLY
New Member

Re: VoIP & Qos & RTP priority

I would implement Low Latency Queuing...take a look: Be sure to have at least 12.1.3T loaded on your 1750.

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log datetime msec localtime

service password-encryption

!

hostname 1750-LIVONIA-R1

!

logging rate-limit console 10 except errors

enable secret 5 $1$LGwO$AGYLm4SQlWaa1c9vwnYVO1

!

username 3640-LISLE-R1 password 7 060506324F41

memory-size iomem 25

ip subnet-zero

no ip finger

no ip domain-lookup

!

!

class-map match-all VOICE

match access-group 102

!

!

policy-map QOS

class VOICE

priority 128 (<--the bandwidth you want allocated to voice calls)

class class-default

fair-queue

!

isdn switch-type basic-dms100

call rsvp-sync

!

!

!

!

!

!

!

!

interface BRI0

description Backup to Frame Relay Lisle

ip address 172.20.253.18 255.255.255.252

encapsulation ppp

dialer idle-timeout 600

dialer wait-for-carrier-time 10

dialer map ip 172.20.253.17 name 2610-LISLEFRAME-R2 broadcast 16303530368

dialer map ip 172.20.253.17 name 2610-LISLEFRAME-R2 broadcast 16303530361

dialer hold-queue 75

dialer load-threshold 128 either

dialer-group 1

isdn switch-type basic-dms100

isdn spid1 73463201230101

isdn spid2 73463201240101

ppp authentication chap

ppp multilink

!

interface FastEthernet0

ip address 172.20.66.254 255.255.255.0

speed auto

!

interface Serial0

no ip address

encapsulation frame-relay

no ip mroute-cache

cdp enable

frame-relay traffic-shaping

frame-relay qos-autosense

!

interface Serial0.1 point-to-point

ip address 172.20.254.10 255.255.255.252

frame-relay interface-dlci 30

class FRAME

frame-relay ip rtp header-compression

!

router eigrp 1

network 172.20.0.0

default-metric 64 200 255 1 1500

distribute-list 1 out

no auto-summary

eigrp log-neighbor-changes

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.20.253.17 240

no ip http server

!

!

map-class frame-relay FRAME

frame-relay cir 256000

frame-relay bc 2560

frame-relay be 0

frame-relay mincir 128000

no frame-relay adaptive-shaping

service-policy output QOS

frame-relay fragment 320

access-list 1 deny 172.20.253.0 0.0.0.255

access-list 1 permit any

access-list 100 deny eigrp any any

access-list 100 permit ip any any

access-list 102 permit udp any any range 16384 32767

access-list 102 permit tcp any eq 1720 any

access-list 102 permit tcp any any eq 1720

dialer-list 1 protocol ip list 100

!

!

line con 0

password 7 151C5902123E

login

transport input none

line aux 0

password 7 011D540A4D1F

login

modem InOut

modem autoconfigure type usr_sportster

speed 115200

flowcontrol hardware

line vty 0 4

password 7 030A0905101B

login

269
Views
0
Helpful
1
Replies
CreatePlease to create content