Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

VOIP QOS Setup

I am having issues with one-way audio from a branch office to the headquarters and need to make sure my qos is setup properly. Can anyone advise me on a proper setup. We have an mpls setup with a 1.5 port/768 cir and our COS from AT&T is 40% RT, 80/10/10 Data. Here is what I have now:

class-map match-any VOICE

match ip precedence 5

match protocol rtp

class-map match-any VOICE-CTRL

match ip precedence 3

match protocol skinny

match protocol h323

match dscp af31

!

!

policy-map QOS-OUT

class VOICE

priority 256

set dscp ef

class VOICE-CTRL

bandwidth 32

set dscp af21

class class-default

fair-queue

interface Serial0/1/0:0

no ip address

encapsulation frame-relay IETF

frame-relay lmi-type cisco

service-policy output QOS-OUT

!

interface Serial0/1/0:0.1 point-to-point

description MPLS

ip address X.X.X.X X.X.X.X

frame-relay interface-dlci 444

I have also tried setting up traffic shaping based on the cir,i.e.

map-class frame-relay shapeFT1

frame-relay cir 768000

frame-relay bc 7680

frame-relay be 0

frame-relay mincir 768000

service-policy output QOS-OUT

interface Serial0/1/0:0

no ip address

encapsulation frame-relay IETF

no fair-queue

frame-relay traffic-shaping

frame-relay lmi-type cisco

!

interface Serial0/1/0:0.1 point-to-point

description MPLS

ip address X.X.X.X X.X.X.X

frame-relay class shapeFT1

frame-relay interface-dlci 444

I have mrtg monitoring the bandwidth and it shows very little usage. Any suggestions would be greatly appreciated.

Thanks.

7 REPLIES
New Member

Re: VOIP QOS Setup

Hi,

one way audio is generally related with routing problems, do you have multiple IP address on your Gw?? what is the deployment that do you have, CME or CCM?? what protocol are you using for voice, H323??? witch party doesn't hear the audio??

if you have an MPLS link with more than one IP addresses, then you might need to do some config to bind the protocol (H323 or whatever) to the righ IP

regards,

Rodrigo

New Member

Re: VOIP QOS Setup

Rodrigo

Thanks for responding to this. We are running CM 4.1(3) with this branch using H323. These are internal calls going over our WAN. The person at our Headquarters where the CM is installed does not hear the audio. Our setup has 2 2801's. One for the WAN Router, One for the Voice Gateway to the PSTN. The one for the pstn also serves as a backup wan connection via a site-to-site tunnel to our headquarters over a dsl connection. H323 is binded to the correct internal interface. Attached are the configs. Thanks.

Hall of Fame Super Silver

Re: VOIP QOS Setup

First of all are your classes matching all of the RTP traffic properly? Is QoS configured on the switches, do you have "mls qos trust dscp" applied to the router uplinks and "mls qos trust cos" on all other ports as well as trunks to other switches? Also you said you have contracted for 40% real time, which should be 768*.4 = 307 kbps, I would suggest adjusting your priority class to that value, and possibly inculding voice control traffic in it as well.

Also, consider doing policing to the 307 kbps in this class as all MPLS service providers drop all excess real time traffic. So if you police it and remark down to another DSCP value that traffic has better chance of getting through.

Also, consider doing voice adaptinve traffic shaping within the policy-map instead of within frame-relat map-class to take advantage of the full T1 when voice is not present on the network.

Chris

New Member

Re: VOIP QOS Setup

Hi,

have you take off the service-policy of the interface??? the issue still happens??

could you put the commands

h323-gateway voip interface

h323-gateway voip bind srcaddr X.X.X.X

in the WAN router, and in the interface f0/0 theres a HSRP, are you sure that the response is directed to the VIP, and no to the interface IP?

Greetings

Rodrigo

New Member

Re: VOIP QOS Setup

Thanks for the responses.

Chris

How can I check to make sure all the rtp traffic is being matched? Should I look to change the class-map to include an access-list for my voice vlan? Can you provide an example of a better class-map setup?

Auto-qos is configured on our 3750 with mls qos trust dscp on the router uplinks and mls qos trust cos on all other ports. I adjusted the priority to 307 like you suggested, but not quite sure I understand what you mean by policing the priority traffic. I will look into the Voice-Adaptive Traffic Shaping configuration.

Rodrigo

Please excuse my lack of knowlege on this subject. What do I gain by removing the service policy off the interface. If I don't apply the service policy to an interface then how does the policy-map get applied to the traffic. I have h323 binding to the internal interface ip address of the voice gateway, not the virtual ip address. Should I have it binding to the Virtual IP Address? If it is binded to the virtual ip address then it will be sourcing the WAN router 95% of the time, and not the actual voice-gateway where all the voice settings are configured.

Once again. Thanks for you assistance.

New Member

Re: VOIP QOS Setup

We had a simmilar problem and solved it by configuring QoS between the voice gateway and the LAN switches in the remote branches. originally we only had QoS on the serial frame relay interfaces (marking traffic inbound on the LAN ports with a policy on the outbound wan interface) and auto qoS on the LAN ports on the 3560 switches but after also applying QoS on the voice gateway router-LAN side linking to the LAN switch solved the problem. One of my colleagues looked at it while I was working on something else but as far as I know he also used auto QoS on the router/voice gateway side

New Member

Re: VOIP QOS Setup

Typically, one-way audio is due to the remote gateway not having the mgcp bindings to a routeable address. Make sure the bindings can be routed end to end.

438
Views
0
Helpful
7
Replies
CreatePlease to create content