Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

What is the correct XML request for ccm 6.0

Hi,

i m tring to get getphone-data from my ccm6.0 with a axl call.

here is what i have, which is a example out of the toolkit, i guess its old, so it doesnt work with my ccm6.0

xmlhttp.Open("POST", "http://" + ccmserver + "/CCMApi/AXL/V1/soapisapi.dll", false);

xmlhttp.setRequestHeader("Authorization", "Basic " + authstring);

xmlhttp.setRequestHeader("Content-type", "text/xml");

xmlhttp.Send(xmlDoc);

can anyone help me and share the correct lines for this request?

thanks

9 REPLIES
New Member

Re: What is the correct XML request for ccm 6.0

Hi.

Since CCM 5.0 you should user a POST request to https://:8443/axl/

New Member

Re: What is the correct XML request for ccm 6.0

yeah.. my java programm with the soap call, which works fine, is using

http://myserver/AXL/

i tryied it in my jva-script, but its not working, i also tried https, but in both cases i dont even get an entry in the trace files..:-((

here is what i use in my java programm

sAXLSOAPRequest = "POST /axl/ HTTP/1.0\r\n";

sAXLSOAPRequest += "xxxxxxxxx:8443\r\n";

sAXLSOAPRequest += "Authorization: Basic " + authorization + "\r\n";

sAXLSOAPRequest += "Accept: text/*\r\n";

sAXLSOAPRequest += "Content-type: text/xml\r\n";

sAXLSOAPRequest += "SOAPAction: \"CUCM:DB ver=6.0\"\r\n";

sAXLSOAPRequest += "Content-length: ";

and in my java-script i tryied..

xmlhttp.Open("POST", "http://" + ccmserver + "/AXL/", false);

xmlhttp.setRequestHeader("Authorization", "Basic " + authstring);

xmlhttp.setRequestHeader("Content-type", "text/xml");

xmlhttp.Send(xmlDoc);

but with no success..:-((

can anybody help?

thanks

New Member

Re: What is the correct XML request for ccm 6.0

Try using the port 8443 after the server's ip address and the https as the protocol:

xmlhttp.Open("POST", "https://" + ccmserver + ":8443/AXL/", false);

What response did you receive from axl?

New Member

Re: What is the correct XML request for ccm 6.0

hi,

i dont get any answer, there isnt even an entry in the trace files, if i try https i get an xml error...:-((

New Member

Re: What is the correct XML request for ccm 6.0

this is what i tried now... without any changes..

xmlhttp.Open("POST", "http://myserver:8443/AXL/ HTTP/1.0", false);

xmlhttp.setRequestHeader("Authorization", "Basic " + authstring);

xmlhttp.setRequestHeader("Accept", "text/*");

xmlhttp.setRequestHeader("SOAPAction", "CUCM:DB ver=6.0");

xmlhttp.setRequestHeader("Content-type", "text/xml");

xmlhttp.Send(xmlDoc);

any ideas??

New Member

Re: What is the correct XML request for ccm 6.0

Did you success your request ?

I'm trying to do the same in C#, but no success.

New Member

Re: What is the correct XML request for ccm 6.0

i switch from asp to jsp....

there i can implement my java application and handle the certificats and the https stuff...

New Member

Re: What is the correct XML request for ccm 6.0

Has anyone gotten this to work with C# yet? I'm trying to do the same thing, posting to "http://" + ccmserver + "/CCMApi/AXL/V1/soapisapi.dll"

What is the correct path?

Is it all SSL now, as some of the previous posts seem to indicate?

Is there a AXL test page similar to the one in call manager express?

Thanks for any help,

Brian

Re: What is the correct XML request for ccm 6.0

No there's no AXL test page. however, you mention the URL to be used for callmanager 4.. in a thread about callmanager 6. Do you see where this confuses people?

The first thing you need to be sure about is which CCM version.

Next, the code you're using to send the request, and then the error message you get.

273
Views
0
Helpful
9
Replies
CreatePlease to create content