Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Where are the cnf and xml files?

Our system is CME 3.2 on a 2851 router running IOS 12.3(11)T10.

I read that *.cnf files are created for phone configuration and there should also be directory.xml file (I think).

But where are they? When I do a "dir" I see only the files in flash, such as the phone loads, but there are no cnf files. The only xml file is the one I added (RingList.xml).

Is there a hidden file location? Or another way to search?

This router is not a TFTP server (host). The tech who configured it used his own laptop as a TFTP server and that is long gone. But shouldn't those cnf files be somewhere on the router?

7 REPLIES

Re: Where are the cnf and xml files?

Here is the command to display the tftp-bindings for the phones. I believe CME requires the TFTP running local so it must have been configured at one time and then disabled. You phones are probably using their cached configs.

Use the show telephony-service tftp-bindings command to display the current configuration files that are accessible to IP phones using TFTP. It may also be used to display the current locale codes that are associated with dictionary, language, and call progress tone files.

cme-3725# show telephony-service tftp-bindings

tftp-server system:/its/SEPDEFAULT.cnf

tftp-server system:/its/SEPDEFAULT.cnf alias SEPDefault.cnf

tftp-server system:/its/XMLDefault.cnf.xml alias XMLDefault.cnf.xml

tftp-server system:/its/ATADefault.cnf.xml

tftp-server system:/its/XMLDefault7960.cnf.xml alias SEP00036BAAD1F8.cnf.xml

tftp-server system:/its/XMLDefault7960.cnf.xml alias SEP00036BAAD362.cnf.xml

tftp-server system:/its/XMLDefault7910.cnf.xml alias SEP00044D021CA6.cnf.xml

tftp-server system:/its/united_states/7960-tones.xml alias United_States/7960-tones.xml

tftp-server system:/its/united_states/7960-font.xml alias English_United_States/7960-font.xml

tftp-server system:/its/united_states/7960-dictionary.xml alias English_United_States/7960-dictionary.xml

tftp-server system:/its/united_states/7960-kate.xml alias English_United_States/7960-kate.xml

tftp-server system:/its/united_states/SCCP-dictionary.xml alias English_United_States/SCCP-dictionary.xml

Please rate any helpful posts

Thanks

Fred

New Member

Re: Where are the cnf and xml files?

That's very helpful. Thank you.

Two questions:

1. Can these config files be copied to a TFTP server? I tried a

'copy XMLDefault.cnf.xml tftp'

but got the (File not Found) error.

Do I need to first add the file into flash? (Would that cause any problem?)

2. Where is the Directory xml file? How can I view / edit that? Our local directory seems to have gotten corrupted and I want to edit the file (or recreate it if there is a way).

Re: Where are the cnf and xml files?

Miriam,

1. I wouldn't recommend trying to offload your TFTP from the router. Is there a specific reason for this? CME is a turn-key all in one solution and is designed to be that way. Some configuration files might be cached in memory (as CCM does) but I'm not sure. I would really consider weighing the benefits and pitfalls of doing this. As per my last post that file is located in, tftp-server system:/its/XMLDefault.cnf.xml alias XMLDefault.cnf.xml. This will not be at the root of flash.

2. Not sure off the top of my head but I will look for it. Try doing this on the router first under telephony-service.

no service local-directory

then

service local-directory

Here is also the debug for the directory. Let me know if this helps.

debug ip http token

Make sure the IP HTTP server is enabled and isn't secured to disallow your phones. Here are additional debugs for that.

debug ip http url

debug ip http transaction

Whats the exact directory issue you are getting?

Please rate any helpful posts

Thanks

Fred

New Member

Re: Where are the cnf and xml files?

It's a strange directory problem. Not a major thing but an annoyance. The directory works, except lookups for names beginning with the letter "D". That's why I think a line in the file is messed up.

I tried your suggestion (no service, service) but that did not help. I have turned on the debugging.

I'll see what turns up in the Syslog, or is there a way to view the debug data from the CLI on the gateway?

Thank you again!

Re: Where are the cnf and xml files?

Term mon and make sure monitor logging is at debug. It should be standard IOS debug.

Thanks

Fred

New Member

Re: Where are the cnf and xml files?

I got the debug output using

'terminal monitor'

when I looked up the letter "D" (or "d") names, it says on the terminal that 4 are found, but nothing shows up on the 7940 phone screen (or any other phone's screen). It's just blank.

DEBUG OUTPUT:

Sep 14 19:18:08.344: Thu, 14 Sep 2006 19:18:08 GMT /localdirectory/search ok

Protocol = HTTP/1.1 Method = GET Query = l=d

local_directory_search_get_action: minor = 2, uri_index =l=d

ipkeyswitch_ldir_send_file 1: page 2

ipkeyswitch_ldir_send_file 3: to send prologue

ipkeyswitch_dir_search_result 1: l=d

ipkeyswitch_dir_search_result 2: l=d

ipkeyswitch_dir_search_result token:f=, l=d

ipkeyswitch_dir_search_result length:f=0, l=1

ipkeyswitch_dir_search_result matches: 4

Re: Where are the cnf and xml files?

1st thing, asking the obvious, the last name begins with d correct? Your http queury is looking for l=d, last name d. Sorry I have to ask the obvious.

Ok with that out of the way, are you receiving this back in your debug?

.Sep 14 16:24:34.695 EDT: ipkeyswitch_dir_search_result found:f=, l=**Match**

The **Match** represents the name. You had removed some debug so I just wanted to verify this. If you have a laptop with Ethereal then you might want to capture this HTTP request by plugging into the pc port of the phone. This way you can determine if it is an issue on the CME/HTTP server or the phone. I have packet sniffed this and after the query you should get back a XML formatted HTTP server reply with your user info. Make sure this is indeed not coming from the CME. If it is then it might be a load issue. CME is stringent on the supported phone firmwares. Here are the links to the supported firmwares, do a sh telephony-service to determine your exact 3.2 version.

3.2

http://www.cisco.com/univercd/cc/td/doc/product/voice/its/cme32/cme32spc.htm

3.2.1

http://www.cisco.com/en/US/products/sw/voicesw/ps4625/prod_installation_guide09186a0080520268.html

3.2.2

http://www.cisco.com/en/US/products/sw/voicesw/ps4625/prod_installation_guide09186a008052025b.html

Thanks

Fred

297
Views
4
Helpful
7
Replies