Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Why does ppp multilink drop the serial line

When I use the 'ppp multilink' command on my 3640 serial interface I lose the connection to remote router. use 'no ppp multilink' it comes back.

scenario: main router 3640, remote office 2620

IOS (tm) 3600 Software (C3640-IS-M), Version 12.2(6a)

IOS (tm) C2600 Software (C2600-IS-M), Version 12.0(7)XK1

I'm trying to prioritise traffic for the voice betwen two meridian switches across a 512k leased line.

Was using hdlc and the 'mtu 600' on the serials on each router, the voice was better, but the http traffic timed out (apparently some sites set the DF flag bit to increase throughput??).

I then switched to ppp on the interfaces so that I could use ppp multilink interleave and ppp multilink fragment-delay. ppp multilink command is fine on the 2620 but when entered on the 3640 the connection drops and stays dropped.

Is the only way to do this to set up a virtual interface? Say, multilink1 and attach everything to that?

interfaces set up as follows:

3640:

interface Serial1/0

description *****512k-serial to remote*****

bandwidth 512

ip address 192.168.4.1 255.255.255.252

encapsulation ppp

ip tcp header-compression iphc-format

service-policy output voice-link

ip rtp header-compression iphc-format

2620:

interface Serial0/0

description *****512K-serial to main*****

bandwidth 512

backup delay 1 300

backup interface BRI0/0

ip address 192.168.4.2 255.255.255.252

no ip directed-broadcast

encapsulation ppp

ip tcp header-compression iphc-format

no ip mroute-cache

service-policy output voice-link

ppp multilink

ip rtp header-compression iphc-format

service policy:

class-map voice

match access-group 101

!

!

policy-map voice-link

class voice

priority 384

class class-default

fair-queue

Access list 101 is set for all udp between the two address assign to the meridian switches.

Thanks.

  • Other Collaboration Voice and Video Subjects
2 REPLIES
New Member

Re: Why does ppp multilink drop the serial line

Hi, this is not a recommended configuration. You should for stability first put the 2600 on the same or similar IOS train as 3640. 12.2.6a is also not the latest mainline and may have some bugs, try 12.2.10 or latest 12.2 on CCO.

Here is the recommended configuration for MLPPP on both sides, with correct bandwidth statements, and this should work, you may have to reset the serial interface after configuring but you should not have any other problems:

http://www.cisco.com/warp/customer/788/voice-qos/voip-mlppp.html

Make sure to configure the virtula multilink interface and bind it to your serial interface.

Hope this helps.

New Member

Re: Why does ppp multilink drop the serial line

Thanks, I'm on the case.

247
Views
0
Helpful
2
Replies