Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

WS-X4606-gwy module

Can WS-X4606-gwy module support L3 routing?

the ios image:c4gwy-io3sx3-mz.121-5.YF4.bin. Can the voice gateway module support vlan routing with this ios? is there any sample configuration available?

there seems don't have enough info on this module from cisco web site.

Thanks in advance!

Sara

10 REPLIES

Re: WS-X4606-gwy module

Sara,

Yes you can do inter-vlan routing with the AGM module. Use the Gbit interface as the trunk and configure the subinterfaces. I can't send you any configs but I know it does work and have used it to do just this in the past.

Paul

New Member

Re: WS-X4606-gwy module

Paul,

Thanks for the info, i tried that, create subinterface at gbit interface, encap dot1q. but it doesn't seems to work. do you need to set some backplane port as trunk also?

Sara

New Member

Re: WS-X4606-gwy module

Sara, I would love to see your config so far. I have been un able to get inter vlan routing working so far. I do believe you need to set the backplane to trunk. Ie go into your cat 4006 and set slot/port to trunk. I have my back plane trunking, but I do not know how to get the AGM trunking.

New Member

Re: WS-X4606-gwy module

The voice gateway is at mod 5

Router:

interface GigabitEthernet0/0

no ip address

interface GigabitEthernet0/0.1

description Virtual Routing Interface for User VLAN - user192_v

encapsulation dot1Q 100

ip address 10.178.192.254 255.255.255.0

!

interface GigabitEthernet0/0.2

description Virtual Routing Interface for Server VLAN - server223_v

encapsulation dot1Q 200

ip address 10.178.223.254 255.255.255.0

!

interface GigabitEthernet0/0.3

description Virtual Routing Interface for Voice VLAN - voice196_v

encapsulation dot1Q 300

ip address 10.178.196.254 255.255.255.0

Switch:

#module 5 : 1-port Voice Gateway

set trunk 5/1 nonegotiate dot1q 1-1005

!

sho ip route

Fragmentation Redirect Unreachable

------------- -------- -----------

enabled enabled enabled

The primary gateway: 10.178.223.254

ASTAR_C4006_C01> (enable) sho ver

WS-C4006 Software, Version NmpSW: 7.1(2)

Copyright (c) 1995-2002 by Cisco Systems, Inc.

NMP S/W compiled on Feb 7 2002, 16:53:43

GSP S/W compiled on Feb 07 2002, 15:24:55

System Bootstrap Version: 5.4(1)

Hardware Version: 3.2 Model: WS-C4006 Serial #: FOX0609005U

Mod Port Model Serial # Versions

--- ---- ------------------ --------------------

---------------------------------

1 2 WS-X4013 JAE061502JN Hw : 3.2

Gsp: 7.1(2.0)

Nmp: 7.1(2)

2 48 WS-X4148-RJ45V JAE061207GK Hw : 1.6

3 48 WS-X4148-RJ45V JAE061207PR Hw : 1.6

4 48 WS-X4148-RJ45V JAE061300FU Hw : 1.6

5 1 WS-X4604-GWY JAB0446050V Hw : 1.8

what is missing?

Regards

Sara

New Member

Re: WS-X4606-gwy module

Sara,

I am using that module. We have the VWIC (MFT) installed and use for WAN connectivity. I had a bit of trouble getting it to work myself. You do know that the L3 part only supports (5 or 6 forgot) VLANS. I pruned all but the needed ones on the Dot1q trunk. Also What about the "native' VLAN at L3? Once I did all that everything seemed to work fine.

Are you using it for transcoding? Also there are some bugs in that version of IOS with Frame Relay. I upgraded to 12.2.7b and works fine.

Jim

New Member

Re: WS-X4606-gwy module

Hi Jim,

I am Sara's colleague.

I have tried to clear the trunk on the gig port leaving behind just 5 VLANs. see config:

#module 5 : 1-port Voice Gateway

clear trunk 5/1 2-99,101-199,201-299,301-400,402-1005

set trunk 5/1 nonegotiate dot1q 1,100,200,300,401

but it doesn't seem to work. Do you have any sample configuration to share?

paul

New Member

Re: WS-X4606-gwy module

Sara,

Here is a sample config that works.......Jim

set vlan 1 name default type ethernet mtu 1500 said 100001 state active

set vlan 2 name VLAN2 type ethernet mtu 1500 said 100002 state active

set vlan 3 name VLAN3 type ethernet mtu 1500 said 100003 state active

set vlan 4 name VLAN4 type ethernet mtu 1500 said 100004 state active

set vlan 5 name VLAN5 type ethernet mtu 1500 said 100005 state active

set vlan 10 name VLAN10 type ethernet mtu 1500 said 100010 state active

set vlan 50 name VLAN50 type ethernet mtu 1500 said 100050 state active

set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active

set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state active stp ieee

set vlan 1005 name trnet-default type trbrf mtu 1500 said 101005 state active stp ibm

set vlan 1003 name token-ring-default type trcrf mtu 1500 said 101003 state active mode srb are

maxhop 0 stemaxhop 0 backupcrf off

!

#ip

set interface sc0 4 172.18.90.7/255.255.255.0 172.18.90.255

set interface sl0 down

set interface me1 down

set ip route 0.0.0.0/0.0.0.0 172.18.90.1

!

#syslog

set logging console disable

set logging level cops 2 default

!

#set boot command

set boot config-register 0x2

set boot system flash bootflash:cat4000.6-1-1.bin

!

#mls

set mls nde disable

!

#module 1 : 2-port 1000BaseX Supervisor

!

#module 2 : 18-port 1000BaseX Ethernet

set udld enable 2/7-10

set trunk 2/1 on dot1q 1-1005

set trunk 2/2 on dot1q 1-1005

set trunk 2/3 on dot1q 1-1005

set trunk 2/4 on dot1q 1-1005

set trunk 2/5 on dot1q 1-1005

set trunk 2/6 on dot1q 1-1005

set trunk 2/7 on dot1q 1-1005

set trunk 2/8 on dot1q 1-1005

set trunk 2/9 on dot1q 1-1005

set trunk 2/10 on dot1q 1-1005

!

#module 3 : 48-port Inline Power Module

set vlan 5 3/3-4

!

#module 4 : 1-port Voice Gateway

clear trunk 4/1 6-49,51-1005

set trunk 4/1 on dot1q 1-5,50

!

#module 5 empty

!

#module 6 empty

end

BCO-4006-L2 (enable)

LAYER PIECE

hostname BCO-4000-GWY

!

boot system flash flash:c4gwy-io3s-mz.122-7b.bin

no logging buffered

enable secret 5 $1$st0m$NQmDWhIPNOWlYR7tyw0Nf0

!

ip subnet-zero

ip wccp web-cache

!

ip audit notify log

ip audit po max-events 100

!

class-map match-all voice384

match access-group 166

class-map match-all voice192

match access-group 166

!

!

policy-map voice192-policy

class voice192

priority 100

class class-default

fair-queue

policy-map voice384-policy

class voice384

priority 120

class class-default

fair-queue

!

!

controller T1 1/0

framing esf

linecode b8zs

channel-group 0 timeslots 1-24

!

!

!

interface FastEthernet0/0

no ip address

speed 100

full-duplex

arp timeout 600

!

interface GigabitEthernet0/0

no ip address

no negotiation auto

!

interface GigabitEthernet0/0.1

encapsulation dot1Q 50

ip address 172.17.90.1 255.255.255.0

ip helper-address 10.90.10.111

!

interface GigabitEthernet0/0.2

encapsulation dot1Q 2

ip address 192.168.90.1 255.255.255.0

!

interface GigabitEthernet0/0.4

encapsulation dot1Q 1 native

!

interface GigabitEthernet0/0.5

encapsulation dot1Q 5

ip address 10.90.10.1 255.255.254.0

!

interface GigabitEthernet0/0.10

encapsulation dot1Q 4

ip address 172.18.90.1 255.255.255.0

!

interface Serial1/0:0

no ip address

encapsulation frame-relay

frame-relay traffic-shaping

frame-relay lmi-type cisco

frame-relay ip rtp header-compression passive

!

interface Serial1/0:0.2 point-to-point

description Frame Relay to BEH

ip address 172.16.70.2 255.255.255.252

frame-relay interface-dlci 23

class voip192

!

interface Serial1/0:0.3 point-to-point

description Frame Relay to GMS

ip address 172.16.10.2 255.255.255.252

frame-relay interface-dlci 21

class voip192

!

interface Serial1/0:0.4 point-to-point

description Frame Relay to WOP

ip address 172.16.60.2 255.255.255.252

frame-relay interface-dlci 20

class voip192

!

interface Serial1/0:0.5 point-to-point

description Frame Relay to RLA

ip address 172.16.20.2 255.255.255.252

frame-relay interface-dlci 18

class voip192

!

interface Serial1/0:0.6 point-to-point

description Frame Relay to GEO

ip address 172.16.40.2 255.255.255.252

frame-relay interface-dlci 19

class voip192

!

interface Serial1/0:0.7 point-to-point

description Frame Relay to MCK

ip address 172.16.50.2 255.255.255.252

frame-relay interface-dlci 24

class voip192

!

interface Serial1/0:0.8 point-to-point

description frame realy to GHS

ip address 172.16.30.2 255.255.255.252

frame-relay interface-dlci 17

class voip384

!

router eigrp 382

redistribute static

network 10.0.0.0

network 172.16.0.0

network 172.17.0.0

network 172.18.0.0

network 192.168.90.0

no auto-summary

no eigrp log-neighbor-changes

!

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 10.90.10.118

ip pim bidir-enable

!

!

map-class frame-relay voip192

no frame-relay adaptive-shaping

frame-relay cir 192000

frame-relay bc 1920

frame-relay be 0

frame-relay mincir 192000

service-policy output voice192-policy

frame-relay fragment 240

!

map-class frame-relay voip384

no frame-relay adaptive-shaping

frame-relay cir 384000

frame-relay bc 3840

frame-relay be 0

frame-relay mincir 384000

service-policy output voice384-policy

frame-relay fragment 480

access-list 166 permit udp any any range 16384 32767 precedence critical

access-list 166 permit tcp any eq 1720 any

access-list 166 permit tcp any any eq 1720

New Member

Re: WS-X4606-gwy module

Thanks Jim.

Sara

New Member

Re: WS-X4606-gwy module

after configuring one of the subinterface to native vlan. it actually allow me to reach 3 of the 4 vlan i have configured despite making changes here and there

after a few reboot, all inter vlan routing cease to work..

attached is the config:

vtp

set vtp domain astarvlan

set vlan 1 name default type ethernet mtu 1500 said 100001 state active

set vlan 2 name server223_v type ethernet mtu 1500 said 100002 state active

set vlan 3 name etpl204_v type ethernet mtu 1500 said 100003 state active

set vlan 4 name user192_v type ethernet mtu 1500 said 100004 state active

set vlan 50 name voice196_v type ethernet mtu 1500 said 100050 state active

--More-- set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active

set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state active stp ieee

set vlan 1005 name trnet-default type trbrf mtu 1500 said 101005 state active stp ibm

set vlan 1003 name token-ring-default type trcrf mtu 1500 said 101003 state active mode srb aremaxhop 7 stemaxhop 7 backupcrf off

!

#ip

set interface sc0 2 10.178.223.253/255.255.255.0 10.178.223.255

set interface sl0 down

set interface me1 down

set ip route 0.0.0.0/0.0.0.0 10.178.223.254

!

#spantree

#backbonefast

set spantree backbonefast enable

#vlan

set spantree priority 0 2

set spantree priority 0 3

set spantree priority 0 4

set spantree priority 0 50

#module 5 : 1-port Voice Gateway

clear trunk 5/1 5-49,51-1005

set trunk 5/1 nonegotiate dot1q 1-4,50

ASTAR_C4006_C01> (enable) sho ver

WS-C4006 Software, Version NmpSW: 7.1(2)

Copyright (c) 1995-2002 by Cisco Systems, Inc.

NMP S/W compiled on Feb 7 2002, 16:53:43

GSP S/W compiled on Feb 07 2002, 15:24:55

System Bootstrap Version: 6.1(4)

Hardware Version: 3.2 Model: WS-C4006 Serial #: FOX0609005U

Mod Port Model Serial # Versions

--- ---- ------------------ -------------------- ---------------------------------

1 2 WS-X4013 JAE061502JN Hw : 3.2

Gsp: 7.1(2.0)

Nmp: 7.1(2)

2 48 WS-X4148-RJ45V JAE061207GK Hw : 1.6

3 48 WS-X4148-RJ45V JAE061207PR Hw : 1.6

4 48 WS-X4148-RJ45V JAE061300FU Hw : 1.6

5 1 WS-X4604-GWY JAB0446050V Hw : 1.8

DRAM FLASH NVRAM

Module Total Used Free Total Used Free Total Used Free

------ ------- ------- ------- ------- ------- ------- ----- ----- -----

1 65536K 36772K 28764K 16384K 7391K 8993K 480K 330K 150K

--More--

Uptime is 0 day, 16 hours, 13 minutes

ASTAR_C4006_C01> (enable) sho flash

-#- ED --type-- --crc--- -seek-- nlen -length- -----date/time------ name

1 .. ffffffff 6fb66023 45e468 20 4318184 --- -- ---- --:--:-- cat4000-k8.7-1-2.bin

2 .D ffffffff 1 45e4e8 29 0 May 13 2002 23:02:12 cat4000-promupgrade.6-1-4.bin

3 .. ffffffff f78babc 657a94 29 2069804 May 13 2002 23:07:52 cat4000-promupgrade.6-1-4.bin

9209196 bytes available (6388372 bytes used)

ASTAR_C4006_C01> (enable) session 5

Trying IntlgLineCard-5...

Connected to IntlgLineCard-5.

Escape character is '^]'.

ASTAR-4006-VGWY>en

ASTAR-4006-VGWY#sho run

Building configuration...

Current configuration : 1393 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname ASTAR-4006-VGWY

!

!

ip subnet-zero

!

ip audit notify log

ip audit po max-events 100

call rsvp-sync

!

!

!

!

!

voicecard mode toll-by-pass

!

--More-- controller E1 1/0

channel-group 0 timeslots 1-31

!

controller E1 1/1

channel-group 0 timeslots 1-31

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/0

no ip address

no negotiation auto

!

interface GigabitEthernet0/0.1

encapsulation dot1Q 1 native

!

interface GigabitEthernet0/0.2

description Virtual Routing Interface for User VLAN - user192_v

encapsulation dot1Q 4

--More-- ip address 10.178.192.254 255.255.255.0

!

interface GigabitEthernet0/0.4

description Virtual Routing Interface for Voice VLAN - voice196_v

encapsulation dot1Q 50

ip address 10.178.196.254 255.255.255.0

!

interface GigabitEthernet0/0.5

description Virtual Routing Interface for ETPL VLAN - etpl204_v

encapsulation dot1Q 3

ip address 10.178.204.254 255.255.255.0

!

interface GigabitEthernet0/0.10

description Virtual Routing Interface for Server VLAN - server223_v

encapsulation dot1Q 2

ip address 10.178.223.254 255.255.255.0

!

interface Serial1/0:0

no ip address

!

interface Serial1/1:0

no ip address

!

--More-- no ip http server

ip classless

ip pim bidir-enable

!

!

!

line con 0

line vty 0 4

login

!

end

ASTAR-4006-VGWY#

New Member

Re: WS-X4606-gwy module

the problem is resolved by removing vlan 1. thanks everyone.

152
Views
0
Helpful
10
Replies
CreatePlease login to create content