Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Ask the Expert: Cisco Nexus 2000, 5000, and 6000 Series Switches

Read the biowith Cisco Expert Vinayak Sudame

Welcome to the Cisco Support Community Ask the Expert conversation. This is an opportunity to learn and ask questions how to configure and troubleshoot the Cisco Nexus 2000, 5000 and 6000 Series Switches with Cisco subject matter expert Vinayak Sudame. You can ask any question on configuration, troubleshooting, features, design and Fiber Channel over Ethernet (FCoE).

Vinayak Sudame is a Technical Lead in Data Center Switching Support Team within Cisco's Technical Services in RTP, North Carolina. His current responsibilities include but are not limited to Troubleshooting Technical support problems and Escalations in the areas of Nexus 5000, Nexus 2000, FCoE. Vinayak is also involved in developing technical content for Cisco Internal as well as external. eg, Nexus 5000 Troubleshooting Guide (CCO), Nexus 5000 portal (partners), etc. This involves cross team collaboration and working with multiple different teams within Cisco. Vinayak has also contributed to training account teams and partners in CAE (Customer Assurance Engineering) bootcamp dealing with Nexus 5000 technologies. In the past, Vinayak's responsibilities included supporting MDS platform (Fiber Channel Technologies) and work with EMC support on Escalated MDS cases. Vinayak was the Subject Matter Expert for Santap Technologies before moving to Nexus 5000 support. Vinayak holds a Masters in Electrical Engineering with Specialization in Networking from Wichita State University, Kansas. He also holds Cisco Certification CCIE (#20672) in Routing and Switching.

Remember to use the rating system to let Vinayak know if you have received an adequate response.

Vinayak might not be able to answer each question due to the volume expected during this event. Remember that you can continue the conversation on the  Data Center sub-community, Other Data Center Topics discussion forum shortly after the event.

This event last through Friday July 12, 2013. Visit the community often to view responses to youe questions of other community members.

41 REPLIES
New Member

Ask the Expert: Cisco Nexus 2000 and 5000

Hi Vnayak,

We  have two Nexus 5548 switches along with a coupe of dual homed FEXes.  All vlan, portchannel, interface configurations were done in 'conf sync'  mode.

We  continued like this and faced no problems. However recently i found out  that after a change, i tried to verify and commit, however there is an  error saying that the peer is not reachable. But i am able to ping both  the Nexus switches from each others console via the appropiate vrfs. I  noticed that on switch 1 i am able to see the cfs peers, but on switch 2  on giving the command following is the output:-

5548_02# show cfs peers

CFS Discovery is in Progress ..Please wait

Could not get response. The network topology may be under going change.

Please try after about 30 seconds

5548_02#

{{ Above output takes some time to display}}

I  am not able to find much information about this. I disabled CFSoIP and  re enabled it. Still same result. I am actually stuck here. The other  things to do would be delete the switch profile and add back again or  may be reload the switch.

Any help would be appreciated.

The NX OS is:-

BIOS:      version 3.6.0

loader:    version N/A

kickstart: version 5.2(1)N1(2a)

system:    version 5.2(1)N1(2a)

power-seq: Module 1: version v1.0

Module 3: version v2.0

On switch 1 peers are showing up as normal:-

5548_01# sh cfs peer

Physical Fabric

-------------------------------------------------------------------------

Switch WWN              IP Address

-------------------------------------------------------------------------

20:00:54:7f:ee:b7:c2:80 172.16.1.53                           [Local]

                         5548_01

20:00:54:7f:ee:b6:99:c0 172.16.1.51

20:00:54:7f:ee:b6:9c:00 172.16.1.52

20:00:54:7f:ee:b6:3f:80 172.16.1.54

Total number of entries = 4

Any feed back would be appreciated.

Thanks in advance!!.

Regards

Cisco Employee

Ask the Expert: Cisco Nexus 2000 and 5000

Hello Sonu

I have few initial questions on your query.

- Is switch 2 vpc primary or secondary ?

- Are these switches configured for FC/FCoE ?

- Were these switches upgraded non-disruptively in the past ?

- How are the mgmt ports physically connected ? Are they back-to-back or connecting to other 5k/2k switch ?

- On Switch 2 are you able to perform 'show run', 'config t' and other tasks without any problems ?

Can you send output of

show cfs lock

show system internal csm info trace

show cfs internal ethernet-peer database

- 'show cfs peers' output on Switch 2 was it working correctly before this issue happened? Do you know ?

- I have seen before that sometimes it would take time for that command output to be displayed but in our case Switch 2 could be having issues syncing with Switch1.

Thanks, Vinayak

New Member

Re: Ask the Expert: Cisco Nexus 2000 and 5000

Hi Vinayak,

Thanks for the reply.

As of now i do not have access to the device, but i will answer your queries.

Is switch 2 vpc primary or secondary ?

Vpc secondary

-Are these switches configured for FC/FCoE ?

No

Were these switches upgraded non-disruptively in the past ?

Yes, the upgrade went smoothly

On Switch 2 are you able to perform 'show run', 'config t' and other tasks without any problems?

Yes

How are the mgmt ports physically connected ? Are they back-to-back or connecting to other 5k/2k switch ?

The management ports of both Nexus 5548 switches are connected to a 3750X stack switch in an appropriate vlan

Since i do not have access to switches, i am not in a position to send the outputs but from memory the "show cfs lock" shows no output i.e. no pending locks

'show cfs peers' output on Switch 2 was it working correctly before this issue happened? Do you know ?

Yes "show cfs peers" command was giving proper output before.

Everything was working properly. Ping from one switch to another to peer IP is working properly via appropriate vrf.

I will send the output of the other commands as soon as i get them.

We have about 40 live servers connected to these 5548/FEXes.

Regards.

New Member

Re: Ask the Expert: Cisco Nexus 2000 and 5000

Hi Vinayak,

Output of "show cfs internal ethernet-peer database"

Switch 1

ETH Fabric

-------------------------------------------------------------------------

Switch WWN              logical-if_index

-------------------------------------------------------------------------

20:00:54:7f:ee:b7:c2:80 [Local]

20:00:54:7f:ee:b6:3f:80 16000005

Total number of entries = 2

Switch 2

ETH Fabric

-------------------------------------------------------------------------

Switch WWN              logical-if_index

-------------------------------------------------------------------------

20:00:54:7f:ee:b6:3f:80 [Local]

20:00:54:7f:ee:b7:c2:80 16000005

Total number of entries = 2

Output of "show system internal csm info trace"

Switch 1 in which "show cfs peers" show proper output

Mon Jul  1 05:46:19.145339  (CSM_T) csm_sp_buf_cmd_tbl_expand_range(8604): No range command in buf_cmd_tbl.

Mon Jul  1 05:46:19.145280  (CSM_T) csm_set_sync_status(6257): Peer RT status PSSed

Mon Jul  1 05:46:19.145188  (CSM_T) csm_sp_handle_local_verify_commit(4291):

Mon Jul  1 05:46:19.145131  csm_continue_verify_ac[597]: peer is not reachable over CFS so continuing with local verify/commit

Mon Jul  1 05:46:19.145071  csm_tl_lock(766): Peer information not found for IP address: '172.16.1.54'

Mon Jul  1 05:46:19.145011  csm_tl_lock(737):

Mon Jul  1 05:46:19.144955  (CSM_EV) csm_sp_build_tl_lock_req_n_send(941): sending lock-request for CONF_SYNC_TL_SESSION_TYPE_VERIFY subtype 0 to Peer ip = (172.16.1.54)

Mon Jul  1 05:46:19.143819  (CSM_T) csm_copy_image_and_internal_versions(788): sw_img_ver: 5.2(1)N1(2a), int_rev: 1

Mon Jul  1 05:46:19.143761  (CSM_T) csm_sp_get_peer_sync_rev(329): found the peer with address=172.16.1.54 and sync_rev=78

Mon Jul  1 05:46:19.143699  (CSM_T) csm_sp_get_peer_sync_rev(315):

Mon Jul  1 05:46:19.143641  (CSM_EV) csm_sp_build_tl_lock_req_n_send(838): Entered fn

Mon Jul  1 05:46:19.143582  (CSM_T) csm_set_sync_status(6257): Peer RT status PSSed

Switch 2 in which "show cfs peers" does not show proper output

Mon Jul  1 06:13:11.885354  (CSM_ERR) csm_pss_cmd_tree_walk_cb(2057): Parent command not found for cmd switchport mode trunk, cmd pseq 77 seq 482

Mon Jul  1 06:13:11.884992  (CSM_ERR) csm_pss_cmd_tree_walk_cb(2057): Parent command not found for cmd channel-group 51 mode active, cmd pseq 357 seq 369

Mon Jul  1 06:13:11.884932  (CSM_ERR) csm_pss_cmd_tree_walk_cb(2057): Parent command not found for cmd switchport trunk allowed vlan 2, 11, cmd pseq 357 seq 368

Mon Jul  1 06:13:11.884872  (CSM_ERR) csm_pss_cmd_tree_walk_cb(2057): Parent command not found for cmd switchport mode trunk, cmd pseq 357 seq 367

Mon Jul  1 06:13:11.884811  (CSM_ERR) csm_pss_cmd_tree_walk_cb(2057): Parent command not found for cmd description process_vpc, cmd pseq 357 seq 366

Mon Jul  1 06:13:11.884750  (CSM_ERR) csm_pss_cmd_tree_walk_cb(2057): Parent command not found for cmd channel-group 51 mode active, cmd pseq 352 seq 365

Mon Jul  1 06:13:11.884690  (CSM_ERR) csm_pss_cmd_tree_walk_cb(2057): Parent command not found for cmd switchport trunk allowed vlan 2, 11, cmd pseq 352 seq 364

Mon Jul  1 06:13:11.884630  (CSM_ERR) csm_pss_cmd_tree_walk_cb(2057): Parent command not found for cmd switchport mode trunk, cmd pseq 352 seq 363

Mon Jul  1 06:13:11.884568  (CSM_ERR) csm_pss_cmd_tree_walk_cb(2057): Parent command not found for cmd description process_vpc, cmd pseq 352 seq 362

Mon Jul  1 06:13:11.884207  (CSM_EV) csm_sp_acfg_gen_handler(3011):  Preparing config into /tmp/csm_sp_acfg_1733916569.txt

Mon Jul  1 06:13:11.878695  csm_get_locked_ssn_ctxt[539]: Lock not yet taken.

Mon Jul  1 06:13:11.878638  (CSM_EV) csm_sp_acfg_gen_handler(2937): Recieved sp acfg merge request for type: running cfg

Mon Jul  1 06:12:29.527840  (CSM_T) csm_pss_del_seq_tbl(1989): Freeing seq tbl data

Mon Jul  1 06:12:29.513255  (CSM_T) csm_sp_acfg_gen_handler(3106): Done acfg file write

Mon Jul  1 06:12:29.513179  (CSM_EV) csm_sp_acfg_gen_handler(3011):  Preparing config into /tmp/csm_sp_acfg_1733911262.txt

Mon Jul  1 06:12:29.508859  csm_get_locked_ssn_ctxt[539]: Lock not yet taken.

Mon Jul  1 06:12:29.508803  (CSM_EV) csm_sp_acfg_gen_handler(2937): Recieved sp acfg merge request for type: running cfg

Mon Jul  1 05:53:17.651236  Collecting peer info

Mon Jul  1 05:53:17.651181  Failed to get the argumentvalue for 'ip-address'

Mon Jul  1 05:40:59.262736  DB Unlocked Successfully

Mon Jul  1 05:40:59.262654  Unlocking DB, Lock Owner Details:Client:1 ID:1

Mon Jul  1 05:40:59.262570  (CSM_T) csm_sp_del_buf_cmd(1713): Deleting comand with Id = 1

Mon Jul  1 05:40:59.262513  DB Lock Successful by Client:1 ID:1

Mon Jul  1 05:40:59.262435  Recieved lock request by Client:1 ID:1

Mon Jul  1 05:40:41.741224  ssnmgr_ssn_handle_create_get: Session FSM already present, ID:1

Mon Jul  1 05:40:41.741167  ssnmgr_handle_mgmt_request: Create/Get request received for session[process_n5kprof]

show cfs lock gives no output.

Just to further clarify, we have 4 5548UP switches in the same management vlan. 2 switches are in one location lets say location A and they are CFS peers and are working fine.

These two switches which are having problem are in location B. All the switches are in the same vlan. Essentially the all CFS multicast messages will be seen by all 5548 switches as they are in the same vlan. I am assuming that this might not create any problems as we specify the peers in the respective configurations. Or do we have to change the CFSoIPv4 multicast addresses in location B or may be configure a different region.

Regards.

Cisco Employee

Ask the Expert: Cisco Nexus 2000 and 5000

Thanks, will analyze this and get back to you. In the meantime can you also paste output of

'show switch-profile status'

after you make the change and send it to me?

Thanks, Vinayak

New Member

Ask the Expert: Cisco Nexus 2000 and 5000

Hi Vinayak,

Switch 1 in whcih show cfs peers are showing

Profile-Revision: 85

Session-type: Commit

Session-subtype: -

Peer-triggered: No

Profile-status: Sync Success

Local information:

----------------

Status: Commit Success

Error(s):

Peer information:

----------------

IP-address: 172.16.1.54

Sync-status: Not yet merged

Merge Flags: pending_merge:1 rcv_merge:1 pend_validate:0

Status: Peer not reachable

Error(s):

Profile-Revision: 75

Session-type: Initial-Exchange

Session-subtype: Init-Exchange-All

Peer-triggered: No

Profile-status: -

Switch 2 in which show cfs peers are not shown

I tried a copy run start in the switch 2 but it got stuck and following output taken after that.

Local information:

----------------

Status: Verify Failure

Error(s): CFS send failure: [Failure: Lock failed]

Peer information:

----------------

IP-address: 172.16.1.53

Sync-status: Not yet merged

Merge Flags: pending_merge:1 rcv_merge:1 pend_validate:0

Status: -

Error(s):

Regards

Cisco Employee

Ask the Expert: Cisco Nexus 2000 and 5000

Sonu

1) Do you have a large number of switches on the mgmt network ?

2) Have you used cfs ipv4 mcast-address config on the peer switches

Multicast address configuration will help in making sure only the 2 peer switches are in the CFS domain for config-sync.

http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/configuration/guide/cli/cfs.html

3) Can you remove "cfs ipv4 distribute" config and re-config on the switch where the peer is not seen and check if this helps to resolve the issue?

Thanks, Vinayak

New Member

Ask the Expert: Cisco Nexus 2000 and 5000

Hi Vinayak,

I am refering to the thread:https://supportforums.cisco.com/message/3980732#3980732.

Question:

I am planning an ISSU upgrade on my nexus 7000. On this chassis there are also Nexus 2000 connected. Since they don't support vpc, all fexes are connected to a single chassis. (but different card).

The chassis will upgrade without interruption, but what about the fexes? They will also need  the new NX-OS. Do they reboot after or during the upgrade? Or is it without interruption like the 7000 chassis?

Kindly let me know your opinion on this pleasE/

Thanks,

Fari.

Cisco Employee

Ask the Expert: Cisco Nexus 2000 and 5000

Hi Fari

If the 7k chassis support ISSU, then we should be able to do hitless upgrade on the 2k as well. During ISSU it should not reload your fexes.

Thanks, Vinayak

New Member

Re: Ask the Expert: Cisco Nexus 2000, 5000, and 6000 Series Swit

Hi Vinayak,

If I have the following configuration on the router at the moment, how do you migrate the configuration to the nexus 5000?

int vlan 10

ip address 172.31.10.3 255.255.255.0

int vlan 20

ip address 172.31.20.3 255.255.255.0

int vlan 30

ip address 10.10.30.3 255.255.255.0

router rip

version 2

passive-interface default

no passive-interface vlan20

network 10.0.0.0

network 172.31.0.0

no auto-summary

redistribute static route-map test

route-map test permit 10

match ip address 10

ip access-list 10

permit 0.0.0.0

deny any

TIA

PF

Cisco Employee

Ask the Expert: Cisco Nexus 2000, 5000, and 6000 Series Switches

Hi PF

You should definitely go through our Nexus 5000 Unicast Configuration Guide on Cisco.com as it will assist you in understanding how to configure RIP on Nexus switch and how to configure for route redistribution. Also for Route-Maps we have "Configuring Route Policy Manager" guide which can assist you in configuring for Route-Maps.

"Configuring RIP"

http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/unicast/521_N11/l3_rip.html

"Configuring Route Policy Manager"

http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/unicast/521_N11/l3_rpm.html

New Member

Ask the Expert: Cisco Nexus 2000, 5000, and 6000 Series Switches

Vinayak,

Thanks very much.  The link provides you with the pieces of config for the RIP.  What I need is an example of the RIP configuration by putting the required commands together for a working RIP.  If I have the following configuration below how is that being achieved?  An example will gives a better understanding of the RIP configuration on the Nexus and helps to consolidate the information/understanding I have.

TIA

PF

I also have a ethernet link between 2 data centres.  For example

Config for DC  B

int gi1/1

desc link to DC A

switchport access vlan 10

int vlan 10

ip address 172.31.10.3 255.255.255.0

int vlan 20

ip address 172.31.20.3 255.255.255.0

int vlan 30

ip address 10.10.30.3 255.255.255.0

router rip

version 2

passive-interface default

no passive-interface vlan20

network 10.0.0.0

network 172.31.0.0

no auto-summary

redistribute static route-map test

route-map test permit 10

match ip address 10

ip access-list 10

permit 0.0.0.0

deny any

Cisco Employee

Ask the Expert: Cisco Nexus 2000, 5000, and 6000 Series Switches

Ok I can assist you with building an RIP example config based on what you already have.

The document I provided before would have helped you gather the below information which would have been useful to build a configuration which I pasted below.

- passive interface command is configured under vlan SVI.

- no support for automatic route summarization.

- no network statements definition under router rip.

- redistribute and route-map commands are similar.

Based on the above, following is the config.

int e1/1

desc link to DC A

switchport access vlan 10

feature rip

feature interface-vlan

int vlan 10

ip address 172.31.10.3 255.255.255.0

ip rip passive-interface

int vlan 20

ip address 172.31.20.3 255.255.255.0

int vlan 30

ip address 10.10.30.3 255.255.255.0

ip rip passive-interface

router rip abc

address-family ipv4 unicast

redistribute static route-map test

route-map test permit 10

match ip address 10

ip access-list 10

permit ip any any

You can configure similarly for other site.

Hope this helps,

Thanks,

Vinayak

New Member

Re: Ask the Expert: Cisco Nexus 2000, 5000, and 6000 Series Swit

Vinayak,

Thanks so much for your reply.  It is very much appreciated.

2 more questions.

1.  Don't you need " ip router ip abc" defined on the interface?  For exmaple

int vlan 10

  ip address 172.31.10.3 255.255.255.0

  ip rip passive-interface

  ip router rip abc <-- ???

int vlan 20

...

ip router rip abc

2.  If the  Nexus 5500 and 2000 are used (no other switches), 5500 as core switches,  can I joint the 2 mgmt 0 interfaces on both the 5500 (peer switches)  together?

Thanks again.

PF

Cisco Employee

Ask the Expert: Cisco Nexus 2000, 5000, and 6000 Series Switches

PF

1. yes you are right. I had put the configs on my lab switch but then modified to customize your config and pasted it but somehow missed putting that command when I copied the config over, sorry about that.  Yes you need that command as well on the vlan SVI. Without that neighbor RIP neighbors will not establish and come up.

2. You can connect the two mgmt ports together as vpc peer keepalive for L2, sure. Are you referring to more in relation to running RIP on mgmt ports ? If so, we dont run any routing protocols on mgmt ports. They are just used for out of band connectivity and as vpc peer keepalives for L2.

Thanks, Vinayak

New Member

Re: Ask the Expert: Cisco Nexus 2000, 5000, and 6000 Series Swit

Hi Vinayak,

I am planning a Nexus 5k upgrade (5548) and plan to move from our current  NX_OS n5000-uk9.5.0.3.N2.1to

5.2.1.N1.3.

There is an alternate option of 5.1(3)N2(1c).

Is there any reason why I should choose one of these options over another. I  have examined all the documantation I can find and can see no reason not to move  to the 5.2.1x release, is this a sensible course from 5.0.3.N2.1.

Are there any issues with the 5.2 release train when compared to upgrading to  the 5.1 release.

Any advice and guidance would be very much appreciated.

New Member

Ask the Expert: Cisco Nexus 2000, 5000, and 6000 Series Switches

Hello Vinayak,

How can i configure in N5K - NX-OS ?

- Managment ACL which is applied on VTY terminal

- TACACS+ configuration

Regards

Cisco Employee

Ask the Expert: Cisco Nexus 2000, 5000, and 6000 Series Switches

Hi Dipesh

Please check below links for more detailed information about the features you are asking to be configured on the Nexus 5000 switches.

Configuring ACLs on Virtual Terminal Lines:

http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/security/521_n1_1/b_5k_Security_Config_521N11_chapter_01000.html#task_13C252852D97472F8185DAD714EECB70

Configuring TACACS:

http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/security/521_n1_1/b_5k_Security_Config_521N11_chapter_0101.html

Thanks, Vinayak

Cisco Employee

Ask the Expert: Cisco Nexus 2000, 5000, and 6000 Series Switches

Hi Steve

I agree with you. 5.2 is our long lived release compared to 5.1. So if you are planning to upgrade, 5.2 would be a better option. Besides that, please check the Caveats section of both 5.1 and 5.2 release notes for open and closed caveats and check if any of them might be impacting to the switch that way you can make a better determination wrt which release you can prefer to go to.

Nexus 5000 Release note documentation:

http://www.cisco.com/en/US/products/ps9670/prod_release_notes_list.html

Our Recommended release in 5.2 is 5.2(1)N1(4)

http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/release/recommended_releases/recommended_nx-os_releases.html

If the switch qualifies for ISSU you can upgrade from 5.0(3)N2(1) to 5.2(1)N1(4) without upgrading to intermediate release.

I would definitely suggest checking the Caveats Section for 5.2(1)N1(4) located at:

http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/release/notes/Rel_5_2_1_N1_1/Nexus5000_Release_Notes_5_2_1_N1.html#wp347580

before you upgrade to new release.

Thanks, Vinayak

New Member

Ask the Expert: Cisco Nexus 2000, 5000, and 6000 Series Switches

Thanks Vinayak,

I have read all the docs and I think all wil be OK. Although unfortunatley we can't perform ISSU, due to our spanning tree config.

I am looking into a couple of the Caveats, Our main reason for going for the.3 build not the .4 is that our policy is for releases to have been out 6 months before we role them into any implemenation scheme.

if a caveat is closed in a build, does that mean it is a recognised issue in the previous release.

e.g.

CSCud05886

System restarted due to HA Reset policy.

which is fixed in .4 would this therefore be a problem with .3

Thanks

Steve

Cisco Employee

Ask the Expert: Cisco Nexus 2000, 5000, and 6000 Series Switches

Steve

Yes you can say so. The caveat would be considered as open in earlier release 5.2(1)N1(3). This caveat also impacts earlier 6.0 builds.

Thanks, Vinayak

New Member

Ask the Expert: Cisco Nexus 2000, 5000, and 6000 Series Switches

Thanks Vinayak,

Your info has been very useful. I will take a clos look at the Caveats.

Steve

New Member

Ask the Expert: Cisco Nexus 2000, 5000, and 6000 Series Switches

Dear Vinayak

does Cisco have any switch or ethernet modules with 40G speed over copper??I know nexuse switches have 40G over fiber optic how about 40G over copper?does Cisco have any product which has this feature?

Regards

Cisco Employee

Ask the Expert: Cisco Nexus 2000, 5000, and 6000 Series Switches

Hello

Our Nexus 6000 Switches offer 40gig Copper capability.

Please check Nexus 6001 and 6004 Data Sheets available at:

http://www.cisco.com/en/US/prod/collateral/switches/ps9441/ps12806/ps12807/data_sheet_c78-723667.html

Table 1 - Transceiver Support Matrix

http://www.cisco.com/en/US/prod/collateral/switches/ps9441/ps12806/ps12869/data_sheet_c78-726128.html

Table 2 - Transceiver Support Matrix

Thanks, Vinayak

New Member

Ask the Expert: Cisco Nexus 2000, 5000, and 6000 Series Switches

thank you so much for your reply

do you mean:

QSFP Direct-Attach 40 Gigabit Ethernet Copper for In-Rack Cabling???

Actually our structured cabling is based on Nexans Cat7A with GG45 connectors.Does Cisco have any switch which support 40G copper and compatible with Nexans GG45 connecors?

Cisco Employee

Ask the Expert: Cisco Nexus 2000, 5000, and 6000 Series Switches

As I mentioned before we have switches like Nexus 6k which support 40gig environments. You can initiate a request both with Cisco and Nexan Account teams for that, if you have an Account rep like a Cisco Systems Engineer or Advance Services Engineer and do the same with Nexan Product teams. They would be responsible for certifying the products to make sure they work with each other before you deploy them, provided you have that service. This might not be the best forum to initiate a request for something what you are looking for.

Thanks, Vinayak

New Member

Re: Ask the Expert: Cisco Nexus 2000, 5000, and 6000 Series Swit

Hello Vinayak,

Does a fex connected to a 5K support etherchannel on the host interfaces. I can see that this is possible on a fex connected to the 7K but I have not seen anything authoritative to say that configuration is not supported on a 5K. However when I try to add a second host interface into an etherchannel, I get an error message that says it is not possible

Ask the Expert: Cisco Nexus 2000, 5000, and 6000 Series Switches

Hi Bashir,

Assuming by etherchannel you are referring to virtual Port-Channel (vPC) then the answer will depend on the model of Nexus 5K and how the FEX are connected.

If you have Nexus 5010 or 5020 then you can only use port-channel on the host interfaces if the FEX are single homed i.e., only connected to one parent Nexus 5K. If the FEX are dual-homed then vPC is not supported on the FEX host interfaces.

If you have Nexus 5548 or 5596 then you can use use port-channel on the host interfaces if the FEX are single-homed or dual-homed, provided that you are running an NX-OS release 5.1(3)N1 or later. This release added Enhanced vPC which provides support for vPC on host interfaces when the FEX are also dual-homed.

An excellent reference for this is the Topology Choices for Connecting Cisco Nexus 5000 and 2000 Series section on page 75 of the Data Center Access Design with Cisco Nexus 5000 Series Switches and 2000 Series Fabric Extenders and Virtual PortChannels Design Guide.

Regards

New Member

Re: Ask the Expert: Cisco Nexus 2000, 5000, and 6000 Series Swit

Hello Steve,

Thanks for your response.

7122
Views
15
Helpful
41
Replies