Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Nexus 5000 NXOS downgrade

Hi,

I need to downgrade a Nexus 5548UP from 5.1.3 to 5.0.3.

When performing the incompatibility check, it fails on the running config saying SCP--SERVER is enabled - strict failure.

I haven't got this feature specified and it doesn't show up on a show feature command. The recommended course of action is 'no feature scp-server' which is an invalid command

Does anyone know a way around this?

Thanks

Everyone's tags (5)
8 REPLIES
Cisco Employee

Nexus 5000 NXOS downgrade

can you paste the command alongwith the exact output as well as attach 'show run' from the switch ?

Vin.

Community Member

Nexus 5000 NXOS downgrade

can't paste config but :

xxxxxxx# sh incompatibility system bootflash:n5000-uk9.5.0.3.N1.1c.bin

The following configurations on active are incompatible with  the system image

1) Service : securityd , Capability : CAP_FEATURE_SECURITY_SCP_SERVER

Description : SCP Server is enabled.

Capability requirement : STRICT

Disable command : no feature scp-server

xxxxxxxxx# sh feature

Feature Name          Instance  State 

--------------------  --------  --------

Flexlink              1         disabled

amt                   1         disabled

bgp                   1         disabled

cts                   1         disabled

dhcp                  1         disabled

dot1x                 1         disabled

eigrp                 1         disabled

eigrp                 2         disabled

eigrp                 3         disabled

eigrp                 4         disabled

eth_port_sec          1         disabled

fcoe                  1         disabled

fcoe-npv              1         disabled

fex                   1         enabled

glbp                  1         disabled

hsrp_engine           1         disabled

http-server           1         disabled

interface-vlan        1         enabled

lacp                  1         enabled

ldap                  1         disabled

lldp                  1         enabled

msdp                  1         disabled

ospf                  1         disabled

ospf                  2         disabled

ospf                  3         disabled

ospf                  4         disabled

pim                   1         disabled

poe                   1         disabled

private-vlan          1         disabled

privilege             1         disabled

ptp                   1         disabled

rip                   1         disabled

rip                   2         disabled

rip                   3         disabled

rip                   4         disabled

sshServer             1         enabled

tacacs                1         enabled

telnetServer          1         disabled

udld                  1         enabled

vem                   1         disabled

vmfex                 1         disabled

vpc                   1         enabled

vrrp                  1         disabled

vtp                   1         disabled

xxxxxxxxx(config)# no feature scp-server

                                   ^

% Invalid command at '^' marker.

xxxxxxxxx(config)#

Cisco Employee

Nexus 5000 NXOS downgrade

We are investigating this further.. sounds buggy in nature ...I am trying to reproduce on my switch but cant so far, I assume you ran the command, show install all impact system bootflash:n5000-uk9.5.0.3.N1.1c.bin kickstart bootflash:n5000-uk9-kickstart.5.0.3.N1.1c.bin and it gives you a reason for not being able to downgrade because of this compatibility, correct? if you want to downgrade, for now you can change the boot variables to point to the old image, save config and reload. we dont prefer downgrading this way, but thats the only option ...

Vin.

Community Member

Nexus 5000 NXOS downgrade

Hi Vin,

you're correct, we had the following returned:

xxxxxxxxxxxxxx# show install all impact kickstart bootflash:n5000-uk9-kickstart.5.0.3.N1.1c.bin system bootflash:n5000-uk9.5.0.3.N1.1c.bin

Verifying image bootflash:/n5000-uk9-kickstart.5.0.3.N1.1c.bin for boot variable "kickstart".

[####################] 100% -- SUCCESS

Verifying image bootflash:/n5000-uk9.5.0.3.N1.1c.bin for boot variable "system".

[####################] 100% -- SUCCESS

Verifying image type.

[###########         ]  50%

[####################] 100% -- SUCCESS

Extracting "system" version from image bootflash:/n5000-uk9.5.0.3.N1.1c.bin.

[####################] 100% -- SUCCESS

Extracting "kickstart" version from image bootflash:/n5000-uk9-kickstart.5.0.3.N1.1c.bin.

[####################] 100% -- SUCCESS

Extracting "bios" version from image bootflash:/n5000-uk9.5.0.3.N1.1c.bin.

[####################] 100% -- SUCCESS

Extracting "fexth" version from image bootflash:/n5000-uk9.5.0.3.N1.1c.bin.

[####################] 100% -- SUCCESS

"Running-config contains configuration that is incompatible with the new image (strict incompatibility).

Please run 'show incompatibility system ' command to find out which feature needs to be disabled.".

[#                   ]   0% -- FAIL. Return code 0x40930029 (Current running-config is not supported by new image).

Pre-Upgrade check failed. Return code 0x40930029 (Current running-config is not supported by new image).

Cisco Employee

Nexus 5000 NXOS downgrade

Stephen, can you please open a TAC Case on this? Let me know when you open one. We would like to get some more logs from the switch ?

Thanks,

Vinayak.

Community Member

Nexus 5000 NXOS downgrade

Hi Vinayak,

the company I'm working for has raised a TAC Case already, that is being investigated.

I don't know the reference, sorry.

Cisco Employee

Nexus 5000 NXOS downgrade

if you can find out the tac case no and give it to me, that would be great. - Vin.

Cisco Employee

Re: Nexus 5000 NXOS downgrade

2026
Views
0
Helpful
8
Replies
CreatePlease to create content