Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Nexus 7009 N7K-SUP2 Downgrade Issue

Hi Folks,

I  am getting below error when I am trying to downgrade my Nexus 7009  switches from image 6.2.2a to 6.1.4a or 6.1.2. The reason I want to  downgrade them because I have Fabric Extender Cisco Nexus 2248TP which  can not work on Image 6.2.2a as per release note of 6.2 (

http://www.cisco.com/en/US/docs/switches/datacenter/sw/6_x/nx-os/release/notes/62_nx-os_release_note.html#wp578652).

CS7009-A# install all kickstart bootflash:///n7000-s2-kickstart-npe.6.1.4a.bin system bootflash:///n7000-s2-dk9-npe.6.1.4a.bin

Installer will perform compatibility check first. Please wait.

Verifying image bootflash:/n7000-s2-kickstart-npe.6.1.4a.bin for boot variable "kickstart".

[####################] 100% -- SUCCESS

Verifying image bootflash:/n7000-s2-dk9-npe.6.1.4a.bin for boot variable "system".

[#                   ]   0% -- FAIL.

Return code 0x40930077 (Install is not supported between NPE and non-NPE system image).

Pre-upgrade check failed. Return code 0x40930011 (Image verification failed).

----------------------------------------------------------------------------------------------------------------------------------

CS7009-A# install all kickstart bootflash:///n7000-s2-kickstart-npe.6.1.2.bin system bootflash:///n7000-s2-dk9-npe.6.1.2.bin

Installer will perform compatibility check first. Please wait.

Verifying image bootflash:/n7000-s2-kickstart-npe.6.1.2.bin for boot variable "kickstart".

[####################] 100% -- SUCCESS

Verifying image bootflash:/n7000-s2-dk9-npe.6.1.2.bin for boot variable "system".

[#                   ]   0% -- FAIL.

Return code 0x40930077 (Install is not supported between NPE and non-NPE system image).

Pre-upgrade check failed. Return code 0x40930011 (Image verification failed).

--------------------------------------------------------------------------------------------------------------------------------

Output of show dir bootflash:

ADM-G-CS7009-A# dir bootflash:

          0    Jun 18 16:37:47 2013  20130618_163747_poap_6057_init.log

       1492    Jun 18 23:22:08 2013  20130618_232128_poap_5934_init.log

          0    Oct 21 19:18:37 2013  20131021_191837_poap_5934_init.log

          0    Oct 22 13:41:24 2013  20131022_134124_poap_5934_init.log

          0    Oct 22 13:48:14 2013  20131022_134814_poap_5927_init.log

          0    Oct 22 15:21:19 2013  20131022_152119_poap_5934_init.log

          0    Oct 22 15:27:36 2013  20131022_152736_poap_5927_init.log

          0    Oct 22 15:53:04 2013  20131022_155304_poap_5934_init.log

        281    Jun 18 16:05:41 2013  JAF1712ARAC_11772274.lic

        414    Oct 22 15:00:08 2013  de

  218195278    Jun 18 16:05:30 2013  n7000-s2-dk9-npe.6.1.2.bin

  219109890    Oct 23 18:10:01 2013  n7000-s2-dk9-npe.6.1.4a.bin

  378629008    Oct 22 18:01:01 2013  n7000-s2-dk9-npe.6.2.2a.bin

   36344320    Jun 18 16:04:05 2013  n7000-s2-kickstart-npe.6.1.2.bin

   36353024    Oct 23 18:10:27 2013  n7000-s2-kickstart-npe.6.1.4a.bin

   37094912    Oct 22 18:01:49 2013  n7000-s2-kickstart-npe.6.2.2a.bin

       4096    Jun 18 16:37:14 2013  scripts/

       4096    Jun 18 16:36:38 2013  vdc_2/

       4096    Jun 18 16:36:38 2013  vdc_3/

       4096    Jun 18 16:36:38 2013  vdc_4/

       4096    Jun 18 16:36:38 2013  vdc_5/

        664    Oct 23 12:39:38 2013  vlan.dat

Please help.

Thanks

1 REPLY

Re: Nexus 7009 N7K-SUP2 Downgrade Issue

Hi,

I think you've misunderstood the release note. The reference you've provided is for new FEX that are supported from NX-OS 6.2, and not a list of all the FEX supported in this release.

The list of all FEX supported is shown in Table 3 FEX Modules Supported by Cisco Nexus 7000 Series Modules

If this is the only reason you're downgrading the NX-OS version then there should be no need to do so.

Regrds

1553
Views
0
Helpful
1
Replies
CreatePlease to create content