Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Nexus 7010 SVI down

Hi,

I have a Nexus 7010 running version 5.0(3).  I was testing its features and noticed that a SVI for a vlan is not "up" unless there is a node in the vlan.  There isn't any nondefault VDC (not licensed for it) and the VRF is 'default'.  The SVI looks like this:

interface Vlan77
  no shutdown
  ip address 192.168.169.1/24

Of course the vlan exists.  If this were IOS, you would be able to ping 192.168.169.1, but this isn't IOS.

When I drop a node in vlan 77, then you can ping the node and the SVI.

I looked at the Cisco documentation but couldn't find anything mentioning this.  I'm not sure if this good or bad, it is different and I am accustomed to just pinging a gateway SVI to see if a subnet should be up or not (without regards to weather or not there are nodes in the subnet).

So my question is: am I missing something, or is this just how it is and I need to get use to it?

Thanks,

Mike

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Nexus 7010 SVI down

firemtngems wrote:

Hi Atif,

Thanks for the reply, I'll check out autostate.  The behavior I described can be seen on 4500s and 3750s, so I guess ymmv.

Cheers,

Mike

Hello Mike,

I believe 3750s and 4500s should exhibit the same behavior. Are you sure you did not have any ports (access or trunk) active when you verified the SVI state? Also there is an autostate exclude feature which allows you to selectively disable the autostate functionality for desired VLANs.

Atif

4 REPLIES
Cisco Employee

Re: Nexus 7010 SVI down

firemtngems wrote:

Hi,

I have a Nexus 7010 running version 5.0(3).  I was testing its features and noticed that a SVI for a vlan is not "up" unless there is a node in the vlan.  There isn't any nondefault VDC (not licensed for it) and the VRF is 'default'.  The SVI looks like this:

interface Vlan77
  no shutdown
  ip address 192.168.169.1/24

Of course the vlan exists.  If this were IOS, you would be able to ping 192.168.169.1, but this isn't IOS.

When I drop a node in vlan 77, then you can ping the node and the SVI.

I looked at the Cisco documentation but couldn't find anything mentioning this.  I'm not sure if this good or bad, it is different and I am accustomed to just pinging a gateway SVI to see if a subnet should be up or not (without regards to weather or not there are nodes in the subnet).

So my question is: am I missing something, or is this just how it is and I need to get use to it?

Thanks,

Mike

Mike,

Which IOS device have you worked with that brought the SVI up without an active port (access or trunk) being part of the VLAN? Based on my experience with IOS (primarily 6500s) this behavior is expected and is referred to as autostate. It can , however, be disabled if required in IOS. My assumption is that it works along similar lines in NXOS, however, I am not sure if there is a way to disable it or not yet in NXOS.

Atif

Community Member

Re: Nexus 7010 SVI down

Hi Atif,

Thanks for the reply, I'll check out autostate.  The behavior I described can be seen on 4500s and 3750s, so I guess ymmv.

Cheers,

Mike

Cisco Employee

Re: Nexus 7010 SVI down

firemtngems wrote:

Hi Atif,

Thanks for the reply, I'll check out autostate.  The behavior I described can be seen on 4500s and 3750s, so I guess ymmv.

Cheers,

Mike

Hello Mike,

I believe 3750s and 4500s should exhibit the same behavior. Are you sure you did not have any ports (access or trunk) active when you verified the SVI state? Also there is an autostate exclude feature which allows you to selectively disable the autostate functionality for desired VLANs.

Atif

Community Member

Re: Nexus 7010 SVI down

Hi Atif,

I read up on the topic.  I'm pretty sure there would have been active trunks when I created the SVIs.  I'll file this under the 'learn something new every day' category.

Thanks,

Mike

2071
Views
0
Helpful
4
Replies
CreatePlease to create content